Subject: Re: [Codestand-develop] [ietfdb] #2295 (doc/): logins fail

From: Christian O'Flaherty <[email-masked]>
Date: Mon, 8 May 2017 15:34:49 -0300

Hi Henrik, Robert,  thanks for the email. 

Matheus has been working on this problem and he can’t diagnose it. I’m including him in this email.

Is there a way to troubleshoot it from the server side? 
Apparently it started when he upgraded Datatracker. 

Christian O'Flaherty  [email-masked] <mailto:[email-masked]>
Regional Development - Internet Society 
Skype/Gmail/Yahoo!:  christian.oflaherty 
Mobile/WhatsApp: +598 98769636

> On 8 May 2017, at 14:15, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> 
> -------- Forwarded Message --------
> Subject:	[ietfdb] #2295 (doc/): logins fail
> Date:	Mon, 08 May 2017 16:14:51 -0000
> From:	ietfdb issue tracker <[email-masked]> <mailto:[email-masked]>
> To:	[email-masked] <mailto:[email-masked]>
> CC:	[email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> 
> #2295: logins fail
> 
>  I can no longer (tried 2017-05-08, 11:30am-ish) login to codestand with my
>  datatracker ID.
>  My DT login works fine.
> 
> -- 
> ------------------------------+--------------------
>  Reporter:  [email-masked] <mailto:[email-masked]>  |      Owner:
>      Type:  defect            |     Status:  new
>  Priority:  n/a               |  Milestone:  (None)
> Component:  doc/              |    Version:  6.x.x
>  Keywords:                    |
> ------------------------------+--------------------
> 
> Ticket URL: <https://tools.ietf.org/tools/ietfdb/ticket/2295> <https://tools.ietf.org/tools/ietfdb/ticket/2295>
> ietfdb <https://tools.ietf.org/tools/ietfdb/> <https://tools.ietf.org/tools/ietfdb/>
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 8 May 2017 17:13:23 -0500

I don't think there's anything serverside we can do to help, but perhaps 
a checking a couple of things on your deployment will tease out what's 
going on.

What do you get when you run something similar to this?

$ ietf/manage.py shell
Python 2.7.13 (default, Apr 23 2017, 16:50:35)
Type "copyright", "credits" or "license" for more information.

IPython 5.3.0 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.

In [1]: import django

In [2]: django.__version__
Out[2]: '1.10.7'

(you may not have ipython installed, so the prompts might look different)

In [3]: from ietf.person.models import User

In [4]: User.objects.get(username=[email-masked]').password
Out[4]: u'crypt$$oaK9wnkFgkG5c'

(You should get something else there, since that's from my development 
database where my password is 'password'. It doesn't matter what you get 
as long as you get _something_).

On 5/8/17 1:34 PM, Christian O'Flaherty wrote:
>> On 8 May 2017, at 14:15, Robert Sparks <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
>>
>>
>> From: 	ietfdb issue tracker <[email-masked]>
>> To: 	[email-masked]
>> CC: 	[email-masked], [email-masked]
>>
>>
>>
>> #2295: logins fail
>>
>>   Reporter:[email-masked]   |      Owner:
>> Ticket URL:<https://tools.ietf.org/tools/ietfdb/ticket/2295>
>> ietfdb<https://tools.ietf.org/tools/ietfdb/>
>>
>

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 10 May 2017 13:13:30 -0300

Olá Matheus, 

Pudo hacer la prueba que pide Robert?

> On 8 May 2017, at 19:13, Robert Sparks <[email-masked]> wrote:
> 
> I don't think there's anything serverside we can do to help, but perhaps a checking a couple of things on your deployment will tease out what's going on.
> 
> In [4]: User.objects.get(username=[email-masked] <mailto:[email-masked]>').password
> (You should get something else there, since that's from my development database where my password is 'password'. It doesn't matter what you get as long as you get _something_).
> 
> 
>>> On 8 May 2017, at 14:15, Robert Sparks <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>> 
>>>

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 10 May 2017 14:17:37 -0300

Hi Robert, 

I’m reporting back the output Matheus has just sent:

In [1]: import django

In [2]: django.__version__
1.8.10
In [3]: from ietf.person.models import User
In [4]: User.objects.get(username=[email-masked] <mailto:[email-masked]>').password
argon2$argon2i$v=19$m=512,t=2,p=2$aTlZTnVYRTFFZjhM$Fd/KdcAzRhW4Zu+8xAfYP

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 May 2017 13:19:35 -0500

I thought that might be the case. I would expect all manner of subtle failures running on Django 1.8 and I'm a little surprised you don't have less than subtle failures. You really need to port forward to a current release of the datatracker code and move your own code to 1.10 as well. 

Sent from my iPhone

> On May 10, 2017, at 12:17 PM, Christian O'Flaherty <[email-masked]> wrote:
> 
> Hi Robert, 
> 
> Christian O'Flaherty  [email-masked]
>>> Christian O'Flaherty  [email-masked]
>>>>  Reporter:  [email-masked]  |      Owner:
>>>> Ticket URL: <https://tools.ietf.org/tools/ietfdb/ticket/2295>
>>>> ietfdb <https://tools.ietf.org/tools/ietfdb/>
>>>> 
>>> 
>> 
>

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 10 May 2017 15:42:42 -0300

Thanks Robert, 

> I thought that might be the case. I would expect all manner of subtle failures running on Django 1.8 and I'm a little surprised you don't have less than subtle failures.

It started behaving strangely when we were in Chicago… I think Matheus did a Datatracker upgrade just before the meeting. 

> You really need to port forward to a current release of the datatracker code and move your own code to 1.10 as well. 

OK.
Matheus, can we do that? I can help you if you want. 

Christian

> 
> Sent from my iPhone
> 
> On May 10, 2017, at 12:17 PM, Christian O'Flaherty <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Robert, 
>> 
>>> On 8 May 2017, at 19:13, Robert Sparks <[email-masked] <mailto:[email-masked]>> wrote:
>>>

---

From: Christian O'Flaherty <[email-masked]>
Date: Tue, 16 May 2017 12:22:24 -0300

Hi Robert,

You were right about the Datatracker and Django versions. 
Matheus upgraded both and now the login is stable again. 

He’s now fixing some issues that came up after the upgrade. 
You will probably receive additional tickets… please forward them all.  

Thanks!

> On 10 May 2017, at 15:42, Christian O'Flaherty <[email-masked]> wrote:
> 
> Thanks Robert, 
>