Subject: [Codestand-develop] Fwd: IETF CodeStand on revamped website

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 15 Feb 2017 11:47:34 -0300

Hi team, 

Find below an email from Greg Wood who is working with others in the updated IETF site.

We can include a section in “How We Work” -> “Running Code” -> “Codestand"

He has already suggested some text (included below) and he has a couple of asks...

Christian O'Flaherty  [email-masked] <mailto:[email-masked]>
Regional Development - Internet Society 
Skype/Gmail/Yahoo!:  christian.oflaherty 
Mobile/WhatsApp: +598 98769636

> Begin forwarded message:
> 
> From: Greg Wood <[email-masked]>
> Subject: Re: IETF CodeStand on revamped website
> Date: February 15, 2017 at 8:47:21 AM GMT-3
> To: Christian O'Flaherty <[email-masked]>
> 
> Hi Christian,
> 
> I can’t join the call today, but the article text is very helpful. Here’s some text I’d propose.
> 
> 
> CodeStand connects the IETF standards process with open source and proprietary software. Authors of IETF Documents benefit from knowing about implementations of their proposals and developers can receive support from experienced working group participants and IETF document authors) while they are creating code based on a IETF proposals. 
> 
> CodeStand showcases opportunities to develop running code for IETF protocols that can benefit students in a class or researchers in projects, lowering barriers to IETF participation. When developers have questions, they may suggest changes to IETF documents to improve accuracy and interoperability for future implementations.
> 
> 
> The CodeStand team will definitely have a chance to test drive a live version of the revamped website before it goes to production, but for the moment, it would be helpful to know from the team if there is:
> 
> - a particular “call to action” (i.e. link to go somewhere else on the IETF website or elsewhere on the Web (perhaps visit the IETF CodeStand website!) to appear in the darker blue box at the bottom of the page, and
> 
> - a particular email list folks should sign up for (I think we discussed something like “codestand-announce’ or “codestand-discuss”)?
> 
> Thanks,
> -Greg
> 
> 
> 
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 15 Feb 2017 10:15:56 -0500

Thanks, Christian & Greg!

I have the BoF planning call today, so I may be late or wind up not being
able to join, but will do my best.

> We can include a section in “How We Work” -> “Running Code” -> “Codestand"

Very good!

> Christian O'Flaherty  [email-masked]
> Mobile/WhatsApp: +598 98769636 <+598%2098%20769%20636>
>
> Begin forwarded message:
>
> *From: *Greg Wood <[email-masked]>
> *Subject: **Re: IETF CodeStand on revamped website*
> *Date: *February 15, 2017 at 8:47:21 AM GMT-3
> *To: *Christian O'Flaherty <[email-masked]>
>
> Hi Christian,
>
> CodeStand connects the IETF standards process with open source and
> proprietary software. Authors of IETF Documents benefit from knowing about
> implementations of their proposals and developers can receive support from
> experienced working group participants and IETF document authors) while
> they are creating code based on a IETF proposals.
>
> CodeStand showcases opportunities to develop running code for IETF
> protocols that can benefit students in a class or researchers in projects,
> lowering barriers to IETF participation. When developers have questions,
> they may suggest changes to IETF documents to improve accuracy and
> interoperability for future implementations.
>
>
The text looks good to me, thanks!

>
> The CodeStand team will definitely have a chance to test drive a live
> version of the revamped website before it goes to production, but for the
> moment, it would be helpful to know from the team if there is:
>
> - a particular “call to action” (i.e. link to go somewhere else on the
> IETF website or elsewhere on the Web (perhaps visit the IETF CodeStand
> website!) to appear in the darker blue box at the bottom of the page, and
>
>
I'd say a call to action should be to populate codestand - linking drafts
to existing implementations.

>
> - a particular email list folks should sign up for (I think we discussed
> something like “codestand-announce’ or “codestand-discuss”)?
>
> Hmm, that's a good idea rather than codestand-develop.  How about
codestand-discuss?

Thanks,
Kathleen

>
> Thanks,
> -Greg
>
>
>
>
>
> _______________________________________________
> Codestand-develop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codestand-develop
>
>

-- 

Best regards,
Kathleen

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 15 Feb 2017 13:21:54 -0300

Hi Kathleen, thanks for the early notice. 

We can follow-up on email.

It looks like the article for the IETF journal is ready (putting the hackathon paragraph in a box as suggested by Toral) 

We have the slot confirmed for the lightning talk on Codestand at the tools BOF

I plan to participate in CodeSprint to update the Datatracker team about our progress and to discuss next steps (anyone can join?)

We’ll be supporting Hackthon with CodeRequests and encouraging Codestand usage among participants. Volunteers?

> On Feb 15, 2017, at 12:15 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> I have the BoF planning call today, so I may be late or wind up not being able to join, but will do my best.
> 
> On Wed, Feb 15, 2017 at 9:47 AM, Christian O'Flaherty <[email-masked] <mailto:[email-masked]>> wrote:
> Hi team, 
> 
> Mobile/WhatsApp: +598 98769636 <tel:+598%2098%20769%20636>
> 
>> Begin forwarded message:
>> 
>> From: Greg Wood <[email-masked] <mailto:[email-masked]>>
>> To: Christian O'Flaherty <[email-masked] <mailto:[email-masked]>>
>> 
>> Hi Christian,
>> 
> I'd say a call to action should be to populate codestand - linking drafts to existing implementations. 
>> 
> Hmm, that's a good idea rather than codestand-develop.  How about codestand-discuss? 
> 
> Thanks,
> Kathleen
>> 
>> Thanks,
>> -Greg
>> 
>> 
>> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/codestand-develop <https://www.ietf.org/mailman/listinfo/codestand-develop>
> 
> 
> 
> 
> -- 
> 
> Best regards,
> Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 15 Feb 2017 13:21:40 -0500

Thanks, Christian!  inline

On Wed, Feb 15, 2017 at 11:21 AM, Christian O'Flaherty
<[email-masked]> wrote:
> It looks like the article for the IETF journal is ready (putting the
> hackathon paragraph in a box as suggested by Toral)
>
> I plan to participate in CodeSprint to update the Datatracker team about our
> progress and to discuss next steps (anyone can join?)

I'll be in Chicago and can help.  I will have my son with me that day,
so I can do a block of time.  Do you want us to go around to tables or
talk at some point during the hackathon to reach all at once?
> usage among participants. Volunteers?

I can't be there for the full day, but can stop in if that's helpful.

Thanks,
Kathleen

> On Feb 15, 2017, at 12:15 PM, Kathleen Moriarty
> <[email-masked]> wrote:
>
>> experienced working group participants and IETF document authors) while they
>> are creating code based on a IETF proposals.
>>

-- 

Best regards,
Kathleen