Subject: [codesprints] New datatracker release: v5.6.4

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 13 Oct 2014 13:15:13 -0700

Hi,

This is an automatic notification about a new datatracker release, 
v5.6.4, generated when running the mkrelease script.

Release notes:

ietfdb (5.6.4) ietf; urgency=medium

  * Merged in [8359] from [email-masked]:
    fix get_or_create_nominee() to create Alias for new Person.  

  * Merged in [8156] and [8320] from [email-masked]:
    Do not allow editing or submitting new session requests when the tool 
    is locked.  Fixes Ticket #1443.

  * Merged in [8308] from [email-masked]:
    Build the links to about_url for concluded groups correctly. Fixes bug
    #1487.  

  * Merged in [8303] from [email-masked]:
    Only show comment/discuss document version on the ballot page when the
    text is for a version of the document other than the current one. Fixes
    bug #1482.  

  * Merged in [8377] from [email-masked]:
    Removes a modify-while-iterating error, and removes a bug where two
    different bits of code thought they were responsible for deleting things
    from a global list.  Fixes bug #1498.  

  * Merged in [8301] from [email-masked]:
    Changes to support consensus status.   

  * Merged in [8293] from [email-masked] (Note: Should what is now
    captured in the STATUSCHANGE_RELATIONS list instead be captured in the
    database in name_docrelationshipname? ):
    - Refactored editing the notify field to remove redundant code.
    - Changed the default notification list to include .all for documents, and
      the wg list for wg documents.
    - Allowed recalculating the notification list for all document types.
    - Improved the calculated notification list value for charters, 
      conflict-reviews, and status-changes.
    - Adds shepherds to the notification list when they are assigned to a
      document.
    - Adds the working group email list to the notification list when a
      document is adopted.
    Fixes issue #1438.

  * Merged in [8285] from [email-masked]:
    Removed templates that were no longer being used.  

  * Merged in [8271] and [8292] from [email-masked]:
    Send email when a the telechat date (or returning item bit) changes for a
    document.  Fixes #1452 

  * Merged in [8262] and [8263] from [email-masked]:
    - Changes when returning_item is automatically set to match the current
      IESGs preferences.  Removes several chunks of dead code related to editing
      telechat dates.  Improves returning item tests.
    - Refactored multiple edit_telechat functions into one function in
      doc_views.  Added a helper function for determining if ballots have
      changed to isolate the implementation.  Fixed the issue with
      update_agenda setting the returning item bit even when the user
      explicitly said not to.  Added prompting to encourage proper setting
      of the returning item bit to the edit_telechat view.
    Fixes #1209

  * Merged in [8355] from [email-masked]:
    Add the owners email address to the json path for schedule objects. Fixes
    ticket #1492.  

  * Merged in [8256] from [email-masked]:
    Allow defer for status change documents. Fixes bug #1397.  

  * Merged in [8255] from [email-masked]:
    - Combined defer/undefer tests from doc/tests_ballot and iesg/tests,
      extending them to demonstrate current reported bugs.
    - Made doc.active_defer_event() look for the events that are currently being
      created. This remains brittle.
    - Added email notifying the IESG of an undefer analagous to the defer email.
    - Guarded against deferring an already deferred document or undeferring a
      document that hasn't been deferred.
    - Guarded against deferring a document that's not scheduled for a telechat.
    Fixes bugs 1417, 1465, 1417 

  * Merged in [8254] from [email-masked]:
    Don't send mail to unknown-email-* addresses. Fixes bug #1471.  

  * Merged in [8249] from [email-masked]:
    Skip sheme-relative urls. Fixes bug #1466.  

  * Merged in [8239] from [email-masked]:
    Adds javascript to return to a page a few seconds after successfully
    logging out.  Fixes ticket #1461. 

  * Merged in [8238] from [email-masked]:
    Look in the right place in the filesystem for the files bits when building
    reference relations during submit. Fixes bug #1467.  

  * Merged in [8236] from [email-masked]:
    Log what rebuild_reference_relations returns to diagnose #1467.  

 -- Henrik Levkowetz <[email-masked]>  12 Oct 2014 10:58:55 -0700

The new version is available for installation through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/5.6.4'

For development, check out the new development version instead:
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/5.6.5-dev0'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 14 Oct 2014 11:06:54 +0200

Thank you, Jermaine!

Best regards,

	Henrik

On 2014-10-13 23:57 Jermaine Shaffer said:
> The New Data Tracker version 5.6.4 has been installed on ietfa/ietfb servers. 
> 
> 
> 
> 
> -----------------------------------------------------
> Jermaine Shaffer,
> System Support Engineer
> Association Management Solutions
> Forum Management, 
> Meeting and Event Planning
> 48377 Fremont Blvd., Suite 117, Fremont, CA  94538
> Phone:  510-492-4018
> http://www.amsl.com
> 
> On Oct 13, 2014, at 1:15 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
>>
>> Hi,
>>

---

From: Jermaine Shaffer <[email-masked]>
Date: Mon, 13 Oct 2014 14:57:44 -0700