Subject: [codesprints] New datatracker release: v5.0.2

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Feb 2014 16:54:10 +0100

Hi,

This is an automatic notification about a new datatracker release, 
v5.0.2, generated when running the mkrelease script.

Release notes:

ietfdb (5.0.2) ietf; urgency=medium

  This is a minor bugfix release.

  * Merged [7292] from [email-masked]:
    Allow 1-3 digit RFCs in status change documents. Fixes bug #1321.

  * Fixed a server failure for person alias creation during draft submissions.

  * Fixed overflow error for meetings without timeslots, which gave server 
    errors for meeting/64/agenda.html.

  * Additional tweaks to bin/mergedevbranch.

  * Merged in [7204] from [email-masked]:
    Adds the IAB-parented sessions to the set of things returned as 
    \'areas\'.
    Fixes bug #1288 

  * Reapplied merge of [7209], which although listed in svn:mergeinfo on . 
    actually doesn't seem to have made it into the repository.

  * Only show a link to the tools page for a group if the tools page is 
    likely to exist, i.e., the group is a WG and it is or has been active.

  * Added a logging filter to filter out the 'Invalid HTTP_HOST' emails.

  * Changed the SECRET_KEY setting to take account of the settings in 
    settings_local.

  * Merged in [7138] from [email-masked]:
    Reworked SMTP Exception handling, adding sending a ticket to the 
    secretariat when there are errors handing messages off for delivery.
    Added SMTP exception handling to send-scheduled-mail.
    This is related to ticket #1208 

  * Added a file to hold a list of changesets which are ready for merge, as 
    a manually maintained alternative to 'Ready for merge' annotations in 
    commit messages.

  * Typo fixes.

  * Set version info and settings back to development mode

 -- Henrik Levkowetz <[email-masked]>  22 Feb 2014 21:41:57 +0100

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/5.0.2'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Matt Larson <[email-masked]>
Date: Tue, 25 Feb 2014 11:45:57 -0500

Greetings everyone!

5.0.2 has been deployed.

Matt

> 	(via the mkrelease script)

-------------------------------------------
Matthew Larson, Asst. IT Director
Association Management Solutions
Forum Management, Meeting and Event Planning
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
http://www.amsl.com

---

From: Ted Lemon <[email-masked]>
Date: Tue, 25 Feb 2014 11:52:39 -0500

> 5.0.2 has been deployed.

Thanks, Matt!   I'm actually getting an internal server error now trying to add an RFC status change document.   Dunno if this is a bug or something hasn't been restarted properly...

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Feb 2014 10:55:00 -0600

I'll look at this one.

---

From: Russ Housley <[email-masked]>
Date: Tue, 25 Feb 2014 12:02:22 -0500

Ted:

I am not seeing a problem.

Russ

---

From: Russ Housley <[email-masked]>
Date: Tue, 25 Feb 2014 12:12:14 -0500

Sorry Ted, I now understand the action you were trying to take.  I tried retrieving a status, and that worked.  I'm not an AD any more, so I cannot do the action that you were trying to do.

Russ

On Feb 25, 2014, at 11:52 AM, Ted Lemon wrote:

> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Feb 2014 18:25:00 +0100

> 5.0.2 has been deployed.

Thank you, Matt!

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Feb 2014 18:37:00 +0100

Hi Ted,

> Thanks, Matt!   I'm actually getting an internal server error now trying to add an RFC status change document.   Dunno if this is a bug or something hasn't been restarted properly...

I've received a stack trace for this problem.  Looking at it now, patch coming up.

Best regards,

	henrik

---

From: Ted Lemon <[email-masked]>
Date: Tue, 25 Feb 2014 12:42:39 -0500

> I've received a stack trace for this problem.  Looking at it now, patch coming up.

Thanks!

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Feb 2014 12:39:01 -0600

Ted - I've talked with Henrik and I have some things I want to verify 
with you.

If you could catch me on jabber, we can go through these interactively?

What browser were you using, and did you have javascript enabled?

I think if I submit this for you (in the secretariat role) it will work 
and get you unstuck,
and eliminate several possibilities for why it didn't work for you.
I have the data needed to do so from the attempt that didn't work.
Is it ok with you if I do so?

RjS

---

From: Ted Lemon <[email-masked]>
Date: Tue, 25 Feb 2014 13:44:27 -0500

> If you could catch me on jabber, we can go through these interactively?

You don't seem to be on Google's jabber, and I don't have another jabber ID for you.   I just followed you on g+, so if you try to chat me there you should be able to do so.

> What browser were you using, and did you have javascript enabled?

Chrome.   Javascript is enabled.

> I think if I submit this for you (in the secretariat role) it will work and get you unstuck,

Sure, that's fine.

Thanks!

---

From: Robert Sparks <[email-masked]>
Date: Tue, 25 Feb 2014 13:16:14 -0600

Ok - to close the loop on this.

I created the document for Ted - he's unstuck.

I worked with Ted to identify what went wrong for him.
It turns out that pasting into a text box in Chrome on an apple doesn't 
fire onkeypress as it does in some other browsers.
I'll work on finding the right events, and protecting the rest of the 
code from the kind POST that resulted.
In the meantime, if you see someone else having a similar problem, the 
workaround for chrome is to type the rfc# instead of pasting it in.
Creating and editing the list of RFCs affected by a status change 
document should be the _only_ thing having this issue.

RjS