Subject: [codesprints] New datatracker release: v4.80

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 03 Oct 2013 16:22:51 +0200

Hi,

This is an automatic notification about a new datatracker release, 
v4.80, generated when running the mkrelease script.

Release notes:

ietfdb (4.80) ietf; urgench=high
  This is a major release which provides the code drop from phase 3 of the
  Agenda Scheduling Tool.  The code has been merged in, and a lot of minor
  alignments done.  Deployment of this will make the phase 3 agenda editing
  tools available from the main ietf site, will align the database schema with
  that used in the ongoing development work, and will provide the correct
  models for secretariat tool adaptations.
  Other changes:
  * Reworked the TestCase code and fixture loading substantially, resulting
    in a substantial speed increase for tests when run on a transaction-
    capable database engine.
  * Added an index page for nomcoms, at /nomcom/, with links to nomcom 
    pages and announcements, where they exist.
  * Fixed some bugs in the EncryptedTextField class.
  * Fixed the language of the nomination confirmation message.
  * Changed 'requirement' to 'desired expertise' in user-visible places in 
    the nomcom app.
  * Fixed a wrong secretariat template extension name.
  * Provide the missing safe_rep function required in the back-ported 
    assertIsNone() test case method.
  * Added an explanatory paragraph to the Desired Expertise page.
  * The exception string for submission upload read errors seems to have 
    changed after we switched to wsgi, from "Client read error" to "request 
    data read error".  Now looking for just "read error" to catch both.
  * Tweaked the introductory text on the Nomcom Desired Expertise page.
  * Added a makefixture management command, from 
    http://djangosnippets.org/snippets/918/, somewhat hacked.
  * Updated the test fixtures, built to be more internally consistent in order
    to be able to pre-load them for the test suite.
  * Fixed the many times duplicated position names in the position selection 
    drop-down list in the nomcom private index page.  Fixes issue #1137.

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/4.80'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Robert Sparks <[email-masked]>
Date: Thu, 03 Oct 2013 09:29:23 -0500

Steve -

Could we time deploying this so that it happens today _after_ the 
conflict resolution call?

RjS

---

From: Glen <[email-masked]>
Date: Thu, 3 Oct 2013 07:55:41 -0700

All -

Steve is out today, so, unless this is urgent for today, it will be
deployed tomorrow.

Will that be okay?

Glen

On Thu, Oct 3, 2013 at 7:29 AM, Robert Sparks <[email-masked]> wrote:
> Steve -
>
> Could we time deploying this so that it happens today _after_ the conflict
> resolution call?
>
> RjS
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 03 Oct 2013 12:10:22 -0400

That's fine in my book.

spt

---

From: Alexa Morris <[email-masked]>
Date: Thu, 3 Oct 2013 09:13:25 -0700

Sean,

The problem with that is that the new agenda tool is part of the Datatracker install, and we need to publish the preliminary agenda today. We are determining a way to move this forward today...

Alexa

>>>>         (via the mkrelease script)

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Sean Turner <[email-masked]>
Date: Thu, 03 Oct 2013 12:20:46 -0400

Oh didn't realize that.

spt