Subject: [codesprints] Fwd: latest missing replaced-by information

From: Russ Housley <[email-masked]>
Date: Thu, 11 Oct 2012 10:25:02 -0400

I think we should consider making this a Secretariat tool, perhaps having it run on the server so that the datatracker database can be inserted automatically.

Russ

> From: "Eggert, Lars" <[email-masked]>
> Date: October 11, 2012 3:35:28 AM EDT
> To: Russ Housley <[email-masked]>
> Subject: Re: latest missing replaced-by information
> 
> On Oct 10, 2012, at 17:10, Russ Housley <[email-masked]> wrote:
>> Do you have a tool that gathers this?
> 
> Yep: http://eggert.org/software/find-replaced-by
> 
> Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 11 Oct 2012 14:35:42 +0000

> I think we should consider making this a Secretariat tool, perhaps having it run on the server so that the datatracker database can be inserted automatically.

It can't be fully automated, since there are false positives. (The tool just checks if for each draft-ietf-wgname-foo there exists an earlier draft-someothername-foo that is not currently marked as having been replaced, and flags that.)

What we could do is mark these in the datatracker as potential replacements, and ask the chairs to confirm.

Lars