Subject: Re: [codesprints] New datatracker release: v4.01

From: Steve Young <[email-masked]>
Date: Mon, 23 Apr 2012 12:57:07 -0700

Hi Henrik,

Datatracker 4.01 implemented.

Best regards,
Steve

On 4/22/12 11:38 AM, "Henrik Levkowetz" <[email-masked]>
wrote:

>
>Hi,
>
>This is an automatic notification about a new datatracker release,
>v4.01, generated when running the mkrelease script.
>
>Release notes:
>
>ietfdb (4.01)
>  * Made various fixes to test cases in order to support the new code and
>    database setup.
>  * Merged [4265] from [email-masked]:
>    Migrated HTML agenda to new data model. This has several
>improvements, 
>    as well, such as clearer marking of BOFs.
>  * Merged [4226] from [email-masked]:
>    Updated agenda.ics to use new data model. Also, tons more efficient.
>    Additionally, the description field now includes links to relevant
>meeting 
>    materials. 
>  * Merged [4224] from [email-masked]:
>    Related to #816 - Modified base.html so that the logo is clickable as
>    well as the text.
>  * Merged [4223] from [email-masked]:
>    Related to #817 - added a 401.html page for responding to
>    authentication failures
>  * Merged [4212] from [email-masked]:
>    Ticket #673 Add ability to clear ballot
>  * Merged [4214] from [email-masked]:
>    Fixes #816 - Turns datatracker.ietf.org into a clickable link
>  * Merged [4213] from [email-masked]:
>    Making doc writeup available as read-only text to regular users who
>are 
>    not shepherd/AD/Secretariat etc.
>    Adding a link for viewing a writeup to the main datatracker page.
>  * Merged [4205] from [email-masked]:
>    Added a link to the datatracker main document page when we announce a
>    new document 
>  * Merged [4207] from [email-masked]:
>    Ported week view over to use the new meeting data model
>  * Merged [4204] from [email-masked]:
>    Adds a link to the datatracker main document page in the new-version
>    notification messages
>  * Added a fix to catch summer/wintertime changes.
>
>The new version is available through SVN checkout, with
>  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/4.01'
>
>Regards,
>
>	Henrik
>	(via the mkrelease script)
>

---

From: Adam Roach <[email-masked]>
Date: Mon, 23 Apr 2012 16:24:50 -0500

Yikes! I really botched the "exclude" syntax in the .ics generation, and 
am generating empty calendars as a consequence.

Please apply 
http://svn.tools.ietf.org/svn/tools/ietfdb/personal/adam/v4.00@4312 as 
quickly as practical.

If you'd prefer to apply a patch to trunk rather than merging my branch, 
the diff is:

Index: ietf/meeting/views.py
===================================================================
--- ietf/meeting/views.py    (revision 4311)
+++ ietf/meeting/views.py    (revision 4312)
@@ -499,11 +499,12 @@
          Q(type__name__in = include_types) |
          Q(session__group__acronym__in = filter) |
          Q(session__group__parent__acronym__in = filter)
-        ).exclude(Q(session__group__isnull = False),
-        Q(session__group__acronym__in = exclude) |
-        Q(session__group__parent__acronym__in = exclude))
+        )#.exclude(Q(session__group__isnull = False),
+        #Q(session__group__acronym__in = exclude) |
+        #Q(session__group__parent__acronym__in = exclude))

-    return HttpResponse(render_to_string("meeting/agendaREDESIGN.ics" 
if settings.USE_DB_REDESIGN_PROXY_CLASSES else "meeting/agenda.ics",
+
+    return HttpResponse(render_to_string("meeting/agendaREDESIGN.ics",
          {"timeslots":timeslots, "meeting":meeting },
          RequestContext(request)), mimetype="text/calendar")

Thanks.

/a

On 4/23/12 2:57 PM, Steve Young wrote:
> On 4/22/12 11:38 AM, "Henrik Levkowetz"<[email-masked]>
> wrote:
>
>> Hi,
>>