Subject: [codesprints] IETF83 code sprint - willing to help with documentation

From: Dan York <[email-masked]>
Date: Wed, 7 Mar 2012 15:55:40 -0500

Hi,

Since I'm arriving in Paris on Friday evening, I figured I'd help out with the code sprint.  While I've worked with python for years and did a bit with a few Django-powered sites a few years back, rather than hacking on the main code base to add enhancements, I thought a better use of my particular skills might be to help with documentation and helping explain to people how to better use the IETF tools.  So I'm glad to expand the text on various web pages... add new pages related to some of the features you expect to be adding... write up some tutorials, edit existing pages, whatever...

I took a look at the tickets on http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas but without really diving into the tickets I can't easily see which might need some documentation assistance or not.  Particularly since I've never worked with this code base before.

So I'll put the invitation out there - if you have specific ideas for pages that could use some editing, new pages that need to be created, or some tutorials that could be written, please feel free to assign me ([email-masked]) to new or existing tickets with those tasks on them. When I get to the sprint I'll be glad to plug away at them.  

And if there aren't documentation needs, I'll just join with the rest of you on the code.

Regards,
Dan

P.S. A few of you attending know me from my blogging or from my RAI/SIP activities - you may or may not be aware of the developer side of my background - some info at http://code.danyork.com/ and https://github.com/danyork

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked] 
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/deploy360/

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 13 Mar 2012 14:52:10 +0100

Hi Dan,

Sorry for the delay in answering; I was on a short vacation Thursday
to Monday.  Response below:

On 2012-03-07 21:55 Dan York said:
> Hi,
> 
> Since I'm arriving in Paris on Friday evening, I figured I'd help out
> with the code sprint.  While I've worked with python for years and
> did a bit with a few Django-powered sites a few years back, rather
> than hacking on the main code base to add enhancements, I thought a
> better use of my particular skills might be to help with
> documentation and helping explain to people how to better use the
> IETF tools.  So I'm glad to expand the text on various web pages...
> add new pages related to some of the features you expect to be
> adding... write up some tutorials, edit existing pages, whatever...
> 
> I took a look at the tickets on
> http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas but
> without really diving into the tickets I can't easily see which might
> need some documentation assistance or not.  Particularly since I've
> never worked with this code base before.
> 
> So I'll put the invitation out there - if you have specific ideas for
> pages that could use some editing, new pages that need to be created,
> or some tutorials that could be written, please feel free to assign
> me ([email-masked]) to new or existing tickets with those tasks on
> them. When I get to the sprint I'll be glad to plug away at them.

Thanks for the offer!

> And if there aren't documentation needs, I'll just join with the rest

I'm tempted to say that that would probably be the most straightforward
solution, as I don't directly have a documentation issues list which
I can point you to.  I'd be more than happy to have you jump into the
code.

However, thinking some more about this, one thing that might become
very useful for the future is to improve the documentation related
to the new database schema itself, how we've made it work with the
old codebase, and how we should do refactoring of the old codebase
to clean it up to work directly against the new database schema,
instead of going through proxy models.

There are a few pages in the wiki which touches upon this currently,
but I wouldn't call it comprehensive, and I think a lot of people
would benefit from improving on this, if you think that would be a
good fit for you.

These are the pages which give data regarding this currently:
  http://trac.tools.ietf.org/tools/ietfdb/wiki/DatabaseSchemaDescription
  http://trac.tools.ietf.org/tools/ietfdb/wiki/DatabaseSchemaConversion

I expect that you'll have to buttonhole the contractor developer, Ole
Laursen, who will be available over Skype or similar, and myself, quite
a bit in order to gather information needed to flesh out this, but better
have that happen once than multiplied by the number of people who will
(hopefully!) be touching the code as we go forwards.

And if you decide to hack on the code instead, please feel free!

Best regards,

	Henrik