Subject: [codesprints] New datatracker release: v3.50

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 12 Apr 2011 18:25:44 +0200

Hi,

This is an automatic notification about a new datatracker release, 
v3.50, generated when running the mkrelease script.

Release notes:

ietfdb (3.50)
  * For this release, the idsubmit port from [email-masked] has been merged
    in, which constitute substantial added functionality.  This integrates the
    draft upload functionality with the python/django datatracker; it improves
    draft submission handling and security, and fixes problems with database
    breakage and inconsistency caused by the old implementation.  With this also
    comes a major improvement of author extraction from draft text, provided by
    the ietf/utils/draft.py module from [email-masked].
  * Deployment note:  Once the new release has been placed in its deployment
    directory, and the correct settings_local.py has been copied in, a command
    needs to be run in order to update the database tables to work with the new
    code.  In the directory containing the ietf/ directory, run this command:
        $ PYTHONPATH=$PWD ietf/manage.py migrate
    The output should be as follows:
	Running migrations for liaisons:
	- Nothing to migrate.
	Running migrations for submit:
	 - Migrating forwards to 0003_add_extra_name_fields.
	 > submit: 0001_initial
	 > submit: 0002_add_submission_hash
	 > submit: 0003_add_extra_name_fields
	 - Loading initial data for submit.
    Once this is done, the regular deployment routine should be continued.

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/3.50'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Matt Larson <[email-masked]>
Date: Tue, 12 Apr 2011 13:49:57 -0400

Deployed.

Thanks!

Matt

> 	(via the mkrelease script)

-------------------------------------------
Matthew Larson, Asst. IT Director
Association Management Solutions
Forum Management, Meeting and Event Planning
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
http://www.amsl.com

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 14 Apr 2011 16:11:41 +0200

> Deployed.

And thank you for this, too!

Best,

	Henrik