Subject: [codesprints] New datatracker release: v3.14

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 28 Mar 2011 19:44:46 +0200

Hi,

This is an automatic notification about a new datatracker release, 
v3.14, generated when running the mkrelease script.

Release notes:

ietfdb (3.14)
  * From [email-masked]: 
    Update jQuery to 1.5.1 and jQuery UI to 1.8.11.
  * From [email-masked]: 
    On the agenda page, for the custom agenda display, now only displays groups
    that are actually meeting.
  * From [email-masked]: 
    Remove unused images. Convert GIFs to smaller PNGs.
    Optimize all images with http://www.smushit.com/ysmush.it/ 
  * From [email-masked]: 
    Change default vertical alignment of various datatracker tables
    for better readability.
  * From [email-masked]: 
    Fix typo. Fixes #566.
  * From [email-masked]: 
    Make search result table headers clickable; clicking will sort on said 
    column, fixes #484.
  * From [email-masked]: 
    Don't show AD/Secretariat links for Last Call etc. if they will 404.
    Fixes #550.
  * From [email-masked]: 
    Meeting boxes now expand to reveal all text when users hover over them.
    Fixes ticket #602. 
  * From [email-masked]: 
    Added an URL to retrieve a text/plain version of the list of drafts for
    a given WG.  Useful for building WG-speific ePub documents of a WG's
    drafts.
  * From [email-masked]:
    Updated the JavaScript associated with the search page to 
    control whether the 'search' button is enabled or not. It is
    now enabled if either the main search box has input, or if
    any of the sub-options have input, or both.
  * From [email-masked]: 
    Adds a view of documents currently in IETF Last Call.  Fixes #630.
  * From [email-masked]:
    Remove explicit URLs in the code, using reverse() and the newly created
    helper function reverse_lazy().  Fixes #628.
  * From [email-masked]: 
    Changed the way ballot discuss/comment texts are displayed to
    put the text from current ADs first, and mark ex-ADs with []
    following the convention on the left bar.  This fixes issue #608 
  * From [email-masked]: 
    Added ical-format agenda.  Fixes issue #601.
  * From [email-masked]: 
    Add IPR column to IESG Telechat Agenda.  Fixes issue #552.
  * From [email-masked]: 
    Add a defer/undefer button to the edit_position dialog.  Fixes issue #627.
  * From [email-masked]: 
    Changed cookie settings to be valid for 10 years, they used to be valid
    until the end of session.

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/3.14'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Glen <[email-masked]>
Date: Mon, 28 Mar 2011 11:16:02 -0700

Deployed!

Glen

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 29 Mar 2011 08:48:38 +0200

Hi,

There's a problem with one of the features of this release (the URL reverse
lookups fail for URLs of the form http://datatracker.ietf.org/doc/rfcNNNN/*).
I'm working on understanding and fixing the issue.

Best,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 29 Mar 2011 09:38:21 +0200

> I'm working on understanding and fixing the issue.

Fixed.  I've patched the datatracker, and the issue seems to be gone.  The
problem turned out to be limited to a few very unusual cases, so the rush
wasn't strictly needed.  The fix has been committed as [2998]:
http://trac.tools.ietf.org/tools/ietfdb/changeset/2998

	Henrik

> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints
>