Subject: [codesprints] New datatracker release: v3.12

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 02 Feb 2011 18:36:03 +0100

Hi,

This is an automatic notification about a new datatracker release, 
v3.12, generated when running the mkrelease script.

Release notes:

ietfdb (3.12)
  Note: Deploying this release requires a database schema update, see below.
  From [email-masked]:
  * Allow an SDO Liason Manager to send outgoing liaison from any IETF
    Entity to his SDO.
  * Allow the secretariat to send liaisons on behalf of another user.
  * On login, retrieve the person record related to the login from the 
    legacy tables of non IESG logins. Provides the link between login name
    and person listed in the liaison manager table.  Fixes #576.
  * Refined handling of the To: and From: address lists when the Liaison
    Manager is also a WG Chair or AD.
  From [email-masked]:
  * Add a clean_whitespace filter in some places to get rid of any newlines 
    embedded in document titles.  Fixes a problem with bad email headers
    in announcements related to documents with newlines embedded in the title.
  * Don't try to send out mail which has no recipients.  Fixes a crash when
    trying to send announcements related to drafts which have an empty
    'email notes to' field.
  * Fix typo in method calls to send email, fixes a crash when submitting
    liaison statements.
  * Renamed 'LiaisonDetail.taken_care' field to 'action_taken'.  
    Miscellaneous associated fixes.  Enhanced liaison-related admin pages.
  Note: Deploying this release requires an additional steps to create
    a new column in a table.  This is done as a South migration
    (see http://south.aeracode.org/ for more info on South):
    # 8<----------
    # First the regular checkout and prepare:
       cd /a/www/ietf-datatracker
       svn co http://svn.tools.ietf.org/svn/tools/ietfdb/tags/3.12
       cp web/ietf/settings_local.py 3.12/ietf/
       cd 3.12
    # Next, apply the migrations:
 
       PYTHONPATH=$PWD ietf/manage.py migrate liaisons
    # Then carry on with the usual actions:
       cd ../
       rm ./web; ln -s 3.12 web
       sudo /etc/init.d/apache restart
    # 8<----------

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/3.12'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Glen <[email-masked]>
Date: Wed, 02 Feb 2011 10:53:19 -0800

This has been done!

GLen

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 02 Feb 2011 20:24:02 +0100

Thank you, Glen!

Best,
	Henrik