Subject: [codesprints] New datatracker release: v2.24

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 26 Apr 2009 16:03:43 +0200

Hi,

This is an automatic notification about a new datatracker release, 
v2.24, generated when running the mkrelease script.

Release notes:

ietfdb (2.24)
  * Merged in code from Pasi for new ID/RFC search and per-document pages,
    and IESG "discuss report".
  * Added missing images for liaison_manager.cgi to static/images/.
  * More sensible error message if settings_local.py is not found.
	
  * Fix feed problem for non-ascii names. From Pasi Eronen. 
  * ** NOTE: This release uses the Django cache framework, and requires
    that the cache directory in settings.py (/a/www/ietf-datatracker/cache/)
    exists.
  * Fix problem with area model in admin interface
ietfdb (2.23)
  * Fixed a wrong link in the html agenda (from Henrik)
  * Removed the explicit database server ip address in settings.py
    (from Henrik)
  * Integrated updated authorization system.  This requires applying
    database fixups as follows:
	cd /a/www/ietf-datatracker/2.23/ietf
	python manage.py dbshell < ../test/sql_fixup.sql
    The existing htpasswd file can be imported into this new system
    as follows:
	export PYTHONPATH=/a/www/ietf-datatracker/2.23
	export DJANGO_SETTINGS_MODULE=ietf.settings
	/a/www/ietf-datatracker/2.23/ietf/bin/import-users /a/www/htpasswd
    Please capture the output of the import-users script, as it will
    help us resolve any troubles that users have.
  * Fixed infinite loop in wrapping code that prevented display of certain
    document comments

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/2.24'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Glen <[email-masked]>
Date: Sun, 26 Apr 2009 17:09:53 -0700

Installed!

Glen