Subject: [Codematch-develop] Codematch status

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 16 Mar 2016 20:54:39 +0000

Hi Brazilian team,

Were you able to sort out the authentication issue?

We’re close to the meeting and we’re really anxious about the initial tests :-)

Thanks!

Christian O'Flaherty  [email-masked]<mailto:[email-masked]>
Regional Development - Internet Society
Skype/Gmail/Yahoo!:  christian.oflaherty
Mobile/WhatsApp: +598 98769636

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 16 Mar 2016 17:01:56 -0400

I'll do my best to join next week's call.  I'm still on leave, but would love to hear the progress that's been made.

Thanks,
Kathleen 

Sent from my iPhone

> On Mar 16, 2016, at 4:54 PM, Christian O'Flaherty <[email-masked]> wrote:
> 
> 
> Hi Brazilian team, 
> 
> Christian O'Flaherty  [email-masked]
> _______________________________________________
> Codematch-develop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codematch-develop

---

From: "Wanderson Paim" <[email-masked]>
Date: Wed, 16 Mar 2016 18:24:45 -0300

Hi Christian,

Due to the start of Daylight Saving Time in USA I miscalculated the time of today’s call. I was there one hour latter. :( Sorry.

I was planning to show you the current version of CodeMatch, with the ‘autosuggest’ solution working. It can be tested in the dev version at  <http://codematch.inf.ufrgs.br/codematch-dev/codematch/> http://codematch.inf.ufrgs.br/codematch-dev/codematch/ .

Whit this solution, the inclusion of documents and Mentor’s name in the new CodeMatch form is much easier. When you start typing the documents’ name or mentor’s name, the system shows a list of documents or names that matches the characters typed so far.

Matheus was working both on the authentication system and in this autosuggest. Now that we have autosuggest working, he is focused on the authentication system. We are going to ask the new user to provide the email or username from DataTracker. So, using this data we retrieve all information about that user from DataTracker’s database and fill it into a registration form, letting only the password field empty. So that, the user is able to define a new password for CodeMatch system while it keeps the same general profile information form DataTracker.

We are engaged on this goal and Matheus is giving his best to have it ready before the Buenos Aires’ meeting.

Sorry again about today’s meeting.

Cheers,

Wanderson Paim de Jesus
Coordenador de Projetos - CTIC

 <http://www.rnp.br/> RNP - Rede Nacional de Ensino e Pesquisa

Tel.:+55 (61) 3243 4350 | Cel: +55 (61) 8315 8994

De: Codematch-develop [mailto:[email-masked]] Em nome de Christian O'Flaherty
Enviada em: quarta-feira, 16 de março de 2016 17:55
Para: codematch-develop <[email-masked]>
Assunto: [Codematch-develop] Codematch status

Hi Brazilian team, 

Thanks!

Christian O'Flaherty   <mailto:[email-masked]> [email-masked]

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 16 Mar 2016 22:22:17 +0000

Thank you Wanderson for the update and the great progress with codematch! Great job.

I look forward to having the password feature so we can start with the tests

I tried to reset my password but it looks like the SMTP server configured is not answering

An error occured while sending email: SMTP Exception: <class 'socket.error'> Error Message: [Errno 111] Connection refused

On Mar 16, 2016, at 6:24 PM, Wanderson Paim <[email-masked]<mailto:[email-masked]>> wrote:

Hi Christian,

I was planning to show you the current version of CodeMatch, with the ‘autosuggest’ solution working. It can be tested in the dev version at http://codematch.inf.ufrgs.br/codematch-dev/codematch/ .
Whit this solution, the inclusion of documents and Mentor’s name in the new CodeMatch form is much easier. When you start typing the documents’ name or mentor’s name, the system shows a list of documents or names that matches the characters typed so far.

Cheers,

Wanderson Paim de Jesus
Coordenador de Projetos - CTIC
RNP<http://www.rnp.br/> - Rede Nacional de Ensino e Pesquisa
Tel.:+55 (61) 3243 4350 | Cel: +55 (61) 8315 8994

De: Codematch-develop [mailto:[email-masked]] Em nome de Christian O'Flaherty
Enviada em: quarta-feira, 16 de março de 2016 17:55
Para: codematch-develop <[email-masked]<mailto:[email-masked]>>
Assunto: [Codematch-develop] Codematch status

Hi Brazilian team,

Thanks!

---

From: "Wanderson Paim" <[email-masked]>
Date: Wed, 23 Mar 2016 13:22:42 -0300

Hello,

In today’s call, just Matheus and me are online. After all changes in daylight saving time, are the meeting still happening at 12h GMT-4 ?

In the last week CodeMatch was updated with two features. One is the authentication system, which is now able to use DataTracker username and password to validate the sessions. The other one is the use of ‘autosuggest’ in some fields on the new CodeRequest form.

Both solutions can be tested in the development environment through the following link:

 <http://codematch.inf.ufrgs.br/codematch-dev/codematch/> http://codematch.inf.ufrgs.br/codematch-dev/codematch/

After having your feedback, we are going to move the code to the production environment in:

 <http://codematch.inf.ufrgs.br/codematch-master/codematch/> http://codematch.inf.ufrgs.br/codematch-master/codematch/

Best Regards

Wanderson

De: Christian O'Flaherty [mailto:[email-masked]] 
Enviada em: quarta-feira, 16 de março de 2016 19:22
Para: Wanderson Paim <[email-masked]>
Cc: codematch-develop <[email-masked]>; Matheus Prola <[email-masked]>; Lisandro Zambenedetti Granville <[email-masked]>
Assunto: Re: RES: [Codematch-develop] Codematch status

An error occured while sending email: SMTP Exception: <class 'socket.error'> Error Message:

[Errno 111] Connection refused

On Mar 16, 2016, at 6:24 PM, Wanderson Paim <[email-masked] <mailto:[email-masked]> > wrote:

Hi Christian,

Cheers,

Wanderson Paim de Jesus

 

De: Codematch-develop [ <mailto:[email-masked]> mailto:[email-masked]] Em nome de Christian O'Flaherty
Enviada em: quarta-feira, 16 de março de 2016 17:55
Para: codematch-develop < <mailto:[email-masked]> [email-masked]>
Assunto: [Codematch-develop] Codematch status

Hi Brazilian team, 

Thanks!

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Wed, 23 Mar 2016 20:07:02 +0000

That sounds great, thanks for your work on this!  I'll be back full time a week or two after the IETF and will be attending all of my WG sessions remotely for BA.

It's hard for me to join calls until I have help here.

Thanks!
Kathleen

Sent from my iPhone

On Mar 23, 2016, at 12:23 PM, Wanderson Paim <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Both solutions can be tested in the development environment through the following link:
http://codematch.inf.ufrgs.br/codematch-dev/codematch/

After having your feedback, we are going to move the code to the production environment in:
http://codematch.inf.ufrgs.br/codematch-master/codematch/

Best Regards
Wanderson

De: Christian O'Flaherty [mailto:[email-masked]]
Enviada em: quarta-feira, 16 de março de 2016 19:22
Para: Wanderson Paim <[email-masked]<mailto:[email-masked]>>
Cc: codematch-develop <[email-masked]<mailto:[email-masked]>>; Matheus Prola <[email-masked]<mailto:[email-masked]>>; Lisandro Zambenedetti Granville <[email-masked]<mailto:[email-masked]>>
Assunto: Re: RES: [Codematch-develop] Codematch status

Hi Christian,

Cheers,

Wanderson Paim de Jesus

Hi Brazilian team,

Thanks!

_______________________________________________
Codematch-develop mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/codematch-develop

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 23 Mar 2016 21:15:03 +0000

Hi Wanderson,

That’s correct.
I came to Buenos Aires to deal with some customs issues for IETF 95 and was caught in meetings and offline. My apologies for not joining the call.

Yes! great work. I tried a previous version with Matheus on Monday but this one is much better. The login works fantastic and the selections too. I want to congratulate Matheus (and all the Brazilian team) for the amazing work.

It looks like we’re ready for the initial tests. I would move it to the production environment right away.

There’s a minor bug when you enter an email address for a new CodeRequest (it does not store your email). But I would not delay it because of that. Let’s move it to production and ask volunteers to look for additional bugs.

Christian

Best Regards
Wanderson

Hi Christian,

Cheers,

Wanderson Paim de Jesus

Hi Brazilian team,

Thanks!