Subject: [Codematch-develop] Today's call

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 7 Oct 2015 12:19:45 -0400

Hello,

I joined late and no one was on the call.  Does this time work and we
should just resume next week or were some of you on and I missed it?

Can we review the plan for Yokohama soon and possible release dates, etc.?

Thank you!

-- 

Best regards,
Kathleen

---

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Wed, 7 Oct 2015 13:29:45 -0300

Hi Kathleen

Wanderson, Toral, and I were on the call. We’re going to report in a message asap :)

Best regards,

Lisandro

> Em 7 de out de 2015, à(s) 13:19, Kathleen Moriarty <[email-masked]> escreveu:
> 
> Hello,
> 
> _______________________________________________
> Codematch-develop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codematch-develop

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 7 Oct 2015 12:31:48 -0400

Thank you, Lisandro & Toral!  That's right about when I joined, sorry
I was delayed a bit!  I hope it was productive for each of you.

Best regards,
Kathleen

-- 

Best regards,
Kathleen

---

From: "Wanderson Paim" <[email-masked]>
Date: Wed, 7 Oct 2015 13:45:39 -0300

Hello

Because in today’s meeting we had only Toral, Wanderson, and Lisandro in the call (until a certain time), we are reporting the last developments here in this message:

a) Databases integration - The integration of datatracker and CodeMatch databases is important to take advantage of data already stored in datatracker (e.g., user records), thus avoiding replication in CodeMatch. Still, it’s important to secure that CodeMatch won’t change things on datatracker database. A viable solution, in our view, is to have database user in datatracker whose rights are limited to read operations. CodeMatch, by using the credentials of such a database user, would be able to query datatracker without changing anything. Because we are using Django in CodeMatch, we can access different yet complementary databases (datatracker’s and CodeMatch’s) in a convenient way. Is it ok if we move on with this strategy?

b) Search and order tools - Matheus implemented a search and an order tool, sensible to context. When we are listing CodeRequests or CodeMatches, we can now ordem them according to different information, such as title, release data, etc. One can also search the CodeMatch entries by providing a string that is used to query the database and retrieve CodeRequests and CodeMatches that match the search criteria. You can play with the first version of these tools at http://codematch.inf.ufrgs.br/codematch-dev/codematch/

c) Wanderson and Lisandro are working to improve the CodeMatch UI. We want a visual identify that links the CodeMatch site to the IETF pages, but that is also more appealing to the potential coders, who are possibly more attracted to web system with fancier interfaces. 

d) Matheus have updated the feature list to reflect the last efforts, which includes the ordering and searching functions both in CodeMatch and CodeRequest lists. The next planned functions includes showing a list of top coders (ordered by volume of projects), for this week, and enabling the mentor to associate a communication channel to the CodeRequest (ex.: WorkingGroup jabber room), for the next week. After that we will have all Phase 1 features implemented. We may need one additional week to deal with small bugs or details about the layout/interface.

The currently development version is available at:
http://codematch.inf.ufrgs.br/codematch-dev/codematch/

But, when appropriate, the release will be available at:
http://codematch.inf.ufrgs.br/codematch-master/codematch/

Best regards,

Wanderson and Lisandro

-----Mensagem original-----
De: Codematch-develop [mailto:[email-masked]] Em nome de Lisandro Zambenedetti Granville
Enviada em: quarta-feira, 7 de outubro de 2015 13:30
Para: Kathleen Moriarty <[email-masked]>
Cc: [email-masked]
Assunto: Re: [Codematch-develop] Today's call

Hi Kathleen

Best regards,

Lisandro

---

From: Robert Sparks <[email-masked]>
Date: Wed, 7 Oct 2015 14:22:45 -0500

> a) Databases integration - The integration of datatracker and CodeMatch databases is important to take advantage of data already stored in datatracker (e.g., user records), thus avoiding replicatio…
Instead of a datatracker user, I think you should be talking about a 
mysql user that has read only access.
You would have two databases set up in your settings.py.

---

From: "Wanderson Paim" <[email-masked]>
Date: Wed, 7 Oct 2015 16:37:41 -0300

Hello Robert,

-----Mensagem original-----
De: Codematch-develop [mailto:[email-masked]] Em nome de Robert Sparks
Enviada em: quarta-feira, 7 de outubro de 2015 16:23
Para: [email-masked]
Assunto: Re: [Codematch-develop] RES: Today's call

> a) Databases integration - The integration of datatracker and CodeMatch databases is important to take advantage of data already stored in datatracker (e.g., user records), thus avoiding replicatio…
Instead of a datatracker user, I think you should be talking about a mysql user that has read only access.

- Yes, we are talking about database user. In case of MySQL databases, they could be called mysql user as well.

- Yes. See the example:

DATABASES = {
    'default': {
        'NAME': 'app_data',
        'ENGINE': 'django.db.backends.postgresql_psycopg2',
        'USER': 'postgres_user',
        'PASSWORD': 'xxxyyy'
    },
    'users': {
        'NAME': 'user_data',
        'ENGINE': 'django.db.backends.mysql',
        'USER': 'mysql_user',
        'PASSWORD': 'priv4te'
    }
}

---

From: Robert Sparks <[email-masked]>
Date: Wed, 7 Oct 2015 14:45:55 -0500

Good - we're on the same page.

(I misread the message originally to imply a user in the User table 
inside the datatracker database, which on re-read is clearly not what 
was intended).

You can build this using a copy of the datatracker database (I think 
you're already familiar with how to get one, but if not, there are 
instructions at 
http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintDatabase (and some 
other useful information at 
http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintCoderSetup). When we 
get closer, we'll work out how to work against the production database.

RjS