Subject: Re: [Codematch-develop] Tuesday Design Call

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Tue, 9 Sep 2014 13:03:31 -0300

Dear all

I couldn’t participate on the last week’s call, but I would like to share a draft, initial list of requirements. This list is taken from the perspective of the mockups materialization. It’s a draft and certainly not exhaustive list, but it can serve as a starting point. In this context, consider the following requirements:

1) Support, on the database, for the notion of:
- User (coders, shepherds, working group chairs)
- Group of users (e.g., working groups, research groups, team of coders)
- List of coding requests
- List of CodeMatches

Quite simple indeed, and I expect a simple RBAC implementation must the sufficient. I’ll sketch a data model as mentioned in the last mockup meeting.

2) User authentication with password. Quite obvious, but I didn’t want to avoid listing it.

3) Cascading Style Sheet suport
Mockups will be materialized though CSS. I don’t know how datatracker handles that, or whether we can incorporate CSS in HTML pages exported from datatracker.

4) I don’t see the need of support for multimedia contents like video of voice.

To help further improve this list, could you guys consider reading through Henrik's message? 

Best regards,

Lisandro

ps.: I’m in transit today going back to Brazil and won’t be able to attend today’s meeting.

Em 29/08/2014, à(s) 17:22, Kathleen Moriarty <[email-masked]> escreveu:

> Hello,
> 
> For the regularly scheduled deign team call on Tuesday at 1PM EDT, we have a few items on the agenda (in no particular order, as it may change).  
> 
> 1. Review of initial set of requirements (Lisandro)
> 2. Content for student/professor pamphlets (Toral)
> 3. Review of proposed text for introduction page of web site (Kathleen)
>     I will likely revise it again before then, but have posted it to the Google drive and it was just my first pass.
> 
> 
> Team input and feedback will be appreciated on each of these efforts.
> 
> -- 
> 
> Best regards,
> Kathleen
> _______________________________________________
> Codematch-develop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codematch-develop

---

From: Toral Cowieson <[email-masked]>
Date: Tue, 9 Sep 2014 12:43:40 -0400

Hi Lisandro, All,

I have uploaded a document to Google Docs.  This is the draft language for the CodeMatch leave behind for students and professors -- and would be the foundation for the actual "pamphlet" or promo piece .  I look forward to  today's conversation and to moving this work along.

Best regards,
Toral