Subject: [Codematch-develop] CodeMatch document in Google drive

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Mon, 21 Jul 2014 19:49:08 -0400

Dear all

Thanks for today’s opportunity of getting in touch with the CodeMatch initiative. I did manage to find a document distributed by Lars to the IRSG mailing list, but because Kathleen mentioned today that there’s a working document in Google drive I was wondering how to have access to it.

Thanks,

Lisandro

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Tue, 22 Jul 2014 08:04:59 -0400

Good morning,

Thank you each for coming to meet yesterday.  I scheduled a room for our follow up session today at 1PM, the Albert room.

Here is a link to the Google doc describing CodeMatch goals, functions, and features:

https://docs.google.com/document/d/12kbFDwzhecC1DLtVEo3ruLuFZMCtiSwd5US0I44v96Q/edit#heading=h.pz5w8aj4nbgs

If you have suggestions, please share them with the list and we'll up date as needed so that we have a solid starting point and an understanding of desirable features to assist each of the target audiences.  I'll see you at 1!

Thank you,
Kathleen
________________________________________
From: Codematch-develop [[email-masked]] On Behalf Of Lisandro Zambenedetti Granville [[email-masked]]
Sent: Monday, July 21, 2014 7:49 PM
To: [email-masked]
Subject: [Codematch-develop] CodeMatch document in Google drive

Dear all

Thanks,

Lisandro
_______________________________________________
Codematch-develop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codematch-develop

---

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Tue, 22 Jul 2014 11:16:20 -0400

Dear Kathleen

Thanks for sharing the CodeMatch document. After a first look, I would like to mention two questions:

1) I believe IRTF research groups could be, when possible, more explicitly mentioned because some coding efforts can result from RGs too;

2) I understand that the CodeMatch website will work as, let’s say, a market place, where opportunities do code and implementers will match. It’s probably written between the lines, but I believe that it would be important for students to have their names advertised in the CodeMatch website as soon as the students propose to code something. Having their names listed since the beginning provide: a) a sense of responsibility because the students would be “officially” expected to deliver something, and b) they can acquire a sense of how important they are in the whole CodeMatch effort. Of course there is always the risk of acknowledging students/implementers that don’t deliver anything in the end, but that’s a worthwhile risk in my view.

Best regards,

Lisandro

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Tue, 22 Jul 2014 11:19:59 -0400

Dear Lisandro,

> 2) I understand that the CodeMatch website will work as, let’s say, a market place, where opportunities do code and implementers will match. It’s probably written between the lines, but I believe t…

Yes, agreed. Having their name in public associated to a project may 
also increase responsibility and commitment. It's also very much the 
IETF style ...

Best

Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: Alejandro Acosta <[email-masked]>
Date: Tue, 22 Jul 2014 14:21:27 -0430

> 1) I believe IRTF research groups could be, when possible, more explicitly mentioned because some coding efforts can result from RGs too;

Well said, I fully agree too.

> 2) I understand that the CodeMatch website will work as, let’s say, a market place, where opportunities do code and implementers will match. It’s probably written between the lines, but I believe t…

In the other hand, even when the document mentions a lot about who can
participate I would add explicitly post-graduate students of Engineering
or Computer Science.

Two small comments:
In the section "Motivation for students to participate":
  I would add something like: participate/belong to a high tech community

In incentives we could add something like:
  The project could be valid as a final project, thesis, internship,
other (depends on the university)

Alejandro,