Subject: [codec] Comments on draft-ietf-codec-ambisonics-01.txt

From: Hans Fugal <[email-masked]>
Date: Wed, 8 Feb 2017 18:29:40 +0000

I have reviewed this draft and find it satisfactory. In particular I like the default ambiX (ACN ordering and SN3D normalization) format, the inclusion of non-diegetic audio in both channel mappings, and the flexible support in channel mapping 3 for arbitrary matrices. I think it will be an important contribution to encoding and standardizing distribution of ambisonics - which is an important emerging format - and that it will be a boon to Ogg Opus.

I wonder if it might also be possible to widen the scope of the draft to include other codecs in an Ogg container, particularly FLAC or some other lossless codec.

Cheers

---

From: Ralph Giles <[email-masked]>
Date: Fri, 10 Feb 2017 12:57:04 -0800

> I wonder if it might also be possible to widen the scope of the draft to include other codecs in an Ogg container, particularly FLAC or some other lossless codec.

I think the draft would be a good basis for a similar extension to
lossless encoding. However, FLAC's 8-channel limit means one would
probably need some way of trunking multiple FLAC streams together.

There's interest in this for multitrack recording as well as ambisonics,
but I think specifying it is outside the focus of this working group.
Could you bring it up with the CELLAR group, which is standardizing FLAC?

 -r