Subject: [codec] WGLC of draft-ietf-codec-opus-update-04

From: "Timothy B. Terriberry" <[email-masked]>
Date: Wed, 16 Nov 2016 17:43:06 -0800

Except for the issue of where the new test vectors should live, the 
chairs believe that this draft is ready to go. We would like to initiate 
a working group last call on draft-ietf-codec-opus-update-04 to help 
gather any remaining issues.

The draft can be found at 
https://tools.ietf.org/html/draft-ietf-codec-opus-update-04

Please send comments to the list by the end of the day on Dec. 1.

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 18 Nov 2016 07:15:06 +0000

> On Nov 17, 2016, at 10:43 AM, Timothy B. Terriberry <[email-masked]> wrote:
> 
> Except for the issue of where the new test vectors should live, the chairs believe that this draft is ready to go. We would like to initiate a working group last call on draft-ietf-codec-opus-update-04 to help gather any remaining issues.
> 
> The draft can be found at https://tools.ietf.org/html/draft-ietf-codec-opus-update-04
> 

I have reviewed this document.

I haven't personally validated all the changes to the C code, but they seem plausible to me.  Each of the patches’ explanatory text also seems good.

However, I think the overview text could be clearer.

1. I assume none of these changes rise to the level that they would make any change to the textual description of the Opus codec?  This should probably be stated explicitly.

2. The abstract and introduction should mention that this document updates the normative behavior of the codec, including the test vectors.

3. The link to the properly-formatted patch matching the document should be mentioned somewhere other than in Section 5 — especially since it actually includes patches for all the sections of the document, not just Section 5 and above.  The introduction seems like a sensible place, perhaps.

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 18 Nov 2016 02:41:27 -0500

Hi Jonathan,

Thanks very much for the review.

On 18/11/16 02:15 AM, Jonathan Lennox wrote:
> 1. I assume none of these changes rise to the level that they would
> make any change to the textual description of the Opus codec?  This
> should probably be stated explicitly.

I believe that's correct, but I'll check.

> 2. The abstract and introduction should mention that this document
> updates the normative behavior of the codec, including the test
> vectors.

Agreed. I'll make the change in the next version.

> 3. The link to the properly-formatted patch matching the document
> should be mentioned somewhere other than in Section 5 — especially
> since it actually includes patches for all the sections of the
> document, not just Section 5 and above.  The introduction seems like
> a sensible place, perhaps.

Agreed, will update. There's also going to be the question of where that
patch should go. Since it's a lot smaller than the test vectors, there
may be more options.

Cheers,

	Jean-Marc