Subject: Re: [codec] Fwd: New Version Notification for draft-valin-codec-opus-update-00.txt

From: Tina le Grand <[email-masked]>
Date: Fri, 6 Sep 2013 13:35:19 +0200

I generally approve of this draft. I have a few comments.

   - Section 4, in the source code lines:

This might be a little picky, but I suggest to remove the following line
  len--;
and replace the new line, "len -= p==255 ? 254: p;" with
  len -= p==255 ? 255: p+1;
or should it even be:
  len -= p;
?

   - Section 5, page 4:  "The code can be fixed by applying the following
   changes to like 70" - "like" should be "line".
   - Section 6. Can you describe how to remove the 180-degree phase shift?

Thanks,
Tina le Grand.

On Thu, Aug 1, 2013 at 5:18 PM, Timothy B. Terriberry <[email-masked]>wrote:

> Jean-Marc Valin wrote:
>
>> See these proposed fixes to the Opus RFC. These are minor changes to the
>> normative part of the reference implementation.
>>
>
> With my chair hat on:
>
> Although JDR originally said we would handle updates to RFC 6716 through
> the normal errata process [1], after conferring with our ADs, we decided to
> do them via a new draft, so that there was no question about overriding
> working group consensus.
>
> To that end, we'd like to run a consensus call to add a milestone for
> doing these updates. It would be helpful to have reviews of this document
> before doing that call. I propose we allow a month (until Sep. 1) for such
> reviews, and then run the call.
>
>
> [1] https://datatracker.ietf.org/**documents/LIAISON/liaison-**
> 2012-09-21-codec-isoiec-jtc-**1sc-29wg-11-liaison-from-ietf-**
> codec-working-group-to-isoiec-**regarding-speech-and-audio-**
> coding-standardization-**attachment-1.pdf<https://datatracker.ietf.org/documents/LIAISON/liaison-2012-09-21-codec-isoiec-jtc-1sc-29wg-11-liaison-from-ietf-codec-working-group-to-isoiec-regarding-speech-and-audio-coding-standardization-attachment-1.pdf>
>
> ______________________________**_________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/codec<https://www.ietf.org/mailman/listinfo/codec>
>

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 06 Sep 2013 14:58:32 -0400

Hi Tina,

Thanks for the feedback. I'll make the changes.

> * Section 6. Can you describe how to remove the 180-degree phase
> shift?

Not sure what part of my explanation isn't clear. What happens is that
the encoder has a per-band "inversion flag" it can use for intensity
stereo and when the decoder sees that flag, it flips the sign of the
right channel to make it 180-degrees out of phase with the left
channel. The proposal is simply to make the inversion step optional on
the decoder side, even when the flag is set by the encoder. Any
suggestion on how to fix the current text?

Cheers,

	Jean-Marc

> Thanks, Tina le Grand.
> 
> 
> 
> On Thu, Aug 1, 2013 at 5:18 PM, Timothy B. Terriberry
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Jean-Marc Valin wrote:
> 
> See these proposed fixes to the Opus RFC. These are minor changes
> to the normative part of the reference implementation.
> 
> 
> With my chair hat on:
> 
> Although JDR originally said we would handle updates to RFC 6716 
> through the normal errata process [1], after conferring with our 
> ADs, we decided to do them via a new draft, so that there was no 
> question about overriding working group consensus.
> 
> To that end, we'd like to run a consensus call to add a milestone 
> for doing these updates. It would be helpful to have reviews of
> this document before doing that call. I propose we allow a month
> (until Sep. 1) for such reviews, and then run the call.
> 
> 
> [1] 
> https://datatracker.ietf.org/__documents/LIAISON/liaison-__2012-09-21-codec-isoiec-jtc-__1sc-29wg-11-liaison-from-ietf-__codec-working-group-to-isoiec-__regarding-speech-and-audio-__coding-standardization-__attachment-1.pdf
>
> 
<https://datatracker.ietf.org/documents/LIAISON/liaison-2012-09-21-codec-isoiec-jtc-1sc-29wg-11-liaison-from-ietf-codec-working-group-to-isoiec-regarding-speech-and-audio-coding-standardization-attachment-1.pdf>
> 
> _________________________________________________ codec mailing
> list [email-masked] <mailto:[email-masked]> 
> https://www.ietf.org/mailman/__listinfo/codec 
> <https://www.ietf.org/mailman/listinfo/codec>
> 
> 
> 
> 
> _______________________________________________ codec mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/codec
>