Subject: Re: [codec] Huawei IPR disclosure 1712 against draft-ietf-codec-opus-11

From: Liujingrong <[email-masked]>
Date: Tue, 13 Mar 2012 17:55:32 +0000

Dear Stephan Wenger,
Thanks for your e-mail below.
This's Jill Liu from Legal Affairs Dept. of Huawei, owing to something wrong happened to the [email-masked]<mailto:[email-masked]> e-mail account and it cannot be fixed in days, please take this e-mail as a reply to your e-mail below.

So far Huawei thinks that the IPR **MAY** cover the I-D, a disclosure was therefore submitted. Regarding whether the I-D also relates to the issued patent, please give us more time to investigate.

With respect to the facts, what exactly happened under the "surface" is the IPR was just acquired by Huawei in November 2011, more details can be gathered from the USPTO website:
http://assignments.uspto.gov/assignments/q?db=pat&qt=pub&reel=&frame=&pat=&pub=20080154588&asnr=&asnri=&asne=&asnei=&asns=

After the acquisition, owing to evaluating the relevance between the IPR and the I-D and the Chinese new year holiday in Jan 2012, we have already made swift efforts to make the declaration in the best possible time frame.

In addition it is investigated that the previous patentee/inventor did not take part in the IETF activities, and none of Huawei personnel was involved in the IPR. Although Huawei personnel did occasionally comment in the codec WG on the subject draft, during the development of the I-D, Huawei had no prior knowledge of this IPR when the codec was developed in IETF. This IPR came to our attention through acquisition, and after noticing that it MAY cover the I-D, prompt efforts were taken to disclose it as soon as reasonably possible.

Referring back to your previous question, that's also the reason why we even do not have time to evaluate the issued patent and counterpart applications. However, in order to facilitate your work I have pushed my colleagues to accelarate the pace, hope an investigation result can be available within two weeks.

Best regards,
Ms. Jill Liu/Liu Jingrong
European IPR Division, Legal Affairs Dept.
Huawei Technologies Duesseldorf GmbH

3.0G, Dessauerstr.3,
80992 Munich, Germany
Phone: 0049-89-1430442128
Fax: 0049-89-1430442200
Mobile: 0049-(0)1622106251
E-mail: [email-masked]<mailto:[email-masked]>
http://www.huawei.com<http://www.huawei.com/>
-------------------------------------------------------------------------------------------------------------------------------------
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: den 13 mars 2012 00:22
To: [email-masked]
Cc: [email-masked]
Subject: [codec] Huawei IPR disclosure 1712 against draft-ietf-codec-opus-11

To: Huawei Director of Licensing
CC: IETF codec WG

Dear Director of Licensing,

I'm writing in my capacity as the technical advisor to the IESG on IPR matters related to the IETF's Codec WG, which is chartered to specify a speech/audio codec for the Internet.  I have a request for clarification and/or modification/amendment of the subject IPR disclosure, and a further request to reconsider the licensing term substance of the disclosure in the light of the disclosure timing.

It is my understanding, that the US patent application serial No. 11/942,118 "SPEECH CODING SYSTEM TO IMPROVE PACKET LOSS CONCEALMENT", that is currently declared against the opus draft, has issued in US patent 8,010,351 on August 30, 2011; please see http://portal.uspto.gov/external/portal/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3hff1NDc1NLYwN3SzcDA08PwyD_YF8zINcYKB-JW97AiCLdBgR0h4Nci992vPIGEHkDHMDRQN_PIz83Vb8gNzTCIDMgHQCGKKj-/dl3/d3/L0lDU0lKSWdrbUNTUS9JUFJBQUlpQ2dBek15cXpHWUEhIS80QkVqOG8wRmxHaXQtYlhwQUh0Qi83X01PNTE3NTkzMEc5RjAwSUgxUk9TTTYzMDI2LzhTa1lrODg0ODAwMjAvc2EuZ2V0Qmli/.

Please clarify whether the disclosure made also applies to the issued patent.  If yes, please submit an update to disclosure 1712.  You may also wish to disclose any possibly missing international counterparts, continuations, or divisionals.

Further, assuming that the disclosure also relates to the issued patent, and considering the relatively late disclosure ( a) The disclosure was made more than a year that the opus bitstream format has been stable, b) more than half a year since the scope of protection of the patent was known through the notice of allowance, and c) my understanding that Huawei personnel did occasionally comment in the codec WG on the subject draft), I would like to ask you to consider whether licensing terms more compatible with the expressed wishes of the WG (as expressed in the WG charter) could be made available.

If you wish to discuss either of these requests in person with me, please note that I am traveling internationally for the next three weeks, , and my cell phone will mostly be off.  I may not even check voicemail.  Please contact me by email for call logistics.

Thanks for your kind consideration.

Best regards,
Stephan Wenger

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 14 Mar 2012 07:39:57 +0000

Dear Mrs. Liu,
Thank you very much for your detailed, quick, and public reply to my inquiry, which in my opinion goes a long way in explaining the situation.  As you probably know, the IETF will have a face to face meeting in Paris, starting March 25.  Let me suggest that, in my opinion, most participants in the Codec working group would truly appreciate being informed of the results of your further investigations by this deadline.  I understand that this is an awfully tight schedule, but I can imagine that matching it would likely be to the benefit of both the Codec WG and your client.  If you need logistical help in conveying information, I would be more than willing to help.
Best regards,
Stephan

From: Liujingrong <[email-masked]<mailto:[email-masked]>>
Date: Tue, 13 Mar 2012 17:55:32 +0000
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [codec] Huawei IPR disclosure 1712 against draft-ietf-codec-opus-11

Dear Stephan Wenger,
Thanks for your e-mail below.
This’s Jill Liu from Legal Affairs Dept. of Huawei, owing to something wrong happened to the [email-masked]<mailto:[email-masked]> e-mail account and it cannot be fixed in days, please take this e-mail as a reply to your e-mail below.

With respect to the facts, what exactly happened under the “surface” is the IPR was just acquired by Huawei in November 2011, more details can be gathered from the USPTO website:
http://assignments.uspto.gov/assignments/q?db=pat&qt=pub&reel=&frame=&pat=&pub=20080154588&asnr=&asnri=&asne=&asnei=&asns=

Referring back to your previous question, that’s also the reason why we even do not have time to evaluate the issued patent and counterpart applications. However, in order to facilitate your work I have pushed my colleagues to accelarate the pace, hope an investigation result can be available within two weeks.

Best regards,

3.0G, Dessauerstr.3,
80992 Munich, Germany

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: den 13 mars 2012 00:22
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [codec] Huawei IPR disclosure 1712 against draft-ietf-codec-opus-11

Best regards,
Stephan Wenger

_______________________________________________ codec mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/codec

---

From: Liujingrong <[email-masked]>
Date: Wed, 14 Mar 2012 09:05:00 +0000

Dear Mr. Stephan Wenger,
Thanks for your e-mail below.
We have already adjusted our schedule as suggested by you and will try our best to have a result before March 25, but taking unknown factors which may happen into account, we really cannot hundred percent guarantee this. However I'm sure you will be well and timely informed no matter we can make it or not.

Best regards,

3.0G, Dessauerstr.3,
80992 Munich, Germany

From: Stephan Wenger [mailto:[email-masked]]
Sent: Wednesday, March 14, 2012 8:40
To: Liujingrong
Cc: [email-masked]
Subject: Re: [codec] Huawei IPR disclosure 1712 against draft-ietf-codec-opus-11

Dear Mrs. Liu,

Dear Stephan Wenger,

Best regards,

3.0G, Dessauerstr.3,
80992 Munich, Germany

Best regards,
Stephan Wenger