Subject: [codec] Tübingen Test plan

From: "Christian Hoene" <[email-masked]>
Date: Sun, 14 Aug 2011 15:22:21 +0200

Hi, 

I was compiling the following tests plan for Tuesday.

Any comments and hint to improve the test plan?

With best regards,

Christian

Testplan for MUSHRA Listening Tests 
Focusing on a Conferencing Scenario

Mansoor Hyder, Christian Hoene
Universität Tübingen
14. August 2011

Test setup

MUSHRA tests following the recommendation ITU-R BS 1584.1 will take place on August 16th, from 9:00 till 19:00 in the office B303/B304 at the building Sand 13 in 72076 Tübingen.

Tests will be done with Sennheiser HD 280 pro headphones, a PC and the software „RateIt“ version 0.1.

Twenty participants have been selected from employees and students of the University of Tübingen. They have well to very good hearing abilities. Participant will receive soft drinks and/or coffee and 8 € compensation. 

Each session will last at most 60 minutes. This includes 15 to 20 minutes for explaining and practicing the tests, 25 to 30 minutes of testing, and 5 to 10 minutes of interviewing and farewell.

In total, 40 stimuli will be tested (in addition to the references).

Test stimuli

The focus of the stimuli is on a conferencing scenario, in which multiple persons speak at the same time. Only stereo test stimuli will be taken and only stereo coding modes will be tested.

Five different reference samples will be taken:

1.       A female German (¼ right channel, ¾ left channel)

2.       Two female voice (¼ right/left channel, ¾ left/right channel)

3.       One female voice, panning moving

4.       Two female voices, panning, rendered with a HRTF

5.       Music (Suzanne Vega singing or similar)

The following codec and codec modes will be tests

1.       Opus, Silk mode, stereo, high complexity, 20ms frame size, at 16 kbps.

2.       Opus, Hybrid mode, stereo, high complexity, 20ms frame size, at 32 kbps

3.       Opus, Celt mode, high complexity, stereo, 20ms frame size at 64 kbps

4.       Opus, Celt mode, high complexity, stereo, 5ms frame size, at 96 kbps

5.       G.719, stereo, at 2x48 kbps

6.       AMR-WB+, stereo, at 2x7,95 kbps

7.       AMR-WB+, stereo, at 2x15,85 kbps

8.       TBD, stereo at 64 kbits, 20ms frame size

In total, 5x8=40 stimuli are going to be tested.

---------------------------------------------------------------------------------

Dr.-Ing. Christian Hoene, University of Tübingen, Computer Science, Chair of

Communication Networks, Research Group Interactive Communication Systems (ICS)

Sand 13, 72076 Tübingen, Germany, Tel +49 7071 2970532, www.net.uni-tuebingen.de

---

From: "Christian Hoene" <[email-masked]>
Date: Sun, 14 Aug 2011 21:34:31 +0200

Hi,

Thanks for the input. I have updated the test plan:

Version 2

Test setup

MUSHRA tests following the recommendation ITU-R BS 1584.1 will take place on August 16th, from 9:00 till 19:00 in the office B303/B304 at the building Sand 13 in Tübingen, Germany.

Each session will last at most 60 minutes. This includes 15 to 20 minutes for explaining and practicing the tests, 25 to 30 minutes of testing, and 5 to 10 minutes of questioning and farewell.

Test stimuli

1.       Female German voice (stereo)

2.       Two female voices (stereo, cross talking)

3.       One female voice (binaural rendered, moving)

4.       Two female voices (binaural rendered, cross talking)

5.       Music (an acappella  song by “Die Prinzen”)

5.       G.719, stereo, at 2x32 kbps (Fix-point-200806-Release-1.0a)

6.       AMR-WB+, stereo, at 16 kbps (Code from TS 26304 Version 6.6)

7.       AMR-WB+, stereo, at 32 kbps (Code from TS 26304 Version 6.6)

8.        TBD, stereo at 64 kbps, 20ms frame size

Script to make stimuli

#!/bin/bash

OPUS=../opus.testing/draft-ietf-codec-opus-07/test_opus

G719e=../G.719-Fix-point-200806-Release-1.0a/out/encoder 

G719d=../G.719-Fix-point-200806-Release-1.0a/out/decoder

AMRWBPe="wine ../26304_ANSI-C_source_code_v6_6_0/encoder"

AMRWBPd="wine ../26304_ANSI-C_source_code_v6_6_0/decoder"

I=1

for file in ../reference\ items/*\.wav

do

    echo $I $file

    sox "$file" -r48000 -c2 input.sw

    $OPUS 0 48000 2 16000 -cbr -framesize 20 -bandwidth WB input.sw output.sw >/dev/null

    sox -r48000 -c2 output.sw $I-opus.16k.wav 

    $OPUS 0 48000 2 32000 -cbr -framesize 20 -bandwidth FB input.sw output.sw >/dev/null

    sox -r48000 -c2 output.sw $I-opus.32k.wav

    $OPUS 1 48000 2 64000 -cbr -framesize 20 -bandwidth FB input.sw output.sw >/dev/null

    sox -r48000 -c2 output.sw $I-opus.64k.wav

    $OPUS 1 48000 2 96000 -cbr -framesize 2.5 -bandwidth FB input.sw output.sw >/dev/null

    sox -r48000 -c2 output.sw $I-opus.96k.wav

    rm output.sw

    sox -r48000 -c2 input.sw -r48000 -c1 left.sw remix 1 0

    sox -r48000 -c2 input.sw -r48000 -c1 right.sw remix 0 1

    $G719e -r 32000 -i left.sw -o left.g192

    $G719e -r 32000 -i right.sw -o right.g192

    $G719d -i left.g192 -o outleft.sw

    $G719d -i right.g192 -o outright.sw

    sox -r48000 -c1 outleft.sw -c2 outleft.wav remix 1 0 

    sox -r48000 -c1 outright.sw -c2 outright.wav remix 0 1

    sox -m outleft.wav outright.wav $I-g719.64k.wav

    rm left.sw right.sw left.g192 right.g192 outleft.sw outright.sw 

    rm outleft.wav outright.wav input.sw

    $AMRWBPe -rate 16 -if "$file" -of out.wb+

    $AMRWBPd  -if out.wb+ -of $I-amrwbp.16k.wav

    $AMRWBPe -rate 32 -if "$file" -of out.wb+

    $AMRWBPd -if out.wb+ -of $I-amrwbp.32k.wav

    rm out.wb+

    sox "$file" -r48000 -c2 $I-reference.wav

    sox "$file" -r48000 -c2 $I-hidden.wav

    sox "$file" -r48000 -c2 $I-anchor.wav lowpass 3500

    let I=$I+1

done

Sand 13, 72076 Tübingen, Germany, Tel +49 7071 2970532, www.net.uni-tuebingen.de <http://www.net.uni-tuebingen.de/> 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christian Hoene
Sent: Sunday, August 14, 2011 3:22 PM
To: [email-masked]
Subject: [codec] Tübingen Test plan

Hi, 

With best regards,

Christian

---

From: Koen Vos <[email-masked]>
Date: Sun, 14 Aug 2011 22:28:09 +0200 (CEST)

Hi Christian, 

What audio bandwidths are you planning to use for the Opus test cases? 

You should probably call the SILK and Hybrid modes just "Voice" mode, and the CELT mode "Audio" mode. 

best, 
koen. 

----- Original Message -----
From: "Christian Hoene" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, August 14, 2011 12:34:31 PM 
Subject: Re: [codec] Tübingen Test plan 

Hi, 

Version 2 Test setup 

In total, 40 stimuli will be tested (in addition to the references). Test stimuli 

In total, 5x8=40 stimuli are going to be tested. Script to make stimuli 

#!/bin/bash 

I=1 

do 

echo $I $file 

rm output.sw 

rm out.wb+ 

let I=$I+1 

done 

Hi, 

With best regards, 

Christian 

_______________________________________________ 
codec mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/codec

---

From: "Christian Hoene" <[email-masked]>
Date: Mon, 15 Aug 2011 10:26:48 +0200

Hi Koen,

[Christian Hoene] Actually, Opus selects the mode by itself. I have printed out the following data

Mode CELT bitRate 64000 fs 48000 channels 2 framesize 960

Mode CELT bitRate 96000 fs 48000 channels 2 framesize 120

Mode HYBRID bitRate 32000 fs 48000 channels 2 framesize 960

Mode SILK bitRate 16000 fs 48000 channels 2 framesize 960

With best regards,

Christian Hoene

  _____  

Hi,

 

Test setup

Test stimuli

Script to make stimuli

#!/bin/bash

I=1

do

    echo $I $file

    rm output.sw

    rm out.wb+

    let I=$I+1

done

Hi, 

With best regards,

Christian

---

From: "Benjamin M. Schwartz" <[email-masked]>
Date: Mon, 15 Aug 2011 14:00:09 -0400

> */[Christian Hoene] Actually, Opus selects the mode by itself. I have
> printed out the following data/*
...
> */Mode HYBRID bitRate 32000 fs 48000 channels 2 framesize 960/*
> 
> */Mode SILK bitRate 16000 fs 48000 channels 2 framesize 960/*

I'm not sure what you mean by "printed out" ... but bear in mind that Opus
always supports a samplerate (fs) of 48000, regardless of the audio
bandwidth.  I believe the current encoder's bandwidth-selection heuristics
would code 16kbps stereo Silk at Narrowband (4 kHz bandpass), and 32kbps
stereo Hybrid at Superwideband (12 kHz bandpass).

--Ben