Subject: [codec] Planning of further codec testing

From: Christian Hoene <[email-masked]>
Date: Thu, 4 Aug 2011 21:37:18 +0200

Hi all,

for the week of August 15th, I am planning to do some MUSHRA testing with
Opus.

The focus will be on dual voices in mono and stereo Silk mode and binaural
voice content in stereo Silk, hybrid and CELT mode. More details are yet to
be defined.

I would also like to compare Opus against some other stereo codecs such as
G.718. Do you have any other suggestions on which interactive stereo codec
to take? Does anybody know how to get an AAC-LD encoder and decoder? 

Thanks for any help.

With best regards,

 Christian Hoene

PS:
The ITU-T has these test signals are to be found here:
http://www.itu.int/net/itu-t/sigdb/menu.htm

---

From: Stephen Botzko <[email-masked]>
Date: Fri, 5 Aug 2011 06:24:02 -0400

I believe you will find that while there is a standard decoder, there is no
reference AAC-LD encoder available.

Regards,
Stephen Botzko

On Thu, Aug 4, 2011 at 3:37 PM, Christian Hoene <
[email-masked]> wrote:

> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec
>

---

From: Gregory Maxwell <[email-masked]>
Date: Fri, 5 Aug 2011 07:26:53 -0700

Christian Hoene [[email-masked]] wrote:
> Does anybody know how to get an AAC-LD encoder and decoder?

I was hoping someone would provide a better answer:

There is an implementation of an AAC-LD encoder and decoder
included with Apple computers.  People with quicktime pro
installed are able to select it and write AAC-LD to mp4 files and
decode from them to wav.

As I recall the encoder's selection is some limited in terms of
supported sample/bitrates, and doesn't present pretty much
any options, I seem to recall it using the larger of the supported
frame sizes, and also having extensive bitres usage (not really
hard CBR).   "Take it or leave it". 

If you use it you will want to be careful to check to see the
the files it wrote were what you wanted and not some other
codec.

I'm also not sure if it's a particularly good implementation or
not, but it seemed to work okay.

---

From: Anisse Taleb <[email-masked]>
Date: Fri, 05 Aug 2011 15:40:28 +0000

Dear Christian, Gregory

Just a suggestion....to get an AAC-LD or ELD (enhanced low delay), encoder and decoder you probably would like to get in touch with the folks in FhG IIS (Markus Schnell or Ralf Geiger). I am not sure they would be willing to provide you with a complete suite of encoder and decoder, however, they could encode the items for you if you provide them with the input wavefiles...It's worth a shot.

I am personally skeptical to using the workaround suggested by Gregory, the encoder and decoder may be subject to some obscure EULA and it is not clear what delay this implementation has and the reported limited set of bitrates and actual quality. It is however a good fallback if FhG is unwilling to help with this.

Kind regards,
/Anisse
________________________________________
From: [email-masked] [[email-masked]] on behalf of Gregory Maxwell [[email-masked]]
Sent: 05 August 2011 16:26
To: Christian Hoene; [email-masked]
Subject: Re: [codec] Planning of further codec testing

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 05 Aug 2011 11:54:28 -0400

I seem to remember that Jan Skoglund also attempted -- without success
-- to get access to AAC-LD for the previous Google test. Might still be
worth trying, but I wouldn't count on getting access to it.

	Jean-Marc

On 11-08-05 11:40 AM, Anisse Taleb wrote:
> Dear Christian, Gregory
> 
> Just a suggestion....to get an AAC-LD or ELD (enhanced low delay),
> encoder and decoder you probably would like to get in touch with the
> folks in FhG IIS (Markus Schnell or Ralf Geiger). I am not sure they
> would be willing to provide you with a complete suite of encoder and
> decoder, however, they could encode the items for you if you provide
> them with the input wavefiles...It's worth a shot.
> 
> I am personally skeptical to using the workaround suggested by
> Gregory, the encoder and decoder may be subject to some obscure EULA
> and it is not clear what delay this implementation has and the
> reported limited set of bitrates and actual quality. It is however a
> good fallback if FhG is unwilling to help with this.
> 
> Kind regards, /Anisse ________________________________________ From:
> [email-masked] [[email-masked]] on behalf of Gregory
> Maxwell [[email-masked]] Sent: 05 August 2011 16:26 To:
> Christian Hoene; [email-masked] Subject: Re: [codec] Planning of
> further codec testing
> 
> There is an implementation of an AAC-LD encoder and decoder included
> with Apple computers.  People with quicktime pro installed are able
> to select it and write AAC-LD to mp4 files and decode from them to
> wav.
> 
> supported sample/bitrates, and doesn't present pretty much any
> options, I seem to recall it using the larger of the supported frame
> sizes, and also having extensive bitres usage (not really hard CBR).
> "Take it or leave it".
> 
> If you use it you will want to be careful to check to see the the
> files it wrote were what you wanted and not some other codec.
> 
> I'm also not sure if it's a particularly good implementation or not,
> but it seemed to work okay.
> 
> 
> _______________________________________________ codec mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/codec 
> _______________________________________________ codec mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/codec
> 
>