Subject: [codec] draft-ietf-codec-opus-07: Compiler warning

From: "Christian Hoene" <[email-masked]>
Date: Mon, 25 Jul 2011 07:01:37 -0400

Hi,

Attached you find a patch to remove some compiler warnings. I was using the
latest Ubuntu.
The HAVE_LRINTF" is nowhere defined because configure.sh is missing. 

CH

---

From: Ralph Giles <[email-masked]>
Date: Mon, 25 Jul 2011 13:04:17 -0700

> The HAVE_LRINTF" is nowhere defined because configure.sh is missing.

I think a better fix would be to just add HAVE_LRINTF to the options
at the top of the makefile. Depending on GNUC assumes gcc is in C99
mode.

MS_predictorIx is indeed an unused variable.

The unused warning against lost in test_opus.c is incorrect, but
initializing it to zero looks safe to me.

 -r