Subject: Re: [codec] [payload] Padding in draft-ietf-codec-opus-07?

From: Stephen Botzko <[email-masked]>
Date: Mon, 25 Jul 2011 13:24:46 -0400

I think RTP padding should be sufficient.

Regards,
Stephen

Sent from my Verizon Wireless Device

Christian Hoene <[email-masked]> wrote:

>Hello,
>
>I am wondering about a padding feature in draft-ietf-codec-opus-07. It
>allows you to extend the frame size by filling it up with zeros.
>
> I just spoke with the Tim, Jean-Marc and Gregory about this feature. As far
>as I understood, this feature is required at transcoding gateways to enforce
>a stream of packets having a constant size (while using UDP). Otherwise,
>attackers could potentially follow the conversation by observing packet
>sizes. 
>
>To my understanding, padding is a feature that can be easily skipped from
>the codec specification. It violates the layering principle and is intended
>only for a very specific use cases. On the other side, constant sized frames
>can be easily supported by keeping the codec parameters fixed.
>
>With best regards,
>
> Christian Hoene
>
>
>
>----------------------------------------------------------------------------
>-----
>Dr.-Ing. Christian Hoene, University of Tübingen, Computer Science, Chair of
>Communication Networks, Research Group Interactive Communication Systems
>(ICS)
>Sand 13, 72076 Tübingen, Germany, Tel +49 7071 2970532,
>www.net.uni-tuebingen.de
>
>
>
>_______________________________________________
>payload mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/payload

---

From: Jean-Marc Valin <[email-masked]>
Date: Mon, 25 Jul 2011 17:12:09 -0400

> I think RTP padding should be sufficient.

Well, it is possible for Opus to be transmitted in real-time over
something other than RTP. Also, even for RTP, there's the issue that the
padding bit is transmitted in the clear, which would impose padding even
frames that would not otherwise need padding.

	Jean-Marc

> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: "Christian Hoene" <[email-masked]>
Date: Mon, 25 Jul 2011 17:41:39 -0400

> something other than RTP. 

 [Christian Hoene] Yes, know I remember the discussion. You are meaning
Bluetooth links, don't you?

---

From: "Wyss, Felix" <[email-masked]>
Date: Mon, 25 Jul 2011 22:08:31 +0000

Another challenge with relying on RTP padding is communicating the maximum packet size for padding from the encoder to the RTP/SRTP stack.  Of course, this could be done implicitly by having the RTP/SRTP sender maintain a "high watermark" of payload sizes seen, but that would still leak information.  Dependencies and forced "abstraction leaks" between layers increase implementation complexity, may result in subtle security bugs, and risk incompatibilities.  RTP padding is not common, so there _will_ be vendors that get it wrong when they get padded packets.

My vote is for *NOT* relying on RTP padding for conversation masking.  

--Felix

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jean-Marc Valin
> Sent: Monday, July 25, 2011 17:12
> To: Stephen Botzko
> Cc: [email-masked]
> Subject: Re: [codec] [payload] Padding in draft-ietf-codec-opus-07?
> 
> >> I am wondering about a padding feature in draft-ietf-codec-opus-07.
> >> It allows you to extend the frame size by filling it up with zeros.
> >>
> >> I just spoke with the Tim, Jean-Marc and Gregory about this feature.
> >> As far as I understood, this feature is required at transcoding
> >> gateways to enforce a stream of packets having a constant size (while
> >> using UDP). Otherwise, attackers could potentially follow the
> >> conversation by observing packet sizes.
> >>
> >> To my understanding, padding is a feature that can be easily skipped
> >> from the codec specification. It violates the layering principle and
> >> is intended only for a very specific use cases. On the other side,
> >> constant sized frames can be easily supported by keeping the codec
> parameters fixed.
> >>
> >> With best regards,
> >>
> >> Christian Hoene
> >>
> >>
> >>
> >> Dr.-Ing. Christian Hoene, University of Tübingen, Computer Science,
> >> Chair of Communication Networks, Research Group Interactive
> >> Communication Systems
> >> (ICS)