Subject: Re: [codec] Last Call: <draft-ietf-codec-requirements-04.txt> (Codec Requirements) to Informational RFC

From: "Christian Hoene" <[email-masked]>
Date: Thu, 16 Jun 2011 22:42:23 +0200

Hello,

In this draft, the editors of draft are not named as editors but as authors.
Thus, I would suggest to follow the example given in
http://www.rfc-editor.org/rfc/rfc5620.txt and add an ", Ed." behind the
names. A list of authors is given in the acknowledgement section of the
draft.

With best regards,

 Christian Hoene

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of The IESG
> Sent: Thursday, June 16, 2011 9:24 PM
> To: IETF-Announce
> Cc: [email-masked]
> Subject: [codec] Last Call: <draft-ietf-codec-requirements-04.txt> (Codec
> Requirements) to Informational RFC
> 
> 
> The IESG has received a request from the Internet Wideband Audio Codec
> WG
> (codec) to consider the following document:
> - 'Codec Requirements'
>   <draft-ietf-codec-requirements-04.txt> as an Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2011-06-30. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    This document provides specific requirements for an Internet audio
>    codec.  These requirements address quality, sampling rate, bit-rate,
>    and packet loss robustness, as well as other desirable properties.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-codec-requirements/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-codec-requirements/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 20 Jun 2011 07:31:47 -0600

This is all a sort of confusing point of many IETF documents and not unique to this one. I think the important points is that for many IETF documents, the people listed on the front page are not the authors. Typically the list of authors is a much longer list. And to clarify what I mean by Author, I mean it in the sense that it would used in copyright law. I do think the Acknowledgements section needs to identity anyone who is a contributor to the document. The limit on number of people on the front pages makes it impossible to even put all the authors on the front page if we wanted to. 

So my main point is, just because someone is listed on front page or not, should not be used to decide if they are an author or not. 

The use of "Ed." has been a bit inconsistent at the IETF and I'm not aware of good guidelines on how and when to use it. Traditionally when we have had a few people producing the drafts and incorporating work from the multiple people in on the mailing list, the people where were actively editing the document have often been listed on the front page. There are many exception to this - I was a bit cheesed to not be listed on the front page of RFC 4244. 

Back to the matter at hand ... This is a pretty classic sort of document where an individual draft got selected as a basis for the WG document, multiple people in the WG contributed text, a final draft was produced. Historically, most IETF docs like this do not put "Ed" after all the people on the front page. However, perhaps we should, I don't really have any strong opinion one way or the other. I can confirm that this document, like many documents coming out of a WG,  includes contribution from people beyond the list of names on the front page. 

Cullen

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Jun 2011 18:02:04 +0200

> This is all a sort of confusing point of many IETF documents and not unique to this one. I think the important points is that for many IETF documents, the people listed on the front page are not th…

Ceterum censeo: A situation that is untenable.

(And that may actually be problematic in countries with droit d'auteur/Urheberrecht such as Germany, but that's not my point.)

Gruesse, Carsten

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 17 Jun 2011 16:31:29 -0400

> names. A list of authors is given in the acknowledgement section of the

If everyone listed at the upper right of the first page is going to be
an Editor, then adding "Ed." after their name is completely
superfluous and adds only clutter.

Traditionally, those listed at the upper right of the first page of an
RFC have been called "authors" in most cases, regardless of their
actual role, and those listed in an Acknowledgements section have
frequently been called "contributors" or the like. So I think it s
perfectly fine the way it is in regards to this non-issue.

Donald

> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>