Subject: [codec] USAC as reference?

From: "Christian Hoene" <[email-masked]>
Date: Thu, 14 Apr 2011 17:57:12 +0200

Hi Anisse,

It is possible you ask your colleagues (e.g. David Virette) whether we can
access a reference implementation of USAC? It would be quite interesting to
watch the contest Opus vs. USAC. 

Do you have any internal data on this, which you want to share?

With best regards,

 Christian

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), Universität Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

---

From: Anisse Taleb <[email-masked]>
Date: Thu, 14 Apr 2011 19:43:02 +0000

Dear Christian, 

I believe this could be an interesting contest. MPEG is currently in the process of conducting verification tests for the USAC standard and one could seize this opportunity to include Opus in the MPEG tests.

However, formally, this should be a request directed to MPEG and not to me or David. The next MPEG meeting will be held in Torino (Italy) from  11/07/18-22, and I think the chairs could send a Liaison to MPEG on this topic.

Kind regards,
/Anisse

> -----Original Message-----
> From: Christian Hoene [mailto:[email-masked]]
> Sent: Thursday, April 14, 2011 5:57 PM
> To: Anisse Taleb
> Cc: [email-masked]
> Subject: USAC as reference?
> 
> Hi Anisse,
>

---

From: Stephen Botzko <[email-masked]>
Date: Thu, 14 Apr 2011 15:49:38 -0400

Sounds like a way to get "free" testing!

Stephen Botzko

On Thu, Apr 14, 2011 at 3:43 PM, Anisse Taleb <[email-masked]>wrote:

> Dear Christian,
>
> I believe this could be an interesting contest. MPEG is currently in the
> process of conducting verification tests for the USAC standard and one could
> seize this opportunity to include Opus in the MPEG tests.
>
> However, formally, this should be a request directed to MPEG and not to me
> or David. The next MPEG meeting will be held in Torino (Italy) from
>  11/07/18-22, and I think the chairs could send a Liaison to MPEG on this
> topic.
>
> Kind regards,
> /Anisse
>
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec
>

---

From: David Virette <[email-masked]>
Date: Fri, 15 Apr 2011 16:02:01 +0200

Dear Christian, all,
The only reference quality implementation of USAC is owned by the initial
proponents of the codec. If the group wants to test OPUS vs USAC, the best
way is probably to inform MPEG that IETF would like to conduct some tests
comparing those two codecs. Regarding the inclusion of OPUS in the USAC
verification tests, the test plan and accompanying workplan have already
been agreed and the first round of testing will occur in June. However, it
is foreseen to have a second round of testing by the end of the year. It
could be proposed to include OPUS in this second phase. As Anisse said,
there will be an MPEG meeting in July, this leaves enough time to liaise
with MPEG before the next meeting. But I think that only a standardized
codec could be included in the USAC verification tests.
Best regards,
David

David Virette
HUAWEI TECHNOLOGIES CO.,LTD. 

Building C
Riesstrasse 25
80992 Munich, Germany
Tel: +49 89 158834 4148
Fax: +49 89 158834 4447
Mobile: +49 1622047469
E-mail: [email-masked]
www.huawei.com
----------------------------------------------------------------------------
---------------------------------------------------------
This e-mail and its attachments contain confidential information from
HUAWEI, which 
is intended only for the person or entity whose address is listed above. Any
use of the 
information contained herein in any way (including, but not limited to,
total or partial 
disclosure, reproduction, or dissemination) by persons other than the
intended 
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by 
phone or email immediately and delete it!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Christian Hoene
Sent: jeudi 14 avril 2011 17:57
To: 'Anisse Taleb'
Cc: [email-masked]
Subject: [codec] USAC as reference?

Hi Anisse,

With best regards,

 Christian

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 15 Apr 2011 11:50:16 -0400

Hi David,

> codec could be included in the USAC verification tests.

I think it's indeed a good idea to liaise with MPEG before the next meeting 
to get Opus included in the second round of USAC testing. I think the 
condition that only standardized codecs can be included again supports the 
idea of first publishing Opus as a proposed standard to facilitate further 
testing.

Cheers,

	Jean-Marc

---

From: Stephen Botzko <[email-masked]>
Date: Fri, 15 Apr 2011 14:09:19 -0400

If we can commit to having the bitstream frozen before the next round of
USAC verification tests, then we can certainly say that in the Liaison, and
request that they include it in their verification tests.

It's up to them to say no.

Regards
Stephen Botzko

---

From: David Virette <[email-masked]>
Date: Mon, 18 Apr 2011 22:24:51 +0200

Hi Jean-Marc,
Of course IETF can liaise with MPEG asking to include OPUS in USAC
verification tests, but I am a bit skeptical that OPUS will be included in
their extensive testing if a sufficient testing effort is not done in IETF
before.
By extensive listening tests, I mean a verification test where more than 15
listening labs will take part to the first round of listening to conduct
between 1 and 3 experiments each.
Best regards,
David

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: vendredi 15 avril 2011 17:50
To: David Virette
Cc: 'Christian Hoene'; 'Anisse Taleb'; [email-masked]
Subject: Re: [codec] USAC as reference?

Hi David,

Cheers,

	Jean-Marc