Subject: [codec] I-D Action:draft-ietf-codec-opus-05.txt

From: [email-masked]
Date: Mon, 14 Mar 2011 15:15:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Wideband Audio Codec Working Group of the IETF.

	Title           : Definition of the Opus Audio Codec
	Author(s)       : J. Valin, K. Vos
	Filename        : draft-ietf-codec-opus-05.txt
	Pages           : 199
	Date            : 2011-03-14

This document describes the Opus codec, designed for interactive
speech and audio transmission over the Internet.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-codec-opus-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Jean-Marc Valin <[email-masked]>
Date: Tue, 15 Mar 2011 01:15:36 -0400

Hi,

Just to let you know that the main change in that latest version is the 
ability to decode multi-frame packets. That code has received very 
little testing, so don't be surprised if it breaks. However, I did some 
amount of testing to at least make sure that random inputs do not cause 
buffer overruns and similar security issues.

Cheers,

	Jean-Marc

On 11-03-14 06:15 PM, [email-masked] wrote:
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Keith Yan <[email-masked]>
Date: Wed, 16 Mar 2011 11:33:21 +0800

Dear Jean-Marc,
I have tested V0.9.2 code, and find if enable DTX, it will return from range checking, error code is Error: Range coder state mismatch between encoder and decoder.
And if not define OPUS_TEST_RANGE_CODER_STATE, the decoded file has sharp noise in the silence area. The left channel of test.wav is origin voice, and the right channel is encode/decode with DTX enabled.

Please check it.

Thanks
Keith

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: 2011年3月15日 13:16
To: [email-masked]
Subject: Re: [codec] I-D Action:draft-ietf-codec-opus-05.txt

Hi,

Cheers,

	Jean-Marc

---

From: Jean-Marc Valin <[email-masked]>
Date: Wed, 16 Mar 2011 00:09:01 -0400

Hi Keith,

Thanks a lot for the bug report. I can reproduce the problem easily so 
it shouldn't be very hard to fix. I'll let you know when we have a fix.

Cheers,

	Jean-Marc

---

From: Jean-Marc Valin <[email-masked]>
Date: Thu, 17 Mar 2011 10:05:54 -0400

Hi Keith,

Just to let you know that the DTX problem should now be fixed in git. We're 
still investigating a rare glitch that occurs at high bit-rate, but 
otherwise it should work fine. Could you test this and confirm? If you 
can't access the git repository, I can send you a tarball.

Cheers,

	Jean-Marc

On 11-03-15 11:33 PM, Keith Yan wrote:
> Sent: 2011Äê3ÔÂ15ÈÕ 13:16
> To: [email-masked]

---

From: Jean-Marc Valin <[email-masked]>
Date: Thu, 17 Mar 2011 18:21:52 -0400

OK, we just found and fixed the last known bug in the DTX code. It should 
now work fine. Let me know if there's still any problem.

Cheers,

	Jean-Marc

On 11-03-17 10:05 AM, Jean-Marc Valin wrote:
>> I have tested V0.9.2 code, and find if enable DTX, it will return from
>> range checking, error code is Error: Range coder state mismatch between
>> encoder and decoder.
>> And if not define OPUS_TEST_RANGE_CODER_STATE, the decoded file has sharp
>> noise in the silence area. The left channel of test.wav is origin voice,
>> and the right channel is encode/decode with DTX enabled.
>>
>> Please check it.
>>
>> Thanks
>> Keith
>>
>>

---

From: Keith Yan <[email-masked]>
Date: Fri, 18 Mar 2011 18:39:16 +0800

Hi Jean-Marc,
I have done testing on new codes, it's ok for DTX and PLC.

Thanks
Keith

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: 2011年3月18日 6:22
To: Keith Yan
Cc: [email-masked]
Subject: Re: [codec] I-D Action:draft-ietf-codec-opus-05.txt

Cheers,

	Jean-Marc

---

From: Keith Yan <[email-masked]>
Date: Tue, 22 Mar 2011 14:03:02 +0800

Dear Jean-Marc,

         I have done some FEC related testing based on V0.9.3, from the test result, Opus can congest lost rate <10% well, but to high lost rate, it performances not as well as SILK.

I do a competition with SILK V1.0.7. Following is my test condition:

a.       Set encode bitrates to 40kbps

b.       Enable inband FEC and set max lost rate is 20%

c.       Set OPUS_MODE_VOICE for Opus V0.9.3, MODE_SILK_ONLY for Opus V0.9.1, and set BANDWIDTH_WIDEBAND for V0.9.3 and V0.9.1.

Test it in different lost rate condition, then compute PESQ and PESQ-LQO for result file. From following table, we can see that Opus can’t congest 20% lost rate as well as SILK.

Would you please help to check it.

Regards

Keith

---

From: Koen Vos <[email-masked]>
Date: Sun, 27 Mar 2011 15:18:43 +0200 (CEST)

Hi Keith, 

Thanks for your report. 

The in-band FEC in OPUS Voice mode is a bit different from SILK's in that SILK keeps a separate full state of the noise shaping quantizer for the in-band FEC coding, whereas OPUS copies the state of the regular noise shaping quantizer before coding the FEC data. This reduces the OPUS state size by ~4 kB. There are other examples of where OPUS quality was slightly reduced in favor of complexity or memory. In my experience, packet loss above about 10% is typically of rather bursty nature, meaning that FEC won't be very helpful anyway. 

The good news is that the in-band FEC is still very effective at dealing with (random) packet loss, as suggested by the plot below (again WB speech coded at 40 kbps). 

I'll continue to look for ways to improve quality. 

best, 
koen. 

----- Original Message -----
From: "Keith Yan" <[email-masked]> 
To: "Keith Yan" <[email-masked]>, "Jean-Marc Valin" <[email-masked]> 
Cc: [email-masked] 
Sent: Tuesday, March 22, 2011 7:03:02 AM 
Subject: [codec] I-D Action:draft-ietf-codec-opus-05.txt 

Dear Jean-Marc, 

Test it in different lost rate condition, then compute PESQ and PESQ-LQO for result file. From following table, we can see that Opus can ’ t congest 20% lost rate as well as SILK. 

Regards 

Keith