Subject: [codec] A slimmer specification

From: Erik Norvell <[email-masked]>
Date: Thu, 31 Mar 2011 15:04:43 +0200

Hi all,

Thank you for the meeting today. Unfortunately the meeting time ran fast and there was not enough time to cover the technical status of Opus. Related to this, I think Stephan Wenger raised an important point in his final slide (http://tools.ietf.org/agenda/80/slides/codec-0.pptx). I see that building a feature-rich codec may be beneficial for the users, but it also comes with the risk of including IPRs. A slimmer specification is safer from an IPR perspective and it should also make the testing effort easier - a matter which was also heavily debated in the meeting.

Balancing technology benefit versus IPR risk is difficult. I suggested earlier to test against the baseline codecs as a measure of the benefit, but I admit that this might not be the right tool. However, reducing the IPR risk is important and we need some way to reach this goal.

Best regards,
Erik

---

From: Gregory Maxwell <[email-masked]>
Date: Thu, 31 Mar 2011 06:45:25 -0700

> Balancing technology benefit versus IPR risk is difficult. I suggested earlier to test against the baseline codecs as a measure of the benefit, but I admit that this might not be the right tool. Ho…

Greetings,   

What causes you to conclude that there hasn't already been substantial effort put into exactly this sort of balance?   We've been asked not to discuss specific IPR issues on the list,  so you should not expect to see too much detailed debate on the fine points of this.   The importance of producing a result without IPR problems is clearly stated in the Working Group charter,  and I can say with confidence that for many participants it has been considered an engineering requirement of equal or greater importance to any of the other requirements.

If you have any specific areas of concern where you believe we could make an improvement I would be interested in hearing about them off the list.