Subject: [codec] Draft Agenda for CODEC at IETF 80 Version 1

From: Cullen Jennings <[email-masked]>
Date: Thu, 17 Mar 2011 00:14:32 -0600

Let us know what we need to change .... Thanks

---------------------------------------------------

Admin (10 min)

Liaison Updates (5 min)

Opus Update (30 min) 
draft-ietf-codec-opus-05

How to proceed with WGLC of Opus? (30 min)
Helpful to read:
draft-ietf-codec-requirements-02
draft-ietf-codec-guidelines-00
draft-hoene-codec-quality-00

Guidelines (20 min) 
draft-ietf-codec-guidelines-00

Other Items?

---

From: Anisse Taleb <[email-masked]>
Date: Thu, 17 Mar 2011 09:29:02 +0000

Dear Cullen, 
Thanks for preparing the agenda. I am a bit concerned that we start discussing the WGLC of Opus before discussing the process which is documented in draft-ietf-codec-guidelines-00. Regardless of the ordering of the agenda items, I am in fact more concerned that we are starting to talk about WGLC when almost no formal tests have been conducted. 

My understanding of the document draft-ietf-codec-guidelines-00 is that it provides steps (section 2) that the work is expected to follow. As far as I know we are still in Step 6, where incremental improvements to the codec are being conducted. 

Step 7, which is in parallel with Step 6 is still not complete. What we have seen so far are one set of MUSHRA results which are admittedly not broad enough to be conclusive. Besides, to the best of my knowledge, the codec's payload format is not defined and this is an important piece of the work (mentioned in Step 7) which will allow testing and deployment in real internet application and reporting of potential problems.

Kind regards,
/Anisse

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cullen Jennings
> Sent: Thursday, March 17, 2011 7:15 AM
> To: [email-masked]
> Cc: Jonathan Rosenberg
> Subject: [codec] Draft Agenda for CODEC at IETF 80 Version 1
> 
> 
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: "Paul Coverdale" <[email-masked]>
Date: Thu, 17 Mar 2011 18:18:45 +0100

Yes, it does seem that the process in draft-ietf-codec-guidelines-00 has
become somewhat convoluted. In particular, how  can the Evaluation, Testing,
and Characterization phase be carried out when we don't have a test plan?

...Paul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Anisse Taleb
Sent: Thursday, March 17, 2011 10:29 AM
To: Cullen Jennings; [email-masked]
Cc: Jonathan Rosenberg
Subject: Re: [codec] Draft Agenda for CODEC at IETF 80 Version 1

Dear Cullen, 
Thanks for preparing the agenda. I am a bit concerned that we start
discussing the WGLC of Opus before discussing the process which is
documented in draft-ietf-codec-guidelines-00. Regardless of the ordering of
the agenda items, I am in fact more concerned that we are starting to talk
about WGLC when almost no formal tests have been conducted. 

My understanding of the document draft-ietf-codec-guidelines-00 is that it
provides steps (section 2) that the work is expected to follow. As far as I
know we are still in Step 6, where incremental improvements to the codec are
being conducted. 

Step 7, which is in parallel with Step 6 is still not complete. What we have
seen so far are one set of MUSHRA results which are admittedly not broad
enough to be conclusive. Besides, to the best of my knowledge, the codec's
payload format is not defined and this is an important piece of the work
(mentioned in Step 7) which will allow testing and deployment in real
internet application and reporting of potential problems.

Kind regards,
/Anisse

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 21 Mar 2011 22:58:59 -0600

Makes sense - changed in updated agenda at 

http://www.ietf.org/proceedings/80/agenda/codec.txt

Hit refresh on your browser if you do not get version 2

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 21 Mar 2011 23:06:20 -0600

I agree Paul, in my mind, the big questions related to guidelines is "what is the plan, who is doing it, and when".

---

From: "Christian Hoene" <[email-masked]>
Date: Tue, 22 Mar 2011 09:11:23 +0100

Hi all,

regarding the agenda: Could we please keep the order similar to what has
been defined in the schedule of the charter?

1. Codec Standardization Guidelines (it does not need 30min, maybe 5-10 min)
2. Requirements
3. Opus codec specification 
4. Characterization Phase
5. WG Codec Future plans 

Or shall we go for WGLC of Opus first, then for WGLC of requirements, and
drop guidelines document?

With best regards,

 Christian

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Cullen Jennings
> Sent: Tuesday, March 22, 2011 5:59 AM
> To: Anisse Taleb
> Cc: Jonathan Rosenberg; [email-masked]
> know we are still in Step 6, where incremental improvements to the codec
> are being conducted.
> >

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 23 Mar 2011 08:53:22 -0600

Uh, so I'm glad to change the agenda to a form that meets the WG needs but I think that what you have is roughly what I have with slightly different order. 

The requirements we were going to cover in the admin section but if they need more time, glad to break them out into a separate items that is right after the Liaison update on current agenda. Is that needed ?

Next we have some time for the opus section - your point 3. 

Then we have the guidelines - If they only use 10 minutes, great, but I don't mind reserving 30 in case they need it. We are not pressed for time here. 

Then we have the characterization plans. I think this is the major item under the how to get to WGLC of opus. I wanted to just leave the item a little broader so that if there are issues other than characterization, they can be discussed too. 

I have no time from point 5 Future plans as no one has request time or proposed any future plans. 

The main difference from your proposal below and what we have seems to be move your point 1 to be between 3 and 4. I want to discuss these two things together as I had always assumed that the description of the characterization plan would be in the guidelines. Regardless of if it is or is not, they two seem closely related and it seems to make sense to group that conversation together. It is also the most unbounded conversation this WG needs to have right now so I want don't want to put it at the start where discussion may have to be cut it off to ensure enough time for later things. I'd rather have it near the end where it can soak up any time left over from earlier things. 

Cullen