Subject: Re: [codec] [dispatch] Fwd: New Version Notification for draft-alvestrand-dispatch-rtcweb-protocols-00

From: Henry Sinnreich <[email-masked]>
Date: Tue, 21 Dec 2010 20:32:28 -0600

It is interesting, almost funny (or sad depending on the perspective) how
the reaction to a _God Forbid_ IP-free video codec is mirroring the
opposition to the Internet audio codec. That opposition proved eventually
futile and we have now a CODEC WG.
I hope the AD¹s will have now the same fortitude as was shown when the
Internet audio codec WG was formed.

I have taken the liberty to copy the CODEC WG and hope they can participate
now in the video codec discussion as well.
My apology for the double posting.

Thanks, Henry 

On 12/21/10 3:38 PM, "[email-masked]" <[email-masked]>
wrote:

> Hi Peter, all,
>  
> About the video codec: Are there any arguments on why VP8 would not have IPR
> issues? It is available as an open source implementation, but that does not
> mean there are no IPR against it. My understanding is that the IPR situation
> wrt. VP8 is still unclear and thus risky. The other issue with VP8 is, as far
> as I know, the lack of a clear spec out of which independent interoperable
> implementations can be created.
>  
> So I don¹t at least buy the argument that we should choose VP8 as mandatory to
> implement video codec because of IPR reasons.
>  
> I¹m working on a separate review on Harald¹s drafts (thanks for putting them
> together) and will come back to the codec issue there in more detail, but just
> wanted to respond to Peter¹s point here.
>  
> Regards,
>                 Markus
>  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of ext Peter Musgrave
> Sent: 17 December, 2010 13:48
> To: Harald Alvestrand
> Cc: [email-masked]; [email-masked]; Ted Hardie
> Subject: Re: [dispatch] Fwd: New Version Notification for
> draft-alvestrand-dispatch-rtcweb-protocols-00
>  
> 
> I'd also like to echo Alan's thanks for these drafts.
> 
>  
> 
> The protocol doc is very clear. [If you read only one dispatch draft this
> Christmas, make it this one. ;-)  ]
> 
>  
> 
> One observation to the group. The mandatory to implement video CODEC is VP8
> (presumably since it does not have IPR issues - which some other choices would
> have). 
> 
>  
> 
> Regards, 
> 
>  
> 
> Peter Musgrave
> 
>  
> 
>  
> 
> Nits
> 
> Introduction
> 
> s/veichle/vehicle/
> 
>  
> 
> Section 2 Para "Within each.."
> 
> s/implementaiton/implementation/
> 
>  
> 
> Section 4 Para1
> 
> "such as" (something missing here?)
> 
>  
> 
> Section 5 Para2
> 
> "There is no third mandatory to implement"
> 
> ? Was there a mention of a third before. Not sure why this statement is there.
> 
>  
>  
> 
> On 2010-11-10, at 6:34 AM, Harald Alvestrand wrote:
> 
> 
> This is the overview document for the IETF-related RTC-WEB work.
> 
> -------- Original Message --------
>  
>

---

From: <[email-masked]>
Date: Wed, 22 Dec 2010 07:46:12 +0000

Hi,

The good thing about Opus codec is that as it has been developed through the IETF process, the ownership and change control issues are clear. This makes referencing and even mandating it by IETF or W3C more comfortable.

Markus

From: ext Henry Sinnreich [mailto:[email-masked]]
Sent: 22 December, 2010 04:32
To: Isomaki Markus (Nokia-CIC/Espoo); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dispatch] Fwd: New Version Notification for draft-alvestrand-dispatch-rtcweb-protocols-00

It is interesting, almost funny (or sad depending on the perspective) how the reaction to a _God Forbid_ IP-free video codec is mirroring the opposition to the Internet audio codec. That opposition proved eventually futile and we have now a CODEC WG.
I hope the AD's will have now the same fortitude as was shown when the Internet audio codec WG was formed.

I have taken the liberty to copy the CODEC WG and hope they can participate now in the video codec discussion as well.
My apology for the double posting.

Thanks, Henry

On 12/21/10 3:38 PM, "[email-masked]" <[email-masked]> wrote:
Hi Peter, all,

About the video codec: Are there any arguments on why VP8 would not have IPR issues? It is available as an open source implementation, but that does not mean there are no IPR against it. My understanding is that the IPR situation wrt. VP8 is still unclear and thus risky. The other issue with VP8 is, as far as I know, the lack of a clear spec out of which independent interoperable implementations can be created.

So I don't at least buy the argument that we should choose VP8 as mandatory to implement video codec because of IPR reasons.

I'm working on a separate review on Harald's drafts (thanks for putting them together) and will come back to the codec issue there in more detail, but just wanted to respond to Peter's point here.

Regards,
                Markus

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Peter Musgrave
Sent: 17 December, 2010 13:48
To: Harald Alvestrand
Cc: [email-masked]; [email-masked]; Ted Hardie
Subject: Re: [dispatch] Fwd: New Version Notification for draft-alvestrand-dispatch-rtcweb-protocols-00

The protocol doc is very clear. [If you read only one dispatch draft this Christmas, make it this one. ;-)  ]

One observation to the group. The mandatory to implement video CODEC is VP8 (presumably since it does not have IPR issues - which some other choices would have).

Regards,

Peter Musgrave

Nits

Introduction

s/veichle/vehicle/

Section 4 Para1

Section 5 Para2

-------- Original Message --------