Subject: [codec] Draft with source code

From: Jean-Marc Valin <[email-masked]>
Date: Sun, 14 Nov 2010 02:05:32 -0500

Hi everyone,

I just submitted an updated version of the Opus draft that includes the
source code. This is mostly an experiment to see what it looks like. The
draft is at:
http://www.ietf.org/id/draft-ietf-codec-opus-01.txt

You can extract the compressed source code by typing (on one line):

cat draft-ietf-codec-opus-01.txt | grep '^   ###' | sed 's/   ###//' |
base64 -d > opus_source.tar.gz

and then decompress it with:

tar xzvf opus_source.tar.gz

Any comments?

	Jean-Marc

---

From: Jean-Marc Valin <[email-masked]>
Date: Sun, 14 Nov 2010 02:10:02 -0500

Sorry, I forgot to mention that the draft does not include any build
script/makefile yet so for now you won't be able to compile this draft
(at least not easily).

Cheers,

	Jean-Marc

On 10-11-14 02:05 AM, Jean-Marc Valin wrote:
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec
> 
>

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 15 Nov 2010 10:55:56 +0100

And you probably forgot the most important piece...

Save trees, don't print out the whole draft :-)

/Ingemar

> -----Original Message-----
> From: Jean-Marc Valin [mailto:[email-masked]] 
> Sent: den 14 november 2010 08:10
> To: Jean-Marc Valin
> Cc: [email-masked]
> Subject: Re: [codec] Draft with source code
> 
> Sorry, I forgot to mention that the draft does not include 
> any build script/makefile yet so for now you won't be able to 
> compile this draft (at least not easily).
> 
> Cheers,
> 
> 	Jean-Marc
> 
> > I just submitted an updated version of the Opus draft that includes 
> > the source code. This is mostly an experiment to see what it looks 
> > like. The draft is at:

---

From: Anisse Taleb <[email-masked]>
Date: Tue, 16 Nov 2010 05:42:59 +0000

Dear JM,

Is it intentional to not include any build scripts? Would the build scripts from git able to compile this code ?

Kind regards,
/Anisse

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jean-Marc Valin
> Sent: Sunday, November 14, 2010 8:10 AM
> To: Jean-Marc Valin
> Cc: [email-masked]
> the

---

From: Jean-Marc Valin <[email-masked]>
Date: Tue, 16 Nov 2010 06:15:13 -0500

Hi Anisse,

On 10-11-16 12:42 AM, Anisse Taleb wrote:
> Is it intentional to not include any build scripts? Would the build
> scripts from git able to compile this code ?

Although it would work, I thought the build system in git was a bit too
big/complex to put in a draft. I'd like to include a simple Makefile
instead of the autoconf system, but did not have time to write it yet.
Don't worry, the final document will definitely have a something to
build the codec.

Cheers,

	Jean-Marc

> Kind regards, /Anisse
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Jean-Marc Valin Sent:
>> Sunday, November 14, 2010 8:10 AM To: Jean-Marc Valin Cc:
>> [email-masked] Subject: Re: [codec] Draft with source code
>> 
>> Sorry, I forgot to mention that the draft does not include any
>> build script/makefile yet so for now you won't be able to compile
>> this draft (at least not easily).
>> 
>> Cheers,
>> 
>> Jean-Marc
>> 
>>> source code. This is mostly an experiment to see what it looks
>>> like.
>> The
>>> draft is at: http://www.ietf.org/id/draft-ietf-codec-opus-01.txt
>>> 
>>> cat draft-ietf-codec-opus-01.txt | grep '^   ###' | sed 's/
>>> ###//'
>> |
>>> Jean-Marc _______________________________________________ codec
>>> mailing list [email-masked] 
>> _______________________________________________ codec mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/codec
> _______________________________________________ codec mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/codec
> 
>