Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

From: Koen Vos <[email-masked]>
Date: Fri, 5 Nov 2010 18:58:43 +0100 (CET)

Hi Erik,

I agree with Jean-Marc: 'No license required' is quite unusual for any software, but an automatic license (included with the code) seems like a reasonable request.  Is that what you meant?

I'd be really happy to get concrete feedback on the Skype terms, either on this list or to me directly.  After all the terms are very similar to the standard Cisco terms.

best,
koen.

----- Original Message -----
From: "Jean-Marc Valin" <[email-masked]>
To: "Erik Norvell" <[email-masked]>
Cc: [email-masked]
Sent: Friday, November 5, 2010 10:18:20 AM
Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

<hat colour="xiph">

Hi Erik,

Sorry for not replying earlier. I originally wanted to wait for the Xiph
IPR statement, which should still appear before the meeting. Instead of
aguing indirectly over the terms through the guidelines document, why
not address these issue directly? Your insistence 'No license required'
seems to indicate that you are unhappy with the current terms proposed.
Is that
the case? If so, maybe we can discuss the actual problems you find with
current Skype terms, as well as the terms that will be submitted by Xiph
and (I assume) Broadcom.

In general, I totally agree that having to explicitly request a license
would be problematic. On the other hand, I tend to like the idea of an
"automatic license" that everyone gets, but that can be revoked if
someone starts suing people for implementing the standard. In fact, I
believe that
such clauses can actually make the codec safer to use and redistribute.

Jean-Marc

</hat>

On 10-11-05 06:10 AM, Erik Norvell wrote:
> Hi all,
>
> This suggested guidelines update was sent the day after version 08 was
> announced. However, the sections on which we commented were not
> changed from version 07 to 08, so the comments still apply. To
> re-iterate our proposal:
>
> 1) The guidelines should state a preference for truly unencumbered
> technology if choice is given.
> 2) Truly unencumbered should be defined as the 'No license required'
> option.
>
> I see this as an alignment with the charter of this WG, which already
> emphasizes the preference for unencumbered technologies. To make this
> draft a WG item this point should be considered.
>
> Best,
> Erik
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jonas Svedberg
> Sent: den 26 oktober 2010 13:40
> To: [email-masked]
> Cc: Jean-Marc Valin
> Subject: [codec] Proposed Guidelines update , was: Re:Opus codec
> licensing
>
>   Hi all
>
>    from my point of view it is beneficial if we can boil down the
>    current discussion on licensing and IPR disclosures
>    to what should be included in our WGs process document
>    (guidelines).
>
>
>     With regard to the current proposed guidelines text v07, it is in
>     section 5 refering to BCP79:
>     "In general, IETF working groups prefer technologies with no known
>     IPR claims or, for technologies with
>     claims against them, an offer of royalty-free licensing."
>
>      This BCP79 reference to does not state a preference between the
>      two basic forms of Royalty Free
>         A) 'RF' where 'No license is required' (no royalities, no
>         entering into any agreement )
>         B) 'RF'-licensing, where obtaining a license and entering into
>         an agreement is still required.
>
>       In form B) the licensing terms may include limitations and/or
>       compensations which are identified as encumbrances by
>       the charter of this WG. Reading the charter, it defines
>       encumbrance as :
>         "... need to request a license, enter into a business
>         agreement, pay licensing fees or royalties,
>          or attempt to adhere to other special conditions or
>          restrictions".
>
>       The charter further expresses as one of the goals:
>         "The working group cannot explicitly rule out the possibility
>         of adopting encumbered technologies;
>          however, the working group will try to avoid encumbered
>          technologies that require royalties or
>          other encumbrances that would prevent such technologies from
>          being easy to redistribute and use."
>
>        Hence, in the spirit of the charter and the creation of the WG,
>        we should make it clear in the guidelines that royalty-free
>        licensing by no means is identical with unencumbrance
>        and that proposed technology adhereing to the 'No lic. required
>        option' should be prefered if the WG is presented
>        with such a choice.
>
>       Also in light of the discussion, it seems reasonable to state in
>       the guidelines that any inclusion of technology
>       into the codec will not be considered unless proper IP
>       disclosure for the contribution has been made.
>
>
>      Attached is an proposed updated guidelines (section 5, page ~10),
>      with change marks.
>
>
> //BR Jonas
>
>
>
> _______________________________________________ codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

_______________________________________________ codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: Anisse Taleb <[email-masked]>
Date: Fri, 05 Nov 2010 18:22:46 +0000

Hi all,
I believe having the license go with the code is the best way to insure that the licensor clearly and visibly states the terms and for the user to automatically get a license by using the code. 

Such automatic licenses and agreements are easily done for binaries when installing software, since the software won't install unless the box is ticked. For source code, a LICENSE.TXT file could be added to the code distribution and is not uncommon. 

Kind regards,
/Anisse

> Of Koen Vos
> Sent: Friday, November 05, 2010 6:59 PM
> To: Jean-Marc Valin
> Cc: [email-masked]
> I agree with Jean-Marc: 'No license required' is quite unusual for any
> software, but an automatic license (included with the code) seems like
> a reasonable request.  Is that what you meant?
> 
> I'd be really happy to get concrete feedback on the Skype terms, either
> on this list or to me directly.  After all the terms are very similar
> to the standard Cisco terms.
> 
> best,
> koen.
> 
>

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 05 Nov 2010 14:29:22 -0400

On 10-11-05 02:22 PM, Anisse Taleb wrote:
> Hi all, I believe having the license go with the code is the best way to
> insure that the licensor clearly and visibly states the terms and for
> the user to automatically get a license by using the code.
>
> Such automatic licenses and agreements are easily done for binaries when
> installing software, since the software won't install unless the box is
> ticked. For source code, a LICENSE.TXT file could be added to the code
> distribution and is not uncommon.

I agree. That's already how all open-source software is distributed and I 
have yet to see people complaining about software coming with a BSD license 
rather than being "public domain".

	Jean-Marc

> Kind regards, /Anisse
>
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Koen Vos Sent: Friday,
>> November 05, 2010 6:59 PM To: Jean-Marc Valin Cc: [email-masked]
>> I agree with Jean-Marc: 'No license required' is quite unusual for
>> any software, but an automatic license (included with the code) seems
>> like a reasonable request.  Is that what you meant?
>>
>> I'd be really happy to get concrete feedback on the Skype terms,
>> either on this list or to me directly.  After all the terms are very
>> similar to the standard Cisco terms.
>>
>> best, koen.
>>
>>
>> ----- Original Message ----- From: "Jean-Marc
>> Valin"<[email-masked]> To: "Erik
>> Norvell"<[email-masked]> Cc: [email-masked] Sent: Friday,
>> November 5, 2010 10:18:20 AM Subject: Re: [codec] Proposed Guidelines
>> update , was: Re:Opus codec licensing
>>
>> <hat colour="xiph">
>>
>> Hi Erik,
>>
>> Sorry for not replying earlier. I originally wanted to wait for the
>> Xiph IPR statement, which should still appear before the meeting.
>> Instead of aguing indirectly over the terms through the guidelines
>> document, why not address these issue directly? Your insistence 'No
>> license required' seems to indicate that you are unhappy with the
>> current terms proposed. Is that the case? If so, maybe we can discuss
>> the actual problems you find with current Skype terms, as well as the
>> terms that will be submitted by Xiph and (I assume) Broadcom.
>>
>> In general, I totally agree that having to explicitly request a
>> license would be problematic. On the other hand, I tend to like the
>> idea of an "automatic license" that everyone gets, but that can be
>> revoked if someone starts suing people for implementing the standard.
>> In fact, I believe that such clauses can actually make the codec safer
>> to use and redistribute.
>>
>> Jean-Marc
>>
>> </hat>
>>
>>> technology if choice is given. 2) Truly unencumbered should be
>>> defined as the 'No license required' option.
>>>
>>> I see this as an alignment with the charter of this WG, which
>>> already emphasizes the preference for unencumbered technologies. To
>>> make this draft a WG item this point should be considered.
>>>
>>> Best, Erik
>>>
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On
>> Behalf
>>> Of Jonas Svedberg Sent: den 26 oktober 2010 13:40 To:
>>> [email-masked] Cc: Jean-Marc Valin Subject: [codec] Proposed
>>> Guidelines update , was: Re:Opus codec licensing
>>>
>>> Hi all
>>>
>>> current discussion on licensing and IPR disclosures to what should
>>> be included in our WGs process document (guidelines).
>>>
>>>
>>> section 5 refering to BCP79: "In general, IETF working groups prefer
>>> technologies with no
>> known
>>> IPR claims or, for technologies with claims against them, an offer
>>> of royalty-free licensing."
>>>
>>> This BCP79 reference to does not state a preference between the two
>>> basic forms of Royalty Free A) 'RF' where 'No license is required'
>>> (no royalities, no entering into any agreement ) B) 'RF'-licensing,
>>> where obtaining a license and entering
>> into
>>> compensations which are identified as encumbrances by the charter of
>>> this WG. Reading the charter, it defines encumbrance as : "... need
>>> to request a license, enter into a business agreement, pay licensing
>>> fees or royalties, or attempt to adhere to other special conditions
>>> or restrictions".
>>>
>>> The charter further expresses as one of the goals: "The working
>>> group cannot explicitly rule out the possibility of adopting
>>> encumbered technologies; however, the working group will try to
>>> avoid encumbered technologies that require royalties or other
>>> encumbrances that would prevent such technologies from being easy to
>>> redistribute and use."
>>>
>>> licensing by no means is identical with unencumbrance and that
>>> proposed technology adhereing to the 'No lic.
>> required
>>> option' should be prefered if the WG is presented with such a
>>> choice.
>>>
>>> the guidelines that any inclusion of technology into the codec will
>>> not be considered unless proper IP disclosure for the contribution
>>> has been made.
>>>
>>>
>>> [email-masked] https://www.ietf.org/mailman/listinfo/codec
>>
>> [email-masked] https://www.ietf.org/mailman/listinfo/codec
>> [email-masked] https://www.ietf.org/mailman/listinfo/codec

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 05 Nov 2010 14:29:31 -0400

Sorry, but no.
In the IETF, currently, the source code is to be licensed under the
BSD-style license, and only under this license.  There is no flexibility
on this subject.
Stephan

On 11.5.2010 14:22 , "Anisse Taleb" <[email-masked]> wrote:

>Hi all,
>I believe having the license go with the code is the best way to insure
>that the licensor clearly and visibly states the terms and for the user
>to automatically get a license by using the code.
>
>> Xiph

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 05 Nov 2010 14:38:27 -0400

Hi,
I hit the send button too early.
What interested parties can do is to publish the same source code in a
different venue under a different license.  That assumes, of course, that
the interested parties actually own the rights to the source code from a
copyright viewpoint, which may make it advisable to set up a project in
the open source domain, CLAs and all that.
Do that if you wish, but discussions related to this exercise are probably
best conducted outside this mailing list.
Stephan

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 05 Nov 2010 14:41:22 -0400

Hi Stephan,

I believe that what Anisse was talking about here wasn't the copyright 
license but the patent license. If I understand correctly, the proposal was 
to include the patent license directly with the source code rather than 
relying on the people reading the IPR statement. Sounds like a good idea to 
me. The copyright license would still be the simplified BSD as required by 
the IETF. I do not see any reason to use a different license.

	Jean-Marc

On 10-11-05 02:38 PM, Stephan Wenger wrote:
> On 11.5.2010 14:29 , "Stephan Wenger"<[email-masked]>  wrote:
>
>> Sorry, but no.
>> On 11.5.2010 14:22 , "Anisse Taleb"<[email-masked]>  wrote:
>>
>>> Hi all,
>>>> From: "Jean-Marc Valin"<[email-masked]>
>>>> To: "Erik Norvell"<[email-masked]>
>>>> Cc: [email-masked]

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 05 Nov 2010 15:13:45 -0400

Hi Jean-Marc,

Let me rephrase: It is my understanding that *any* legalese beyond the BSD
license is not acceptable in an RFC.  Whether this legalese is a patent
pledge, a copyright license, or something else, is irrelevant.

The reason for this design choice, if I recall correctly, is that we want
to avoid having technical documents be cluttered with legalese.  It has
happened in the past, and was not pretty.

Stephan

P.s.: I would also be careful to characterize the BSD license as a
copyright license only.  After all, it includes the word "use"...

On 11.5.2010 14:41 , "Jean-Marc Valin" <[email-masked]> wrote:

>>>>>any
>>>>>either
>>>>>license
>>>>>>already

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 5 Nov 2010 22:24:51 -0400

> happened in the past, and was not pretty.

Stephan is correct. The IETF Trust Legal Provisions, Section 4 of 

http://trustee.ietf.org/docs/IETF-Trust-License-Policy.pdf

allows for

- a BSD license for code components or

- In certain circumstances, no license at all (Section 6.c.i and ii) Note well that

"... an IETF Contribution with such a notice cannot become a Standards Track document or, in most cases, a working group document."

So, that doesn't apply here. 

Also note that the IETF does not deal with patent policy, except for publishing IPR statements. 

Section 5.a of the TLP

No Patent License. The licenses granted under these Legal Provisions shall not be deemed to grant any right under any patent, patent application or similar intellectual property right.

Also look at BCP 79 - http://tools.ietf.org/html/bcp79

Regards
Marshall Eubanks

---

From: Erik Norvell <[email-masked]>
Date: Sat, 6 Nov 2010 16:17:52 +0100

Hi Koen,

I agree with you that the 'No license required' is unusual. But I still think this option is precisely in line with what the Codec charter is stating. The preference is for unencumbered technology, if such options exist.

I am not criticizing Skype's licensing terms in general, they are similar to what many other companies are using. But in this WG they are not the first preference, if we really want unencumbered technology.

Best,
Erik

-----Original Message-----
From: Koen Vos [mailto:[email-masked]] 
Sent: den 5 november 2010 18:59
To: Jean-Marc Valin
Cc: [email-masked]; Erik Norvell
Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

Hi Erik,

best,
koen.

----- Original Message -----
From: "Jean-Marc Valin" <[email-masked]>
To: "Erik Norvell" <[email-masked]>
Cc: [email-masked]
Sent: Friday, November 5, 2010 10:18:20 AM
Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

<hat colour="xiph">

Hi Erik,

Sorry for not replying earlier. I originally wanted to wait for the Xiph IPR statement, which should still appear before the meeting. Instead of aguing indirectly over the terms through the guidelines document, why not address these issue directly? Your insistence 'No license required'
seems to indicate that you are unhappy with the current terms proposed.
Is that
the case? If so, maybe we can discuss the actual problems you find with current Skype terms, as well as the terms that will be submitted by Xiph and (I assume) Broadcom.

In general, I totally agree that having to explicitly request a license would be problematic. On the other hand, I tend to like the idea of an "automatic license" that everyone gets, but that can be revoked if someone starts suing people for implementing the standard. In fact, I believe that such clauses can actually make the codec safer to use and redistribute.

Jean-Marc

</hat>

> [email-masked] https://www.ietf.org/mailman/listinfo/codec

_______________________________________________ codec mailing list [email-masked] https://www.ietf.org/mailman/listinfo/codec

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 9 Nov 2010 20:52:32 -0700

As chair, I would like to say "Exactly what Stephan said"

Cullen <CODEC co-chair>