Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

From: Erik Norvell <[email-masked]>
Date: Fri, 5 Nov 2010 11:10:33 +0100

Hi all,

This suggested guidelines update was sent the day after version 08 was announced. However, the sections on which we commented were not changed from version 07 to 08, so the comments still apply. To re-iterate our proposal:

1) The guidelines should state a preference for truly unencumbered technology if choice is given.
2) Truly unencumbered should be defined as the 'No license required' option.

I see this as an alignment with the charter of this WG, which already emphasizes the preference for unencumbered technologies. To make this draft a WG item this point should be considered.

Best,
Erik

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jonas Svedberg
Sent: den 26 oktober 2010 13:40
To: [email-masked]
Cc: Jean-Marc Valin
Subject: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

 Hi all 

  from my point of view it is beneficial if we can boil down the current discussion on licensing and IPR disclosures
  to what should be included in our WGs process document (guidelines). 

   With regard to the  current proposed guidelines text v07, it is in section  5 refering to BCP79: 
   "In general, IETF working groups prefer technologies with no known IPR claims or, for technologies with 
   claims against them, an offer of royalty-free licensing." 

    This BCP79 reference to does not state a preference between the two basic forms of Royalty Free 
       A) 'RF' where 'No license is required'  (no royalities, no entering into any agreement ) 
       B) 'RF'-licensing, where obtaining a license and entering into an agreement is still required. 

     In form B) the licensing terms may include limitations and/or compensations which are identified as encumbrances by 
     the charter of this WG.  Reading the charter, it defines encumbrance as :
       "... need to request a license, enter into a business agreement, pay licensing fees or royalties, 
        or attempt to adhere to other special conditions or restrictions". 

     The charter further expresses as one of the goals: 
       "The working group cannot explicitly rule out the possibility of adopting encumbered technologies;  
        however, the working group will try to avoid encumbered technologies that require royalties or 
        other encumbrances that would prevent such technologies from being easy to redistribute and use."

      Hence, in the spirit of the charter and the creation of the WG, 
      we  should make it clear in the guidelines that royalty-free licensing by no means is identical with unencumbrance 
      and that proposed technology adhereing to the 'No lic. required option' should be prefered if the WG is presented 
      with such a choice.

     Also in light of the discussion, it seems reasonable to state in the guidelines that any inclusion of technology 
     into the codec will not be considered unless proper IP disclosure for the contribution has been made. 

    Attached is an proposed updated guidelines (section 5, page ~10), with change marks.  

//BR Jonas

---

From: Anisse Taleb <[email-masked]>
Date: Fri, 05 Nov 2010 16:29:55 +0000

Dear Erik,

I am not a lawyer but would like to understand what is the difference between obtaining a royalty free license and no license at all, if the former is truly a royalty free license. How do you define an unencumbered codec and truly unencumbered codec? 

If it is on the effort of taking contact with the licensor and obtaining a license (which could be as automated as signing up for a new facebook account) I would still consider that unencumbered. A license could also be provided as part of the code distribution.

Could you please clarify ?

Kind regards,
/Anisse 

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Erik Norvell
> Sent: Friday, November 05, 2010 11:11 AM
> To: [email-masked]
> Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec
> licensing
> 
> Hi all,
> 
> This suggested guidelines update was sent the day after version 08 was
> announced. However, the sections on which we commented were not changed
> from version 07 to 08, so the comments still apply. To re-iterate our
> proposal:
> 
> I see this as an alignment with the charter of this WG, which already
> emphasizes the preference for unencumbered technologies. To make this
> draft a WG item this point should be considered.
> 
> Best,
> Erik
> 
>   from my point of view it is beneficial if we can boil down the
> current discussion on licensing and IPR disclosures
>      In form B) the licensing terms may include limitations and/or
> compensations which are identified as encumbrances by
>       we  should make it clear in the guidelines that royalty-free
> licensing by no means is identical with unencumbrance
>       and that proposed technology adhereing to the 'No lic. required
> option' should be prefered if the WG is presented
>       with such a choice.
> 
>      Also in light of the discussion, it seems reasonable to state in
> the guidelines that any inclusion of technology

---

From: Erik Norvell <[email-masked]>
Date: Fri, 5 Nov 2010 18:08:21 +0100

Hi Anisse,

I am indeed no expert either but I have had these issues explained to me. The problem we see is that a royalty free license may still include other special conditions stipulated by the IPR owner. Such conditions may for instance be a non-assert, which could drag the license into patent lawsuits concerning other patents. The cost of entering such agreements may be larger than paying a royalty.

We are not arguing against such licenses in general, but within this WG there is an explicit preference to avoid them. 

Quouting the Codec charter:
(http://tools.ietf.org/wg/codec/charters)

" A codec that can be widely implemented and easily distributed among
  application developers, service operators, and end users is preferred.
  Many existing codecs that might fulfill some or most of the technical
  attributes listed above are encumbered in various ways.  For example,
  patent holders might require that those wishing to implement the codec
  in software, deploy the codec in a service, or distribute the codec in
  software or hardware need to request a license, enter into a business
  agreement, pay licensing fees or royalties, or attempt to adhere to
  other special conditions or restrictions."

Our suggestion is that the guidelines document, describing the process to follow this charter, should also state this preference for unencumbered technologies. 

In our view, the licensing option that defines truly unencumbered technology is the "No License Required" option: 
(http://tools.ietf.org/html/draft-ietf-ipr-template-07, section VI. Licensing Declaration)

"a) ___   No License Required for Implementers
              Check here if commitment to forgo a license is limited
              solely to standards-track RFCs ___"

Best regards,
Erik

-----Original Message-----
From: Anisse Taleb [mailto:[email-masked]] 
Sent: den 5 november 2010 17:30
To: Erik Norvell; [email-masked]
Subject: RE: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

Dear Erik,

Kind regards,
/Anisse 

> announced. However, the sections on which we commented were not 
> changed from version 07 to 08, so the comments still apply. To 
> re-iterate our
> proposal:
> 
> Of Jonas Svedberg
>        "... need to request a license, enter into a business 
> agreement, pay licensing fees or royalties,

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 05 Nov 2010 13:18:20 -0400

<hat colour="xiph">

Hi Erik,

Sorry for not replying earlier. I originally wanted to wait for the Xiph 
IPR statement, which should still appear before the meeting. Instead of 
aguing indirectly over the terms through the guidelines document, why not 
address these issue directly? Your insistence 'No license required' seems 
to indicate that you are unhappy with the current terms proposed. Is that 
the case? If so, maybe we can discuss the actual problems you find with 
current Skype terms, as well as the terms that will be submitted by Xiph 
and (I assume) Broadcom.

In general, I totally agree that having to explicitly request a license 
would be problematic. On the other hand, I tend to like the idea of an 
"automatic license" that everyone gets, but that can be revoked if someone 
starts suing people for implementing the standard. In fact, I believe that 
such clauses can actually make the codec safer to use and redistribute.

	Jean-Marc

</hat>

On 10-11-05 06:10 AM, Erik Norvell wrote:
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Erik Norvell <[email-masked]>
Date: Sat, 6 Nov 2010 16:20:32 +0100

Hi Jean-Marc,

Thanks for your reply.

The goal is to develop a codec that would be free and available to use for everyone. If the license is bundled with the software or aquired automatically I see no issue there. It is rather the agreements you may enter by accepting such a license. If the use of the codec may bring disadvantages and cost into patent litigations which may not be related to the use of the developed codec, I see this as a problem.

I am not addressing Skype's IPR statement directly because I think the guidelines should apply for all. Skype has, as everyone else, the right to submit their technology under whatever terms they decide. It is up to this group to decide if we accept them or not. Please note that I am not talking about binding rules of the WG, just stating a preference for unencumbered technology is this choice is given. 

The term "unencumbered" is a bit vague and people seem to have different definitions. When I read the Codec charter I think it maps to the "No license required" option. My insistence on this term is because it is a clarification of the term unencumbered using language already known in IETF. 

Best regards,
Erik

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: den 5 november 2010 18:18
To: Erik Norvell
Cc: [email-masked]
Subject: Re: [codec] Proposed Guidelines update , was: Re:Opus codec licensing

<hat colour="xiph">

Hi Erik,

Sorry for not replying earlier. I originally wanted to wait for the Xiph IPR statement, which should still appear before the meeting. Instead of aguing indirectly over the terms through the guidelines document, why not address these issue directly? Your insistence 'No license required' seems to indicate that you are unhappy with the current terms proposed. Is that the case? If so, maybe we can discuss the actual problems you find with current Skype terms, as well as the terms that will be submitted by Xiph and (I assume) Broadcom.

In general, I totally agree that having to explicitly request a license would be problematic. On the other hand, I tend to like the idea of an "automatic license" that everyone gets, but that can be revoked if someone starts suing people for implementing the standard. In fact, I believe that such clauses can actually make the codec safer to use and redistribute.

	Jean-Marc

</hat>