Subject: Re: [codec] Opus codec licensing

From: Koen Vos <[email-masked]>
Date: Tue, 19 Oct 2010 21:31:13 +0200 (CEST)

Sorry, please ignore previous email - bad keyboard shortcut... 

>> Furthermore, any implementation of the codec that accidentally does not confirm to the standard yet will require a license fee. 

If you modify the codec so much that it's no longer compatible to the standard, then that modified codec is no longer "Opus". In that case you've created a new codec and I think it's only reasonable that the patent license doesn't apply. 

best, 
koen. 

From: "Koen Vos" <[email-masked]> 
To: "Christian Hoene" <[email-masked]> 
Cc: "Stephan Wenger" <[email-masked]>, [email-masked] 
Sent: Tuesday, October 19, 2010 12:27:39 PM 
Subject: Re: [codec] Opus codec licensing 

If you modify the codec so much that it can't 

From: "Christian Hoene" <[email-masked]> 
To: "Stephan Wenger" <[email-masked]>, [email-masked] 
Sent: Tuesday, October 19, 2010 11:12:48 AM 
Subject: Re: [codec] Opus codec licensing 

Re: [codec] Opus codec licensing 

Hi 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger 
Sent: Tuesday, October 19, 2010 5:21 PM 
To: Jean-Marc Valin; [email-masked]; [email-masked] 
Subject: Re: [codec] Opus codec licensing 

Hi, 
With “hat”: 
It is, in almost all cases, unwise for a third party to circumscribe—or worse: abbreviate—licensing terms provided by a rightholder. Skype’s licensing declaration can be found at https://datatracker.ietf.org/ipr/1297 . I note that the statement contains conditions beyond the acceptance of their technology into an IETF standard. 
Stephan 

[Christian Hoene] +1 

It is planned to test the new codec by spreading it to users prior standardization. However, under the terms of this licensing declaration, this is not possible for anybody but Skype because it would require a license from Skype. 

Also, any enhancement of the codec, which does not conform to the original standard anymore, will require a license. 

Furthermore, any implementation of the codec that accidentally does not confirm to the standard yet will require a license fee. 

Clearly, these terms are unacceptable. Please, Koen, talk to your lawyer again to weaken this license statements. This shall include at least a draft versions of the standard. Also, updates of the standard shall not require any new license anymore. 

It is patent really essential for the opus codec? 

“ A method of estimating noise in data containing voice information and noise includes receiving the data as a sequence of input values; transforming the data by applying a first non linear mapping to the input values wherein the derivative function of the mapping decreases in magnitude as the input values increase in magnitude smoothing the transformed data; and transforming the smoothed transformed data by applying a second non linear mapping that is opposite to the first non linear mapping, to determine an estimate of the noise in the inputted data.” 

Anyhow, it should not be too difficult to circumvent the patent. Any ideas? 

Christian 

--------------------------------------------------------------- 

Dr.-Ing. Christian Hoene 

Interactive Communication Systems (ICS), University of Tübingen 

Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 

http://www.net.uni-tuebingen.de/ 

On 10.18.2010 19:26 , "Jean-Marc Valin" < [email-masked] > wrote: 

Opus is available under the BSD license. As for patents, Skype has pledged to make them available royalty-free once the codec is accepted as an IETF standard. 

Jean-Marc 

-----Original Message----- 
From: [email-masked] on behalf of Pascal Pochol 
Sent: Mon 10/18/2010 10:19 PM 
To: [email-masked] 
Subject: [codec] Opus codec licensing 

Hello, 

we've been using speex and celt for voice and music but today I heard about 
Opus which sounds like a fantastic replacement for both these codecs. 

We're wondering if Opus will be released under the same type of license as 
speex and celt? SILK's license forbid its use in commercial software and 
we're worried that it might carry over to Opus. If not, as soon as Opus 
handles lower bitrates, stereo and fixed point decoding we'll be using it. 

-Pascal 

_______________________________________________ 
codec mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/codec 

_______________________________________________ 
codec mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/codec 
_______________________________________________ 
codec mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/codec

---

From: "Christian Hoene" <[email-masked]>
Date: Mon, 25 Oct 2010 11:02:50 +0200

Hi Koen,

Comments inline…

Dr.-Ing. Christian Hoene

From: Koen Vos [mailto:[email-masked]] 
Sent: Tuesday, October 19, 2010 9:31 PM
To: Christian Hoene
Cc: Stephan Wenger; [email-masked]
Subject: Re: [codec] Opus codec licensing

[Christian Hoene] Any good codec such as G.729, AMR,  and GSM had successors. Even a potentially great codec such as Opus can be enhanced - for example - by supporting multi channel compression or spatial audio. Also, the first version of the codec might come with bugs, weaknesses, or high third-party IPR licensing claims that might require updates of the standard.

Thus, in my opinion it is reasonable to allow standardizing a follow-up codec, which may need a changed bit-stream and thus cannot be backwards compatible.

Of course, this issue is not time pressing. 

With best regards,

 Christian Hoene

best,
koen.

  _____  

  _____  

Hi

Hi,
With “hat”:
It is, in almost all cases, unwise for a third party to circumscribe—or worse: abbreviate—licensing terms provided by a rightholder.  Skype’s licensing declaration can be found at https://datatracker.ietf.org/ipr/1297.  I note that the statement contains conditions beyond the acceptance of their technology into an IETF standard.
Stephan

[Christian Hoene] +1

“A method of estimating noise in data containing voice information and noise includes receiving the data as a sequence of input values; transforming the data by applying a first non linear mapping to the input values wherein the derivative function of the mapping decreases in magnitude as the input values increase in magnitude smoothing the transformed data; and transforming the smoothed transformed data by applying a second non linear mapping that is opposite to the first non linear mapping, to determine an estimate of the noise in the inputted data.”

Christian

Dr.-Ing. Christian Hoene

On 10.18.2010 19:26 , "Jean-Marc Valin" <[email-masked]> wrote:

    Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Pascal Pochol
Sent: Mon 10/18/2010 10:19 PM
To: [email-masked]
Subject: [codec] Opus codec licensing

Hello,

-Pascal

  _____

---

From: Roman Shpount <[email-masked]>
Date: Mon, 25 Oct 2010 14:59:40 -0400

I know all of you have been very concerned about the Skype IPR, but I don't
think this is the biggest problem. In this group we are currently missing a
lot of traditional CODEC industry players (GIPS (now google), Qualcomm,
Nokia, etc). We never checked that we are not using any of their
intellectual property. If we are serious about creating a royalty free
CODEC, someone (I am not implying doing this on the mailing list, since this
probably is ideally done offline), needs to review Opus, as well as Silk and
CELT, and see if uses any of the third party intellectual property. Good
place to start would be to see if none of the G.729, GSM, AMR, and MP3
patents apply to this code. A wide general purpose patent search is probably
appropriate as well. We can pretend that none of this intellectual property
exists, but we might end up with having royalty associated with a new CODEC
after all the effort that was invested into creating it. I understand that
we cannot possibly protect ourselves against everything, but we should at
least check the most obvious potential intellectual property.

What this comes down to is that we need to do a patent search and CODEC IPR
review. This is something that will cost a considerable amount of money. I
am not sure what is the best way to approach this. We can either find a
volunteer, familiar with CODEC development and patent law, or setup some
type of fund and hire a company to do this.
_____________________________
Roman Shpount - www.telurix.com

2010/10/25 Christian Hoene <[email-masked]>

> *From:* Koen Vos [mailto:[email-masked]]
> *Sent:* Tuesday, October 19, 2010 9:31 PM
> *To:* Christian Hoene
> *Cc:* Stephan Wenger; [email-masked]
> *Subject:* Re: [codec] Opus codec licensing
>
>
>
> >> Furthermore, any implementation of the codec that accidentally does not
> confirm to the standard yet will require a license fee.
>
> If you modify the codec so much that it's no longer compatible to the
> standard, then that modified codec is no longer "Opus".  In that case you've
> created a new codec and I think it's only reasonable that the patent license
> doesn't apply.
>
> *[Christian Hoene] *Any good codec such as G.729, AMR,  and GSM had
> successors. Even a potentially great codec such as Opus can be enhanced -
> for example - by supporting multi channel compression or spatial audio.
> Also, the first version of the codec might come with bugs, weaknesses, or
> high third-party IPR licensing claims that might require updates of the
> standard.
>
>
>
> Thus, in my opinion it is reasonable to allow standardizing a follow-up
> codec, which may need a changed bit-stream and thus cannot be backwards
> compatible.
>
>
>
> * *
>  ------------------------------
>
> *From: *"Koen Vos" <[email-masked]>
> *To: *"Christian Hoene" <[email-masked]>
> *Cc: *"Stephan Wenger" <[email-masked]>, [email-masked]
> *Sent: *Tuesday, October 19, 2010 12:27:39 PM
> *Subject: *Re: [codec] Opus codec licensing
>
>  ------------------------------
>
> *From: *"Christian Hoene" <[email-masked]>
> *To: *"Stephan Wenger" <[email-masked]>, [email-masked]
> *Sent: *Tuesday, October 19, 2010 11:12:48 AM
> *Subject: *Re: [codec] Opus codec licensing
>
>
>  Hi
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Stephan Wenger
> *Sent:* Tuesday, October 19, 2010 5:21 PM
> *To:* Jean-Marc Valin; [email-masked]; [email-masked]
> *Subject:* Re: [codec] Opus codec licensing
>
>
>
> Hi,
> With “hat”:
> It is, in almost all cases, unwise for a third party to circumscribe—or
> worse: abbreviate—licensing terms provided by a rightholder.  Skype’s
> licensing declaration can be found at
> https://datatracker.ietf.org/ipr/1297.  I note that the statement contains
> conditions beyond the acceptance of their technology into an IETF standard.
> Stephan
>
> *[Christian Hoene] *+1
>
>
>
> It is planned to test the new codec by spreading it to users prior
> standardization. However, under the terms of this licensing declaration,
> this is not possible for anybody but Skype because it would require a
> license from Skype.
>
>
>
> Also, any enhancement of the codec, which does not conform to the original
> standard anymore, will require a license.
>
>
>
> Furthermore, any implementation of the codec that accidentally does not
> confirm to the standard yet will require a license fee.
>
>
>
> Clearly, these terms are unacceptable. Please, Koen, talk to your lawyer
> again to weaken this license statements. This shall include at least a draft
> versions of the standard. Also, updates of the standard shall not require
> any new license anymore.
>
>
>
> “A method of estimating noise in data containing voice information and
> noise includes receiving the data as a sequence of input values;
> transforming the data by applying a first non linear mapping to the input
> values wherein the derivative function of the mapping decreases in magnitude
> as the input values increase in magnitude smoothing the transformed data;
> and transforming the smoothed transformed data by applying a second non
> linear mapping that is opposite to the first non linear mapping, to
> determine an estimate of the noise in the inputted data.”
>
> * *
> Opus is available under the BSD license. As for patents, Skype has pledged
> to make them available royalty-free once the codec is accepted as an IETF
> standard.
>
>     Jean-Marc
>
>  ------------------------------
>

---

From: "Benjamin M. Schwartz" <[email-masked]>
Date: Mon, 25 Oct 2010 15:26:47 -0400

On 10/25/2010 02:59 PM, Roman Shpount wrote:
> I understand that we cannot possibly protect
> ourselves against everything, but we should at least check the most
> obvious potential intellectual property.

Work of this nature has been going on throughout codec development, and
will continue.  It may even accelerate.  The codec's structures have been
carefully chosen based on knowledge of existing patents, to ensure that
the result is entirely non-infringing.  You (and everyone here) are
welcome to participate in this process, which of course is not taking
place in a public forum.  Contact any of the active developers with your
questions if you would like to contribute to the effort.  Your
contribution would be appreciated.

> What this comes down to is that we need to do a patent search and CODEC
> IPR review.

Yes.  People have been doing this, and will continue to do this.

> This is something that will cost a considerable amount of
> money.

I don't see why this should be true.  Reading patents is free.  Even
getting file wrappers is not expensive.  The only thing that would be
expensive is hiring certified legal professionals.  In my view, any
possible advantage to hiring lawyers is eliminated by the fact that they
would be unwilling to publish a report with any level of detail beyond
"the codec is non-infringing according to our research".

I don't think that hiring legal professionals would bring any great
advantage regarding IPR review for the codec.  If anything, it is easier
for a codec engineer to learn to read patents than for legal experts to
learn signal processing algorithms.

--Ben

---

From: Jonas Svedberg <[email-masked]>
Date: Tue, 26 Oct 2010 13:40:22 +0200

Hi all 

  from my point of view it is beneficial if we can boil down the current discussion on licensing and IPR disclosures 
  to what should be included in our WGs process document (guidelines). 

   With regard to the  current proposed guidelines text v07, it is in section  5 refering to BCP79: 
   "In general, IETF working groups prefer technologies with no known IPR claims or, for technologies with 
   claims against them, an offer of royalty-free licensing." 

    This BCP79 reference to does not state a preference between the two basic forms of Royalty Free 
       A) 'RF' where 'No license is required'  (no royalities, no entering into any agreement ) 
       B) 'RF'-licensing, where obtaining a license and entering into an agreement is still required. 

     In form B) the licensing terms may include limitations and/or compensations which are identified as encumbrances by 
     the charter of this WG.  Reading the charter, it defines encumbrance as :
       "... need to request a license, enter into a business agreement, pay licensing fees or royalties, 
        or attempt to adhere to other special conditions or restrictions". 

     The charter further expresses as one of the goals: 
       "The working group cannot explicitly rule out the possibility of adopting encumbered technologies;  
        however, the working group will try to avoid encumbered technologies that require royalties or 
        other encumbrances that would prevent such technologies from being easy to redistribute and use."

      Hence, in the spirit of the charter and the creation of the WG, 
      we  should make it clear in the guidelines that royalty-free licensing by no means is identical with unencumbrance 
      and that proposed technology adhereing to the 'No lic. required option' should be prefered if the WG is presented 
      with such a choice.

     Also in light of the discussion, it seems reasonable to state in the guidelines that any inclusion of technology 
     into the codec will not be considered unless proper IP disclosure for the contribution has been made. 

    Attached is an proposed updated guidelines (section 5, page ~10), with change marks.  

//BR Jonas