Subject: [codec] I-D Action:draft-ietf-codec-opus-00.txt

From: [email-masked]
Date: Fri, 15 Oct 2010 13:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Wideband Audio Codec Working Group of the IETF.

	Title           : Definition of the Opus Audio Codec
	Author(s)       : J. Valin, K. Vos
	Filename        : draft-ietf-codec-opus-00.txt
	Pages           : 12
	Date            : 2010-10-15

This document describes the Opus codec, designed for interactive
speech and audio transmission over the Internet.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-codec-opus-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 08:26:07 -0700

Hi,

I want to inquire the status of this draft.  In many working groups, the
filename "draft-ietf-<wg name>-xxx" indicates that the draft in question is
a WG item of WG <wg-name>.  Following this logic, it would appear that the
"opus" draft is now a WG item of the codec WG.  I don't recall a decision to
than extent.

If the draft were indeed accepted as a WG item, I would like to encourage
those who made IPR statements related to it, to resubmit those statements
with the new filename.  This would help those of us who are searching
through the IETF IPR tracker by WG name (which is a very common thing to do,
at least for me).

Thanks,
Stephan

On 10.15.2010 13:30 , "[email-masked]" <[email-masked]>
wrote:

> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Jean-Marc Valin <[email-masked]>
Date: Tue, 19 Oct 2010 11:31:19 -0400

Hi,

draft-ietf-codec-opus-00.txt is indeed a WG item. It has had several names 
in the past, including draft-valin-codec-prototype and 
draft-valin-codec-definition, which may explain the confusion. This is the 
draft for which there was a hum during the last meeting.

	Jean-Marc

On 10-10-19 11:26 AM, Stephan Wenger wrote:
> a WG item of WG<wg-name>.  Following this logic, it would appear that the
> On 10.15.2010 13:30 , "[email-masked]"<[email-masked]>
> wrote:
>

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 09:04:45 -0700

Hi Jean-Marc,

Four things:

First, indeed, there was a hum at the last meeting.  Weak memory on my side.
Apologies.

Second, hums need to be reconfirmed on the mailing list, and that has not
happened according to my read of the email archive.

Third, I also missed the submission of draft-ietf-codec-description-00,
which was really the time I should have complained.

So I'm willing to assume (as apparently have the chairs, see point #2) that
there has been an implied consensus of the WG to accept the
codec-description draft.  Which brings me to point #4:

As this is now a WG item, any major change requires WG consensus.  Selecting
a marketing name, IMO, is such a major change.  "Opus" is such a flashy name
that certain participants and/or companies conceivably may not like it.  For
example, if I were working for a company that has in its portfolio an audio
product named "Opus", I would object to the name change.  So the thing you
should have done, IMO, is to send an email to the list saying "The editors
consider changing the name of our codec to Opus.  Is that acceptable to the
WG?".

It appears to me that twice you guys (chairs included) have taken shortcuts
with the IETF's procedures, as I understand them.  That, IMO, fills up your
quota for the next couple of years.  Please be more conservative from now
on.

Regards,
Stephan

---

From: "Christian Hoene" <[email-masked]>
Date: Tue, 19 Oct 2010 19:02:47 +0200

Hi,

the ITU had some problems with trademarks that were given to standardized algorithms. 
As far as I remember, PESQ or PEAQ are trademarked by some companies. Since then, the ITU-T name their standards only by numbers.

I do not have any problems with nicknames. However, I think the trademark issue shall be addressed and it is important. I would prefer that such as trademark is owned by the IETF if possible.

Uspto.gov does not list an opus codec. But I do not know how fast they  (or the readers of this mailing list) are...

With best regards,

 Christian

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Tuesday, October 19, 2010 6:05 PM
To: [email-masked]
Subject: Re: [codec] I-D Action:draft-ietf-codec-opus-00.txt

Hi Jean-Marc,

Four things:

Regards,
Stephan

---

From: Jean-Marc Valin <[email-masked]>
Date: Tue, 19 Oct 2010 13:33:38 -0400

Hi Christian,

I don't know the details of the ITU-T trademark issues, but in this case, 
the Opus name will not be controlled by any company (I'm not aware of 
anyone registering a trademark on the "Opus" name in this context). I'm not 
against the IETF owning the trademark, but I'm not sure any ownership is 
necessary to begin with.

Cheers,

	Jean-Marc

As a note, my company does use the term "Opus" in a different domain of 
application (digital signal processor architecture) and sees no issue with 
the IETF using it for an audio codec. Oh, and no, I'm not the one who 
originally suggested that name.

On 10-10-19 01:02 PM, Christian Hoene wrote:
> Interactive Communication Systems (ICS), University of TÃ¼bingen
> Sand 13, 72076 TÃ¼bingen, Germany, Phone +49 7071 2970532
> On 10.19.2010 08:31 , "Jean-Marc Valin"<[email-masked]>  wrote:
>
>> Hi,
>>

---

From: Stephen Botzko <[email-masked]>
Date: Tue, 19 Oct 2010 13:44:38 -0400

Registering trademarks can be expensive, esp. if you are doing it in
multiple countries.  I don't see any necessity for this - even if we had the
money, I'd rather see it go for additional characterization/testing.

Regards
Stephen Botzko

On Tue, Oct 19, 2010 at 1:33 PM, Jean-Marc Valin <
[email-masked]> wrote:

> the Opus name will not be controlled by any company (I'm not aware of anyone
> registering a trademark on the "Opus" name in this context). I'm not against
> the IETF owning the trademark, but I'm not sure any ownership is necessary
> to begin with.
>
> Cheers,
>
>        Jean-Marc
>
>> As far as I remember, PESQ or PEAQ are trademarked by some companies.
>> Since then, the ITU-T name their standards only by numbers.
>>
>> I do not have any problems with nicknames. However, I think the trademark
>> issue shall be addressed and it is important. I would prefer that such as
>> trademark is owned by the IETF if possible.
>>
>> Uspto.gov does not list an opus codec. But I do not know how fast they
>>  (or the readers of this mailing list) are...
>>
>> With best regards,
>>
>>  Christian
>>
>>>>> This draft is a work item of the Internet Wideband Audio Codec Working
>>>>> Group
>>>>> of the IETF.
>>>>>
>>>>>

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 10:55:44 -0700

I agree with Stephen.
In addition, there are kinds of marks that are not registered (and thus
cannot be found in the USPTO database), but are still enforceable.

(As an interesting (at least to me) side note, the trademark problematic can
also go the other way.  There is a Chinese guy who tries to sell the world
³his² H.265 video codec‹which has nothing to do with the ITU¹s effort
towards a Recommendation that may bear this name a few years down the road.
Would his activity ³burn² the designation of a future video codec as H.265
by the ITU?  In the IETF, AFAIK, the combination of  ³RFC² and a number is
sufficiently well protected, and that¹s what is really the main concern.
I¹m not sure the ITU has similarly strong mechanisms in place...)

Stephan

On 10.19.2010 10:44 , "Stephen Botzko" <[email-masked]> wrote:

> Registering trademarks can be expensive, esp. if you are doing it in multiple
> countries.  I don't see any necessity for this - even if we had the money, I'd
> rather see it go for additional characterization/testing.
> 
> Regards
> Stephen Botzko
> 
> On Tue, Oct 19, 2010 at 1:33 PM, Jean-Marc Valin <[email-masked]>
> wrote:
>> Hi Christian,
>> 
>> I don't know the details of the ITU-T trademark issues, but in this case, the
>> Opus name will not be controlled by any company (I'm not aware of anyone
>> the IETF owning the trademark, but I'm not sure any ownership is necessary to
>> begin with.
>> 
>> Cheers,
>> 
>>         Jean-Marc
>> 
>>> As far as I remember, PESQ or PEAQ are trademarked by some companies. Since
>>> then, the ITU-T name their standards only by numbers.
>>>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Oct 2010 20:43:09 -0400

IETF has a long history of standards with names - ICE, SIP, POP, IMAP, 
etc. These are also acronyms, but increasingly the acronyms are highly 
contrived and are basically names (DECADE, ENUM, SALUD) and in some 
cases just names (Sieve). However, IETF has not ever filed for 
trademarks on any of these, and I see absolutely no reason to start now.

-Jonathan R.

On 10/19/2010 1:33 PM, Jean-Marc Valin wrote:
> Hi Christian,
>
> I don't know the details of the ITU-T trademark issues, but in this
> case, the Opus name will not be controlled by any company (I'm not aware
> of anyone registering a trademark on the "Opus" name in this context).
> I'm not against the IETF owning the trademark, but I'm not sure any
> ownership is necessary to begin with.
>
> Cheers,
>
> Jean-Marc
>
> application (digital signal processor architecture) and sees no issue
> with the IETF using it for an audio codec. Oh, and no, I'm not the one
> who originally suggested that name.
>
>> I do not have any problems with nicknames. However, I think the
>> trademark issue shall be addressed and it is important. I would prefer
>> that such as trademark is owned by the IETF if possible.
>>
>>>> On 10.15.2010 13:30 ,
>>>> "[email-masked]"<[email-masked]>
>>>> wrote:
>>>>
>>>>> This draft is a work item of the Internet Wideband Audio Codec
>>>>> Working Group
>>>>> of the IETF.
>>>>>
>>>>>

-- 
Jonathan D. Rosenberg, Ph.D.                   SkypeID: jdrosen
Chief Technology Strategist                    Mobile: +1 (732) 766-2496
Skype                                          SkypeIn: +1 (408) 465-0361
[email-masked]                              http://www.skype.com
[email-masked]                            http://www.jdrosen.net

---

From: Jean-Marc Valin <[email-masked]>
Date: Tue, 19 Oct 2010 21:25:28 -0400

OK great! I didn't see any reason either, but was leaving the door open
in case someone insisted. Glad that's not the case :-)

	Jean-Marc

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 20 Oct 2010 08:02:45 +0200

Dear Jonathan,

is Skype registering Opus as trademark?

With best regards,

 Christian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
Sent: Wednesday, October 20, 2010 2:43 AM
To: [email-masked]
Subject: Re: [codec] I-D Action:draft-ietf-codec-opus-00.txt

-Jonathan R.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 20 Oct 2010 07:44:13 -0600

So just as a point of IETF process, my understanding is the selecting of a WG draft is just a chair decision and not an WG consensus topic - of course the draft needs to be changed such that it reflects the WG consensus so really all the chairs are doing here is picking which virtual piece of paper will be used to write on. Often chairs takes hums to get input on this but given the lack of alternatives, and the consensus developing around this draft, it seemed like a pretty easy decision. If we made a mistake or too much of a short cut here, we should go fix that. 

On the name topic, typically the WG just lets the authors of the draft pick a name as its often viewed as a more editorial than actual technical topic. If someone has some serious problem with Opus and wants something different, lets talk about it but I was hoping not to spend too much time on such a bike shed topic. Clearly if Skype has trademarked Opus then we are going to be having a long conversation about it but I'm working on the assumption that they have not done that. We will see what they say to the question asked. 

Your point about updating IPR declaration is excellent - once we are stable on the name, we should all bug folks update the IPR disclosure to point at the new draft. I have been trying to keep the datatracker "replaced by" up to date so there is some hope of seeing what previous drafts are closely related to the newer draft.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Oct 2010 12:17:21 -0400

<With Skype hat on>

No.

Since the Opus codec is a product of the IETF it would make no sense for 
an individual company to trademark the name of an IETF output.

-Jonathan R.

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 20 Oct 2010 19:02:34 +0200

Dear Jonathan Rosenberg and Jean-Marc Valin,

Thank you very much for answering fast and clearly. 

As the decision on the name of the codec was made behind closed doors, I had to ask the question on the trademark. Now, after publishing the codec's name, it should be more difficult for a third party to clam a trademark on it.

Sincerely

 Christian

PS:
Yes, Opus is an excellent name that has a nice allusion to music.

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Wednesday, October 20, 2010 6:17 PM
To: Christian Hoene
Cc: [email-masked]
Subject: Re: [codec] I-D Action:draft-ietf-codec-opus-00.txt

<With Skype hat on>

No.

-Jonathan R.