Subject: Re: [codec] Adopting draft-valin-codec-guidelines-06 as a WG item

From: Erik Norvell <[email-masked]>
Date: Fri, 8 Oct 2010 13:40:42 +0200

Hi all,

Reading the codec guidelines document it still includes arguable and unnecessary generic statements on the problems associated with encumbered technology. The present guidelines do not at all safeguard that the codec can be implemented by anybody as freely as was the intention when the WG was established. Royalty-free conditions do not at all mean free implementation.

The charter implies that the goal of the WG is to produce a codec without any usage restrictions.
http://tools.ietf.org/wg/codec/charters
==============
  There exist codecs that are standardized, but that cannot be widely
  implemented and easily distributed; according to reports, the presence
  of various usage restrictions (e.g., in the form of requirements to pay
  royalty fees, obtain a license, enter into a business agreement, or meet
  other special conditions imposed by a patent holder) has hindered
  adoptions of such codecs in interactive Internet applications.
==============

Considering these exceptional intentions with the codec WG, the guidelines should also be exceptional compared with the customary IETF guidelines. Preferably, the guidelines should clearly state that the intention is that the codec should be freely available to any implementer. The IETF Patent Disclosure and Licensing Declaration template, part VI Licensing Declaration, has an option a) reading "No Licenses required for Implementers" (http://tools.ietf.org/html/rfc3905). I suggest the guidelines should state that all contributors should comply with this option. As a further clarification of this option a) to meet the intentions behind the establishment of the WG the guidelines should expressly request that "no implementer shall be obliged to make a compensation of any kind to the holder of any patent covering the codec or be obliged to make any undertaking towards to the holder of any patent covering the codec".

Admittedly the suggestion really means an exceptional requirement on the patent holders which would not at all be adequate in general for all IETF WGs and would provide an exceptional freedom for the implementers, but considering the exceptional intentions with the WG I believe exceptional requirements can be justified. If not, the codec may end up adding to the list of encumbered codecs which the WG set out to avoid.

Best regards,
Erik 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
Sent: den 24 september 2010 20:30
To: [email-masked]
Subject: [codec] Adopting draft-valin-codec-guidelines-06 as a WG item

At the last IETF meeting, we discussed adopting the codec guidelines document as a working group item. This did not pass, due to concerns over whether it was in the right direction. We put out a call for alternative documents over the next 5 week period.

Some text was proposed by Stephan for inclusion, which was incorporated into the document. Stephan also contributed some comments, including a few open issues which still require some discussion.

However, the chairs feel that it is not necessary for all open items to be closed prior to adopting a document as a working group item. Indeed, discussion on the content of the document is a good sign that it is a reasonable foundation for the working group item. Given the lack of alternative documents to use as a starting point, the chairs plan on adopting this as a working group item in two weeks time.

If you disagree, please speak up - and even better - submit an alternative document.

Thanks,
Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   SkypeID: jdrosen
Chief Technology Strategist                    Mobile: +1 (732) 766-2496
Skype                                          SkypeIn: +1 (408) 465-0361
[email-masked]                              http://www.skype.com
[email-masked]                            http://www.jdrosen.net

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: "Roni Even" <[email-masked]>
Date: Fri, 8 Oct 2010 15:39:36 +0200

Hi,
I agree with Stephan's comments and have one other question

The text currently says: 
"Once IETF participants agree that the codec being developed meets
       the requirements (e.g., via a working group last call), IETF
       participants can begin the task of characterizing the codec.  The
       characterization process is described under Section 3."

Does it mean that the codec may be published without doing characterization
test before. Reading the draft it looks like these are the tests that will
verify that the codec is within the requirements. Maybe you should add some
text saying that the there will be a working group last call after
characterization.

Roni Even

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Stephan Wenger
> Sent: Saturday, September 25, 2010 3:22 AM
> To: Jonathan Rosenberg; [email-masked]
> Subject: Re: [codec] Adopting draft-valin-codec-guidelines-06 as a WG
> item
> 
> >
> My preference would be to resolve strategic issues such as text/code
> being
> normative (where it seems we are very close to consensus: code it
> should
> be), bit-exact or not (and what are the conformance points if its not
> bit-exactness), and characterization gating, before accepting the draft
> as a
> WG item.  That said, I'm willing to support the adoption of the draft
> as WG
> item even in the absence of this consensus, but only under the
> following two
> conditions:
> 
> 1. The draft clearly states that there is no consensus yet on the
> subject of
> bit-exactness.
> 2. The draft clearly states that there is no consensus yet on the
> subject of
> characterization gating (in the sense of Jonathan's email sent a couple
> of
> hours ago).
> 
> These conditions represent my points 11 and 15 of my email sent to this
> list
> on August 21, on neither of which I'm in agreement with the current
> language
> (or the current intention), nor I have seen any movement on the
> proponents
> on the other side towards a compromise/consensus position.  I don't
> have the
> bandwidth this week or next to suggest alternative language, but will
> try to
> do so within the two week time window Jonathan proposed.
> 
> In order to move things forward: in both cases, I have no problems if
> the
> current text stays in, as long as it is made unambiguously clear that
> this
> is not a consensus position, but rather one possible option for a
> resolution
> of the question, and that other options are expressedly solicited.
> 
> The reason for these requests are hopefully obvious: a WG draft should
> represent the consensus of the WG, and should not contain non-consensus
> positions without disclaimers.
> 
> Stephan
> 
> 
> 
> On 9.24.2010 11:30 , "Jonathan Rosenberg" <[email-masked]> wrote:
> 
> > At the last IETF meeting, we discussed adopting the codec guidelines
> > document as a working group item. This did not pass, due to concerns
> > over whether it was in the right direction. We put out a call for
> > alternative documents over the next 5 week period.
> >
> > Some text was proposed by Stephan for inclusion, which was
> incorporated
> > into the document. Stephan also contributed some comments, including
> a
> > few open issues which still require some discussion.
> >
> > However, the chairs feel that it is not necessary for all open items
> to
> > be closed prior to adopting a document as a working group item.
> Indeed,
> > discussion on the content of the document is a good sign that it is a
> > reasonable foundation for the working group item. Given the lack of
> > alternative documents to use as a starting point, the chairs plan on
> > adopting this as a working group item in two weeks time.
> >

---

From: Jean-Marc Valin <[email-masked]>
Date: Sun, 10 Oct 2010 20:54:29 -0400

Hi,

The current version of the guidelines document mainly cites the charter
on IPR issues. This makes sense because this draft can change neither
the charter, nor any IETF IPR policies. Also, judging from the
discussion on the earlier versions of the draft that differed from the
charter, it seems like the current text is still the one that generates
the least objection. So unless there is wide consensus on an alternate
text that doesn't contradict the current charter, I think we can live
with the current text.

Cheers,

	Jean-Marc

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 11 Oct 2010 11:34:37 -0700

+1.
Beyond that, Erik, my feeling is that parts of your proposal, if
implemented, would have antitrust issues.  I'm willing to discuss those in
private if need be.
Stephan

On 10.10.2010 17:54 , "Jean-Marc Valin" <[email-masked]>
wrote:

>> Reading the codec guidelines document it still includes arguable and
>> unnecessary generic statements on the problems associated with encumbered
>> technology. The present guidelines do not at all safeguard that the codec can
>> be implemented by anybody as freely as was the intention when the WG was
>> established. Royalty-free conditions do not at all mean free implementation.
>> 
>> Considering these exceptional intentions with the codec WG, the guidelines
>> should also be exceptional compared with the customary IETF guidelines.
>> Preferably, the guidelines should clearly state that the intention is that
>> the codec should be freely available to any implementer. The IETF Patent
>> Disclosure and Licensing Declaration template, part VI Licensing Declaration,
>> has an option a) reading "No Licenses required for Implementers"
>> (http://tools.ietf.org/html/rfc3905). I suggest the guidelines should state
>> that all contributors should comply with this option. As a further
>> clarification of this option a) to meet the intentions behind the
>> establishment of the WG the guidelines should expressly request that "no
>> implementer shall be obliged to make a compensation of any kind to the holder
>> of any patent covering the codec or be obliged to make any undertaking
>> towards to the holder of any patent covering the codec".
>> 
>> Admittedly the suggestion really means an exceptional requirement on the
>> patent holders which would not at all be adequate in general for all IETF WGs
>> and would provide an exceptional freedom for the implementers, but
>> considering the exceptional intentions with the WG I believe exceptional
>> requirements can be justified. If not, the codec may end up adding to the
>> list of encumbered codecs which the WG set out to avoid.
>> 
>> Best regards,
>> Erik 
>> 
>> 
>> At the last IETF meeting, we discussed adopting the codec guidelines document
>> as a working group item. This did not pass, due to concerns over whether it
>> was in the right direction. We put out a call for alternative documents over
>> the next 5 week period.
>> 
>> Some text was proposed by Stephan for inclusion, which was incorporated into
>> the document. Stephan also contributed some comments, including a few open
>> issues which still require some discussion.
>> 
>> However, the chairs feel that it is not necessary for all open items to be
>> closed prior to adopting a document as a working group item. Indeed,
>> alternative documents to use as a starting point, the chairs plan on adopting
>> this as a working group item in two weeks time.
>>

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 11 Oct 2010 11:39:46 -0400

+1

I think the IPR stuff has already been discussed at length, and was worked
out adequately in the charter.  It'd be best to move on to actually
completing the project...

Stephen Botzko

On Sun, Oct 10, 2010 at 8:54 PM, Jean-Marc Valin <
[email-masked]> wrote:

> technology. The present guidelines do not at all safeguard that the codec
> can be implemented by anybody as freely as was the intention when the WG was
> > Considering these exceptional intentions with the codec WG, the
> guidelines should also be exceptional compared with the customary IETF
> guidelines. Preferably, the guidelines should clearly state that the
> intention is that the codec should be freely available to any implementer.
> The IETF Patent Disclosure and Licensing Declaration template, part VI
> Licensing Declaration, has an option a) reading "No Licenses required for
> Implementers" (http://tools.ietf.org/html/rfc3905). I suggest the
> guidelines should state that all contributors should comply with this
> option. As a further clarification of this option a) to meet the intentions
> behind the establishment of the WG the guidelines should expressly request
> that "no implementer shall be obliged to make a compensation of any kind to
> the holder of any patent covering the codec or be obliged to make any
> undertaking towards to the holder of any patent covering the codec".
> >
> patent holders which would not at all be adequate in general for all IETF
> WGs and would provide an exceptional freedom for the implementers, but
> Of Jonathan Rosenberg
> document as a working group item. This did not pass, due to concerns over
> whether it was in the right direction. We put out a call for alternative
> documents over the next 5 week period.
> >
> > Some text was proposed by Stephan for inclusion, which was incorporated
> into the document. Stephan also contributed some comments, including a few
> open issues which still require some discussion.
> >
> > However, the chairs feel that it is not necessary for all open items to
> be closed prior to adopting a document as a working group item. Indeed,

---

From: Koen Vos <[email-masked]>
Date: Mon, 11 Oct 2010 22:20:35 +0200 (CEST)

+1 
:) 
koen. 

From: "Stephen Botzko" <[email-masked]> 
To: "Jean-Marc Valin" <[email-masked]> 
Cc: [email-masked] 
Sent: Monday, October 11, 2010 8:39:46 AM 
Subject: Re: [codec] Adopting draft-valin-codec-guidelines-06 as a WG item 

+1 

I think the IPR stuff has already been discussed at length, and was worked out adequately in the charter. It'd be best to move on to actually completing the project... 

Stephen Botzko 

On Sun, Oct 10, 2010 at 8:54 PM, Jean-Marc Valin < [email-masked] > wrote: 

Hi, 

Cheers, 

Jean-Marc 

On 10-10-08 07:40 AM, Erik Norvell wrote: 
> Considering these exceptional intentions with the codec WG, the guidelines should also be exceptional compared with the customary IETF guidelines. Preferably, the guidelines should clearly state that the intention is that the codec should be freely available to any implementer. The IETF Patent Disclosure and Licensing Declaration template, part VI Licensing Declaration, has an option a) reading "No Licenses required for Implementers" ( http://tools.ietf.org/html/rfc3905 ). I suggest the guidelines should state that all contributors should comply with this option. As a further clarification of this option a) to meet the intentions behind the establishment of the WG the guidelines should expressly request that "no implementer shall be obliged to make a compensation of any kind to the holder of any patent covering the codec or be obliged to make any undertaking towards to the holder of any patent covering the codec". 
> 
> From: [email-masked] [mailto: [email-masked] ] On Behalf Of Jonathan Rosenberg

---

From: Erik Norvell <[email-masked]>
Date: Fri, 15 Oct 2010 16:42:45 +0200

Hi,

My suggestion was not to debate the charter nor the IETF policies, but rather to make the guidelines more aligned with them. I realize that parts of my suggestion was strong-worded, such as having contributors complying with a "No License option". Still, considering what the charter says about encumbered codecs, the guidelines should also reflect this in some way.

I suggest that the following text is added to the guidelines in page 10:

..that require royalties or other encumbrances that would prevent such technologies from being easy to redistribute and use.[Added text] For the codec to be truly unencumbered, the contributors should adhere to the 'No license required' option, as expressed in BCP 79 section 6.5: "..c) without the need to obtain a license from the IPR holder."[\Added text]

Best,
Erik 

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: den 11 oktober 2010 02:54
To: Erik Norvell
Cc: [email-masked]
Subject: Re: [codec] Adopting draft-valin-codec-guidelines-06 as a WG item

Hi,

The current version of the guidelines document mainly cites the charter on IPR issues. This makes sense because this draft can change neither the charter, nor any IETF IPR policies. Also, judging from the discussion on the earlier versions of the draft that differed from the charter, it seems like the current text is still the one that generates the least objection. So unless there is wide consensus on an alternate text that doesn't contradict the current charter, I think we can live with the current text.

Cheers,

	Jean-Marc