Subject: [codec] Opus codec licensing

From: "Pascal Pochol" <[email-masked]>
Date: Mon, 18 Oct 2010 21:19:27 -0500

Hello,

we've been using speex and celt for voice and music but today I heard about
Opus which sounds like a fantastic replacement for both these codecs.

We're wondering if Opus will be released under the same type of license as
speex and celt? SILK's license forbid its use in commercial software and
we're worried that it might carry over to Opus. If not, as soon as Opus
handles lower bitrates, stereo and fixed point decoding we'll be using it.

-Pascal

---

From: "Jean-Marc Valin" <[email-masked]>
Date: Mon, 18 Oct 2010 22:26:24 -0400

Opus is available under the BSD license. As for patents, Skype has pledged to make them available royalty-free once the codec is accepted as an IETF standard.

    Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Pascal Pochol
Sent: Mon 10/18/2010 10:19 PM
To: [email-masked]
Subject: [codec] Opus codec licensing
 
Hello,

-Pascal

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: "Pascal Pochol" <[email-masked]>
Date: Tue, 19 Oct 2010 08:52:11 -0500

On 9:26:24 pm 10/18/10 "Jean-Marc Valin" <[email-masked]> wrote:
> Opus is available under the BSD license. As for patents, Skype has
> pledged to make them available royalty-free once the codec is accepted
> as an IETF standard.

Great. I know it's still a draft now but how long do you roughly expect
before it is accepted as a standard? Are we talking weeks? months? Or years?

-Pascal

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 19 Oct 2010 08:15:57 -0600

> before it is accepted as a standard? Are we talking weeks? months? Or years?

Definitely not weeks. Probably months. Hopefully not years. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 08:20:47 -0700

Hi,
With ³hat²:
It is, in almost all cases, unwise for a third party to circumscribe‹or
worse: abbreviate‹licensing terms provided by a rightholder.  Skype¹s
licensing declaration can be found at https://datatracker.ietf.org/ipr/1297.
I note that the statement contains conditions beyond the acceptance of their
technology into an IETF standard.
Stephan

On 10.18.2010 19:26 , "Jean-Marc Valin" <[email-masked]> wrote:

> Opus is available under the BSD license. As for patents, Skype has pledged to
> make them available royalty-free once the codec is accepted as an IETF
> standard.
> 
>     Jean-Marc
>

---

From: "Christian Hoene" <[email-masked]>
Date: Tue, 19 Oct 2010 20:12:48 +0200

Hi

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Tuesday, October 19, 2010 5:21 PM
To: Jean-Marc Valin; [email-masked]; [email-masked]
Subject: Re: [codec] Opus codec licensing

Hi,
With “hat”:
It is, in almost all cases, unwise for a third party to circumscribe—or worse: abbreviate—licensing terms provided by a rightholder.  Skype’s licensing declaration can be found at https://datatracker.ietf.org/ipr/1297.  I note that the statement contains conditions beyond the acceptance of their technology into an IETF standard.
Stephan

[Christian Hoene] +1

It is planned to test the new codec by spreading it to users prior standardization. However, under the terms of this licensing declaration, this is not possible for anybody but Skype because it would require a license from Skype.

Also, any enhancement of the codec, which does not conform to the original standard anymore, will require a license.

Furthermore, any implementation of the codec that accidentally does not confirm to the standard yet will require a license fee.

Clearly, these terms are unacceptable. Please, Koen, talk to your lawyer again to weaken this license statements. This shall include at least a draft versions of the standard. Also, updates of the standard shall not require any new license anymore.

It is patent really essential for the opus codec? 

“A method of estimating noise in data containing voice information and noise includes receiving the data as a sequence of input values; transforming the data by applying a first non linear mapping to the input values wherein the derivative function of the mapping decreases in magnitude as the input values increase in magnitude smoothing the transformed data; and transforming the smoothed transformed data by applying a second non linear mapping that is opposite to the first non linear mapping, to determine an estimate of the noise in the inputted data.”

Anyhow, it should not be too difficult to circumvent the patent. Any ideas? 

Christian

---------------------------------------------------------------

Dr.-Ing. Christian Hoene

Interactive Communication Systems (ICS), University of Tübingen 

Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 

http://www.net.uni-tuebingen.de/

    Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Pascal Pochol
Sent: Mon 10/18/2010 10:19 PM
To: [email-masked]
Subject: [codec] Opus codec licensing

Hello,

-Pascal

  _____

---

From: Roman Shpount <[email-masked]>
Date: Tue, 19 Oct 2010 15:00:11 -0400

People get touchy here about discussing the actual patent claims, but as far
as I can see the only thing affected by this patent is the DTX portion of
the codec. We can use some other VAD method for the Opus codec to work
around the patent.

P.S. I am pretty sure, I saw something very similar to what's described in
this patent in OpenH323 about 10 years ago, but I am not the patent lawyer.
_____________________________
Roman Shpount - www.telurix.com

2010/10/19 Christian Hoene <[email-masked]>

>  Hi
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Stephan Wenger
> *Sent:* Tuesday, October 19, 2010 5:21 PM
> *To:* Jean-Marc Valin; [email-masked]; [email-masked]
> *Subject:* Re: [codec] Opus codec licensing
>
>
>
> Hi,
> With “hat”:
> It is, in almost all cases, unwise for a third party to circumscribe—or
> worse: abbreviate—licensing terms provided by a rightholder.  Skype’s
> licensing declaration can be found at
> https://datatracker.ietf.org/ipr/1297.  I note that the statement contains
> conditions beyond the acceptance of their technology into an IETF standard.
> Stephan
>
>  *[Christian Hoene] *+1
>
>
>
> It is planned to test the new codec by spreading it to users prior
> standardization. However, under the terms of this licensing declaration,
> this is not possible for anybody but Skype because it would require a
> license from Skype.
>
>
>
> Also, any enhancement of the codec, which does not conform to the original
> standard anymore, will require a license.
>
>
>
> Furthermore, any implementation of the codec that accidentally does not
> confirm to the standard yet will require a license fee.
>
>
>
> Clearly, these terms are unacceptable. Please, Koen, talk to your lawyer
> again to weaken this license statements. This shall include at least a draft
> versions of the standard. Also, updates of the standard shall not require
> any new license anymore.
>
>
>
> “A method of estimating noise in data containing voice information and
> noise includes receiving the data as a sequence of input values;
> transforming the data by applying a first non linear mapping to the input
> values wherein the derivative function of the mapping decreases in magnitude
> as the input values increase in magnitude smoothing the transformed data;
> and transforming the smoothed transformed data by applying a second non
> linear mapping that is opposite to the first non linear mapping, to
> determine an estimate of the noise in the inputted data.”
>
> * *
> Opus is available under the BSD license. As for patents, Skype has pledged
> to make them available royalty-free once the codec is accepted as an IETF
> standard.
>
>     Jean-Marc
>
>  ------------------------------
>

---

From: Koen Vos <[email-masked]>
Date: Tue, 19 Oct 2010 21:27:39 +0200 (CEST)

If you modify the codec so much that it can't 

From: "Christian Hoene" <[email-masked]> 
To: "Stephan Wenger" <[email-masked]>, [email-masked] 
Sent: Tuesday, October 19, 2010 11:12:48 AM 
Subject: Re: [codec] Opus codec licensing 

Re: [codec] Opus codec licensing 

Hi 

Hi, 
With “hat”: 
It is, in almost all cases, unwise for a third party to circumscribe—or worse: abbreviate—licensing terms provided by a rightholder. Skype’s licensing declaration can be found at https://datatracker.ietf.org/ipr/1297 . I note that the statement contains conditions beyond the acceptance of their technology into an IETF standard. 
Stephan 

[Christian Hoene] +1 

“ A method of estimating noise in data containing voice information and noise includes receiving the data as a sequence of input values; transforming the data by applying a first non linear mapping to the input values wherein the derivative function of the mapping decreases in magnitude as the input values increase in magnitude smoothing the transformed data; and transforming the smoothed transformed data by applying a second non linear mapping that is opposite to the first non linear mapping, to determine an estimate of the noise in the inputted data.” 

Christian 

Dr.-Ing. Christian Hoene 

On 10.18.2010 19:26 , "Jean-Marc Valin" < [email-masked] > wrote: 

Jean-Marc 

-----Original Message----- 
From: [email-masked] on behalf of Pascal Pochol 
Sent: Mon 10/18/2010 10:19 PM 
To: [email-masked] 
Subject: [codec] Opus codec licensing 

Hello, 

-Pascal

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 13:10:38 -0700

Hi,

On 10.19.2010 12:00 , "Roman Shpount" <[email-masked]> wrote:

> People get touchy here about discussing the actual patent claims, [...]
> 
Indeed.  I very strongly suggest to conduct patent related work elsewhere,
and only among those interested and willing.  You are exposing participants
to claim language which can trigger all kinds of evil to those participating
and, arguably, even those only listening in.  I can¹t prevent you from doing
so, but please keep the risks in mind when discussing claim language here:
1) possible willful infringement allegations, 2) potentially loosing
participation because of input from legal departments due to the previous
point, 3) coming to questionable, if not outright wrong, conclusions due to
lack of legal experience, 4) changing a design based on those conclusions
with or without removing the encumbrance.

Stephan

>> standardization. However, under the terms of this licensing declaration, this
>> is not possible for anybody but Skype because it would require a license from
>> Skype.
>>  
>> versions of the standard. Also, updates of the standard shall not require any
>> new license anymore.
>>  
>> ³A method of estimating noise in data containing voice information and noise
>> includes receiving the data as a sequence of input values; transforming the
>> data by applying a first non linear mapping to the input values wherein the
>> derivative function of the mapping decreases in magnitude as the input values
>> increase in magnitude smoothing the transformed data; and transforming the
>> smoothed transformed data by applying a second non linear mapping that is
>> opposite to the first non linear mapping, to determine an estimate of the
>> noise in the inputted data.²
>> On 10.18.2010 19:26 , "Jean-Marc Valin" <[email-masked]
>> <http://[email-masked]> > wrote:
>> From: [email-masked] <http://[email-masked]>  on behalf of
>> Pascal Pochol
>> To: [email-masked] <http://[email-masked]>
>> [email-masked] <http://[email-masked]>
>> [email-masked] <http://[email-masked]>

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 19 Oct 2010 13:14:00 -0700

Hi Christian,

On 10.19.2010 11:12 , "Christian Hoene" <[email-masked]> wrote:

> [...] 
> Clearly, these terms are unacceptable.
> [...]
>  
Let me suggest that you (and everyone else) mark their opinion on licensing
terms as your personal opinion.  What¹s acceptable or inacceptable to you
may very well be acceptable or inacceptable to me.

Same goes with compliance to the charter.

Stephan

> <[email-masked]> > wrote:

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 20 Oct 2010 09:52:39 +0200

Hello,

as long as the IPR license conditions remain unclear to everybody without a legal background – and even those with legal background describe that they could be unacceptable – may I remind that the guidelines draft contains a sentence stating:

“In cases where no RF license can be obtained regarding a patent, the group should consider alternative algorithms or methods, even if they result in lower quality, higher complexity, or otherwise less desirable characteristics (in most cases, the degradation will likely be small once the best alternative has been identified).“

Thus, I kindly want to remind that there is work to do and that any help from any side is highly appreciated. I will try to do my very best to overcome this current drawback. 

What are your personal opinions, does the patent really cover only the DTX part of the Opus codec?

With best regards,

 Christian Hoene

PS:

This, as, my previous emails, are just my personal opinions.

PPS:

Does the IPR statement #1297 only covers the draft-vos-silk-01? Is it require to file a similar statement for the opus draft?

 

Dr.-Ing. Christian Hoene

From: Stephan Wenger [mailto:[email-masked]] 
Sent: Tuesday, October 19, 2010 10:14 PM
To: Christian Hoene; [email-masked]
Cc: 'Alfons Martin'
Subject: Re: [codec] Opus codec licensing

Hi Christian,

[...] 

Let me suggest that you (and everyone else) mark their opinion on licensing terms as your personal opinion.  What’s acceptable or inacceptable to you may very well be acceptable or inacceptable to me.

Stephan

On 10.18.2010 19:26 , "Jean-Marc Valin" <[email-masked] <[email-masked]> > wrote:
Opus is available under the BSD license. As for patents, Skype has pledged to make them available royalty-free once the codec is accepted as an IETF standard.

    Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Pascal Pochol
Sent: Mon 10/18/2010 10:19 PM
To: [email-masked]
Subject: [codec] Opus codec licensing

Hello,

-Pascal

  _____

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 20 Oct 2010 07:01:14 -0400

Is it possible to create a CODEC-IPR mailing list (or some such) to allow
folks to use the alternative list when chatting about patents and
work-arounds?

That would address some of Stephan's concerns, but still allow the
discussion to archived to an IETF list.  I'd prefer to keep out of the
patent discussions, I suspect there are others who would rather not get
those posts either.

Stephen Botzko

2010/10/20 Christian Hoene <[email-masked]>

>  Hello,
>
>
>
> as long as the IPR license conditions remain unclear to everybody without a
> legal background – and even those with legal background describe that they
> could be unacceptable – may I remind that the guidelines draft contains a
> sentence stating:
>
>
>
> “In cases where no RF license can be obtained regarding a patent, the group
> should consider alternative algorithms or methods, even if they result in
> lower quality, higher complexity, or otherwise less desirable
> characteristics (in most cases, the degradation will likely be small once
> the best alternative has been identified).“
>
>
>
> Thus, I kindly want to remind that there is work to do and that any help
> from any side is highly appreciated. I will try to do my very best to
> overcome this current drawback.
>
> Does the IPR statement #1297 only covers the draft-vos-silk-01? Is it
> require to file a similar statement for the opus draft?
>
>
>
>
>
>
>
>
>
>
>
>
>
> *From:* Stephan Wenger [mailto:[email-masked]]
> *Sent:* Tuesday, October 19, 2010 10:14 PM
> *To:* Christian Hoene; [email-masked]
> *Cc:* 'Alfons Martin'
>
> terms as your personal opinion.  What’s acceptable or inacceptable to you

---

From: James Cloos <[email-masked]>
Date: Sun, 24 Oct 2010 03:09:41 -0400

>>>>> "JV" == Jean-Marc Valin <[email-masked]> writes:

JV> Opus is available under the BSD license. As for patents, Skype has
JV> pledged to make them available royalty-free once the codec is
JV> accepted as an IETF standard.

As a Standard?  Or just published as an standards-track RFC?

That is a /huge/ difference, time-wise.

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 1024D/ED7DAEA6

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 27 Oct 2010 17:21:43 -0400

The Skype IPR declaration uses standard in the lower-case sense - any 
standards track RFC. It does not mean that it only applies to a full 
standard protocol.

For those not familiar - IETF standards track documents can be in one of 
three categories - proposed standard, draft standard, and standard. A 
specification, in theory progresses through these three phases in that 
order, each with a different RFC assigned. In practice, the vast 
majority of standards-track RFCs are proposed standard, and never make 
it beyond that stage.

Thanks,
Jonathan R.

On 10/24/2010 3:09 AM, James Cloos wrote:
>>>>>> "JV" == Jean-Marc Valin<[email-masked]>  writes:
>

-- 
Jonathan D. Rosenberg, Ph.D.                   SkypeID: jdrosen
Chief Technology Strategist                    Mobile: +1 (732) 766-2496
Skype                                          SkypeIn: +1 (408) 465-0361
[email-masked]                              http://www.skype.com
[email-masked]                            http://www.jdrosen.net