Subject: [codec] Summary of last two weeks

From: "Christian Hoene" <[email-masked]>
Date: Mon, 24 May 2010 16:42:24 +0200

Hi all,

my personal summary of the last two weeks emails.

- Wireless IP is in, Bluetooth is out. Consensus.

- The need for a low complexity mode was stated (e.g. 10-20 MIPS), which must not support all audio qualities. No clear consensus on
this issue yet...
  - Which is the complexity of the low complexity mode?
  - How to measure the complexity?

- Delay threshold for telephony is somewhere in between 150-250 one way. Consensus.

- 5ms frames should be supported because of different reasons. Consensus. 
  - There is no consensus why. Arguments were given distributed ensemble performances, sidetone, high-density gateways and hardware
phones. Consensus that we do not need to understand all those arguments and scenarios.

- Upper limit frame size limit shall be between 100-250ms. If required, larger packets can be generated by putting multiple frames
in one packet.

- Supporting Layered coding? No consensus yet.

- VAD, CNG, DTX? And how to efficiently combine pre-encoded audio? The discussion is still not finished...

With best regards,

 Christian

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Mon, 24 May 2010 11:12:18 -0500

>   - How to measure the complexity?

s/must not/is not required to/. If the low complexity mode *can* support
all audio qualities (given some other compromises), there's no reason
not to allow it to do so.

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
skype: kpfleming | jabber: [email-masked]
Check us out at www.digium.com & www.asterisk.org

---

From: "Christian Hoene" <[email-masked]>
Date: Mon, 24 May 2010 18:30:56 +0200

>not to allow it to do so.

Ja, you are right.

Auf Wiedersehen.

 Herr Hoene