Subject: [codec] this weeks summary

From: "Christian Hoene" <[email-masked]>
Date: Sun, 9 May 2010 20:10:32 +0200

Hi all,

Again, many emails this week. Any important results? My personal summary after reading them all again:

Raymond did a great job explaining the special requirements of high-density VoIP gateway. They are differ substantially to those of
soft-phones (but are somewhat similar to VoIP phones with embedded CPUs). The requirements include low memory footprint, ultra-low
delay, low complexity and mostly narrow band. But aren't those requirements already covered by existing codecs? Shall this working
group provide a codec profile for end-to-gateway beside the profile for an end-to-end codec?

SpiritDSP and Christian were discussing the need for layered coding - no consensus yet...

The week before, we were discussing whether to consider Bluetooth and Wireless IP as use cases. It seems to be a rough consensus
that wireless IP is in-scope and that Bluetooth is out-of-scope because it requires too special optimizations. However, battery
powered, wireless devices might require low-complexity and low-bandwidth (and are in-scope?).

With best regards,

 Christian

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

---

From: "Raymond (Juin-Hwey) Chen" <[email-masked]>
Date: Mon, 10 May 2010 12:57:51 -0700

Hi Christian,

> Raymond did a great job explaining the special requirements of high-density 
> VoIP gateway. They are differ substantially to those of
> soft-phones (but are somewhat similar to VoIP phones with embedded CPUs). The 
> requirements include low memory footprint, ultra-low
> delay, low complexity and mostly narrow band. But aren't those requirements 
> already covered by existing codecs? Shall this working

[Raymond]: Which existing codecs satisfy all these requirements
and the three conditions listed at the beginning of the IETF 
codec WG charter?  Also, we are not talking about an additional codec 
profile for "end-to-gateway"; no, what we are talking about is just part of 
the "IPend-to-transcoding_gateway-to-PSTNend" scenario that you listed in 
one of your original emails that discussed the codec requirements.

> SpiritDSP and Christian were discussing the need for layered coding - no 

[Raymond]: I think layered coding (or embedded coding) is a nice feature to 
have.  Some of the other SDOs have standardized layered codecs.  Besides 
the pros and cons of layered coding already discussed last week, I think 
another potential benefit is that as the packets of layer-coded bit-stream 
traverse the network, higher-layer bits can be stripped off by network 
nodes to reduce congestion. (This is probably not done, but can be done.)

> The week before, we were discussing whether to consider Bluetooth and Wireless 
> IP as use cases. It seems to be a rough consensus
> that wireless IP is in-scope and that Bluetooth is out-of-scope because it
> requires too special optimizations. However, battery

[Raymond]: I read an article that says that PC was the big thing in 
the decade of 1990-2000, Internet was the big thing in the decade of 2000-
2010, and Mobile Internet will be the next big thing in the decade of 2010-
2020. Judging from the recent trends in smart phones, netbooks, and 
Tablets/iPad, it seems that Mobile Internet indeed will be the next big 
thing this decade.  Given this, I think battery-powered wireless Internet-
capable devices should be in-scope, and low codec complexity is an 
important consideration in these devices.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 12 May 2010 09:20:49 -0600

On May 9, 2010, at 12:10 PM, Christian Hoene wrote:

> delay,

Uh, can someone walk me through the low delay part? I either missed of failed to understand that 

> low complexity and mostly narrow band. But aren't those requirements already covered by existing codecs? Shall this working

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Raymond (Juin-Hwey) Chen" <[email-masked]>
Date: Wed, 12 May 2010 12:00:57 -0700

Hi Cullen,

In my original email discussion of VoIP gateways, I did not use the 
phrase "ultra-low delay".  What I did say was that due to the large 
number of voice channels that the DSPs and the (possibly two layers of) 
micro-controllers have to handle simultaneously, the timing/scheduling 
can be quite complex, and the necessary buffering at the (possibly 
three) hierarchical layers of processors can add substantial delay.  
Therefore, the worst-case codec-dependent one-way delay may be up to 5X 
to 6X the codec frame size before delay optimization, and even after 
the engineers "optimize the delay to death", they could only manage to 
get the worst-case codec-dependent delay down to around 3X codec frame 
size.  

Again, I didn't come up with that myself.  A senior technical guy who 
was deeply involved in high-density VoIP gateway designs told me that, 
and another technical guy who worked at a different company than the 
first guy and who was involved in the design of a different VoIP 
gateway based on a different DSP chip and a different system 
architecture independently gave me a range of codec-dependent one-way 
delay around 3X codec frame size, and he didn't know that I talked to 
the first guy.

Due to this 3X multiplier, an increase in the codec frame size will 
have a larger delay impact in VoIP gateways than, say, a softphone 
that has a lower multiplier.  Perhaps it was due to this larger 
multiplier that Christian used the phrase "ultra-low delay", but I 
myself didn't use that phrase.

I hope this answered your question.

Best Regards,

Raymond

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: Wednesday, May 12, 2010 8:21 AM
To: Christian Hoene
Cc: [email-masked]
Subject: Re: [codec] this weeks summary

Cullen Jennings

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: Michael Knappe <[email-masked]>
Date: Fri, 14 May 2010 08:53:09 -0700

Yes, thanks everyone for a lot of great discussion over the past several
weeks on a number of different issues. I think we're at a good point to
review this discussion and see what strong consensus points have emerged,
and also highlight any remaining issues for particular discussion as we lead
up to the Maastricht meeting in July.

I will be writing up a summary of tracker issues this weekend to send out to
the alias, let's make a big push in the next two weeks to close issues where
possible in preparation for the July meeting.

Cheers,

Mike