Subject: Re: [codec] Thresholds and delay.

From: Michael Knappe <[email-masked]>
Date: Tue, 11 May 2010 11:56:48 -0700

Stephen,

Agreed that achieving low enough latencies for sidetone perception should not be a goal of the wg, but we should be aiming if at all possible for better than 250 ms one-way delay in typical (and non-tandemed) deployments. The knee of the one-way delay impairment factor begins rising non-linearly somewhere between 150 and 250 ms.

Mike

________________________________
From: [email-masked] <[email-masked]>
To: Ben Schwartz <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Tue May 11 14:19:22 2010
Subject: Re: [codec] Thresholds and delay.

In the presence of echo, round-trip delay must be kept below 30 ms to
ensure that the echo is perceived as sidetone, according to the Springer
handbook of speech processing:
Though true, I don't think this is a mainstream consideration.

VOIP phones that are capable of speakerphone operation all have acoustic echo cancelers, and those cancelers are already tuned to deal with internet delays with other voice codecs.  Certainly our phones and videoconferencing systems do not have problems with path delays of this order (hundreds of milliseconds).

From my own experience (not testing) I agree with Brian's claim that 500 ms round trip is acceptable for most conversation.

It does depend on what you are doing, and there are certainly tasks where much lower delays are needed.

Regards,
Stephen Botzko

On Tue, May 11, 2010 at 2:06 PM, Ben Schwartz <[email-masked]<mailto:[email-masked]>> wrote:
On Tue, 2010-05-11 at 12:48 -0400, Marshall Eubanks wrote:
> As a point of order, I object to any graphs without an available paper
> behind them.

I have located the first paper mentioned by Christian Hoene at
http://ieeexplore.ieee.org/xpl/freeabs_all.jsp?arnumber=81952
but of course it's paywalled.

One test in that paper told trained subjects to "Take turns reading
random numbers aloud as fast as possible", on a pair of handsets with
narrowband uncompressed audio and no echo.  Subjects were able to detect
round-trip delays down to 90 ms.  Conversational efficiency was impaired
even with round-trip delay of 100 ms.

Let me emphasize again that these delays are round-trip, not one-way,
there is no echo, and the task, while designed to expose latency, is
probably less demanding than musical performance.

In the presence of echo, round-trip delay must be kept below 30 ms to
ensure that the echo is perceived as sidetone, according to the Springer
handbook of speech processing:

(http://books.google.com/books?id=Slg10ekZBkAC&lpg=PA83&ots=wc9yM9WrCs&dq=sidetone%20delay%2030%20ms&lr&pg=PA84#v=onepage&q&f=false)

Such low delays are clearly impossible on many paths, but for Boston to
New York City (or London to Paris), ping times can be less than 18 ms,
making echo->sidetone conversion just barely possible for a codec with
5ms frames.

I accept Brian Rosen's claim that a slow conversation doesn't normally
suffer greatly from round-trip latencies up to 500 ms, but under some
circumstances much lower latencies are valuable.  Let's make sure
they're achievable for those who can use them.

--Ben

_______________________________________________
codec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/codec

---

From: stephen botzko <[email-masked]>
Date: Tue, 11 May 2010 15:02:35 -0400

I agree, I wasn't meaning to propose 500 ms round trip times as the goal.

Stephen Botzko

On Tue, May 11, 2010 at 2:56 PM, Michael Knappe <[email-masked]> wrote:

> Stephen,
>
> Agreed that achieving low enough latencies for sidetone perception should
> not be a goal of the wg, but we should be aiming if at all possible for
> better than 250 ms one-way delay in typical (and non-tandemed) deployments.
> The knee of the one-way delay impairment factor begins rising non-linearly
> somewhere between 150 and 250 ms.
>
> Mike
>
> ------------------------------
>  *From*: [email-masked] <[email-masked]>
> *To*: Ben Schwartz <[email-masked]>
> *Cc*: [email-masked] <[email-masked]>
> *Sent*: Tue May 11 14:19:22 2010
> *Subject*: Re: [codec] Thresholds and delay.
> >>>
> VOIP phones that are capable of speakerphone operation all have acoustic
> echo cancelers, and those cancelers are already tuned to deal with internet
> delays with other voice codecs.  Certainly our phones and videoconferencing
> systems do not have problems with path delays of this order (hundreds of
> milliseconds).
>
> From my own experience (not testing) I agree with Brian's claim that 500 ms
> round trip is acceptable for most conversation.
>
> On Tue, May 11, 2010 at 2:06 PM, Ben Schwartz <[email-masked]>wrote:
>
>> (
>> http://books.google.com/books?id=Slg10ekZBkAC&lpg=PA83&ots=wc9yM9WrCs&dq=sidetone%20delay%2030%20ms&lr&pg=PA84#v=onepage&q&f=false
>> )
>>
>> [email-masked]