Subject: [codec] #13: reference use-cases and topologies!

From: "codec issue tracker" <[email-masked]>
Date: Sun, 11 Apr 2010 14:57:24 -0000

#13: reference use-cases and topologies!
------------------------------------+---------------------------------------
 Reporter:  hoene@…                 |       Owner:     
     Type:  defect                  |      Status:  new
 Priority:  critical                |   Milestone:     
Component:  requirements            |     Version:     
 Severity:  Active WG Document      |    Keywords:     
------------------------------------+---------------------------------------
 let’s start putting together a doc of use-cases and topologies that we
 expect the proposed codec to operate in. This will be useful for both
 determining implementation characteristics of the codec as well as its
 test regimen.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/codec/trac/ticket/13>
codec <http://tools.ietf.org/codec/>

---

From: "codec issue tracker" <[email-masked]>
Date: Wed, 21 Apr 2010 09:54:25 -0000

Comment(by hoene@…):

 The current draft
 http://tools.ietf.org/id/draft-ietf-codec-requirements-00.txt
 mentions:

 2.  Applications

    The following applications should be considered for Internet audio
    codecs, along with their requirements:

    o  Point to point calls

    o  Conferencing

    o  Telepresence

    o  Teleoperation

    o  In-game voice chat

    o  Live distributed music performances / Internet music lessons

    o  Other applications

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/codec/trac/ticket/13#comment:1>
codec <http://tools.ietf.org/codec/>

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 21 Apr 2010 12:09:02 +0200

Hello all,

this topic is of primal importance.

Are all reference use-cases already listed in the requirements-draft? Currently,
"Point to point calls, Conferencing, Telepresence, Teleoperation, In-game voice chat, Live distributed music performances / Internet music lessons" are listed. Is this list complete? Is this list order rightly?

At least use usages were mentioned previously: 
a) removing the need for echo cancelation because of ultra-low delay, when echoes are called side tones...
b) Push-to-talk (see below)

With are the topologies under study?
a) IPend-to-IPend?
b) IPend-to-transcoding_gateway-to-PSTNend?
c) n to n (decentralized conferencing)
e) IPend-to-legal_interception-to-X

What is important, what is missing?

Christian

PS:
"Scenario: Push-to-talk like service (PTT)

In spite of the development of broadband access (xDSL), a lot of users would only have service access via PSTN modems or mobile links. Also, on these links the available bandwidth might be shared among multiple flows and is subjected to congestion. Then, even low coding rates at about 8 kbps are too high.
If transmission capacity hardly exists, one still can degrade the quality of a telephone call to something like a push-to-talk (PTT) like service having very high latencies. Technically, this scenario takes advantage of bandwidth gains due to disruptive transmission (DTX) modes and very large packets containing multiple speech frames causing a very low packetization overhead."

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

>-----Original Message-----
>From: codec issue tracker [mailto:[email-masked]]
>Sent: Wednesday, April 21, 2010 11:54 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [codec] #13: reference use-cases and topologies!
>

---

From: Colin Perkins <[email-masked]>
Date: Wed, 21 Apr 2010 11:58:10 +0100

On 21 Apr 2010, at 10:54, codec issue tracker wrote:
> ------------------------------------ 
> +----------------------------------
> ------------------------------------ 
> +----------------------------------
>
> Comment(by hoene@…):
>
> The current draft

See RFC 5117.

-- 
Colin Perkins
http://csperkins.org/

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 21 Apr 2010 07:45:12 -0600

On 4/21/10 4:09 AM, Christian Hoene wrote:
> Are all reference use-cases already listed in the requirements-draft?
> Currently, "Point to point calls, Conferencing, Telepresence,
> Teleoperation, In-game voice chat, Live distributed music
> performances / Internet music lessons" are listed. Is this list
> complete? 

The list is illustrative, not complete.

> Is this list order rightly?

The list has no order.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 30 Apr 2010 08:35:59 -0600

> e) IPend-to-legal_interception-to-X

See RFC 2804

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html