Subject: Re: [codec] possible issues to track

From: Michael Knappe <[email-masked]>
Date: Thu, 25 Mar 2010 16:33:53 -0700

Just to clarify, is #3 what's sometimes called a fold-down scheme? (DVD-Audio for instance could generate stereo mixdowns from multi-channel content on the fly)

Mike

----- Original Message -----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Sent: Thu Mar 25 19:08:56 2010
Subject: Re: [codec] possible issues to track

>I agree with Stephen Botzko that the mechanism should not be part of the requirements.  However, we
>will need to agree on an interface, i.e. the abstraction barriers.  I think:
>
>1. The codec should provide an interface for coding a pair of closely coupled channels with the
>presumption that they represent something like a stereo pair.
>
>2.  The format should provide an efficient way to pack multiple independent synchronized codec
>channels into a single stream.
>
>3. The format should provide a way to specify N named output channels as linear combinations of the
>coded channels.

Later would make the mixing in a conference server also quite easy. Just pack the encoded active streams and set the linear equation
according to the placement of the participants. Very efficient!

Christian

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: "Benjamin M. Schwartz" <[email-masked]>
Date: Thu, 25 Mar 2010 20:58:37 -0400

> Just to clarify, is #3 what's sometimes called a fold-down scheme? (DVD-Audio for instance could generate stereo mixdowns from multi-channel content on the fly)

That would be one good use of it.  It could also be used to increase
efficiency by statically decoupling surround-sound channels.  For example,
a "7.1" channel mix could be transmitted as just two stereo pairs, with an
8x4 mixing matrix to produce the 8 output channels.  This obviously
wouldn't make full use of the speakers, but it would be allowable, and
maybe useful.  Even if the number of channels in and out is the same
(square mixing matrix), decorrelating the channels could improve compression.

Another possibility is to specify a number of different mixing matrices,
so that a single stream could have defined mixes for different output systems.

The biggest problem I see with this system is agreeing on channel names.
I wonder if there's an existing multichannel mapping or mixing
specification somewhere that we could borrow.

--Ben