Subject: [codec] 3/1/2010 weekly update

From: Michael Knappe <[email-masked]>
Date: Mon, 1 Mar 2010 07:52:15 -0800

Hello everyone!

This is the first of what will be weekly update emails on the progress of the codec WG. This will include the status of work in progress as well as a reminder list for upcoming events. Comments on form / content as always more than welcome. We’ll also post this info up on the wiki.

Adoption of WG  documents
========================
There is general consensus to adopt draft-valin-codec-guidelines-02 [3] as the initial version of the Codec Standardization Guidelines and draft-valin-codec-requirements-02 [4] as the initial version of the Technical Requirements, as starting points for discussion and further consensus building within the WG.

WG naming
==========
Koen Vos had a great proposal to change our longer WG title from “Internet Wideband Audio Codec” to ”Internet Interactive Audio Codec”, and there appears to be general consensus to move forward with that. Will update everyone on progress with the name change.

Codec info matrix
===============
We’d like to create on our wiki a matrix of basic information about a number of codecs that might be considered as input to the WG’s efforts. Please let Peter or I know if you’d like to help volunteer with that effort.

Upcoming events
===============
Tuesday, March 9, 2010, 18:00 UTC: Codec WG will hold a virtual interim
Meeting in preparation for IETF 77, meeting logistics to follow on the [email-masked] list.

Sunday, March 21, 2010: logistics TBD (sometime Sunday evening), proposed pre-WG codec beer bash / “technical” summit

Monday, March 22, 2010, 17:40 PST: codec WG at IETF 77 (provisional)

---

From: Keith Lantz <[email-masked]>
Date: Wed, 3 Mar 2010 00:10:47 -0800

With regard to a new name for the group, I would recommend "conversational" rather than "interactive" for two related reasons: First, "interactive" is used in the context of (streaming) services such as IPTV to denote the ability to interact with a stream -- e.g. trick play -- as opposed to two-way interaction between people. Thus, "interactive audio codec" is subject to being interpreted as a codec targeted for such services. Correspondingly, 3GPP, 3GPP2, PacketCable and other organizations/efforts adopted "conversational" to clearly identify services (and associated codecs) that support two-way communication between people. (Google for "conversational services" if you don't believe me. ;-))

With regard to the desired "matrix of basic information", you should consider starting with one of two existing matrices:

1. The matrices developed for the PacketCable 2.0 Codec & Media Specification -- in particular, Annexes C & D. 

2. The matrix/database developed by ITU-T Study Group 16 in support of its activities. Unfortunately, I have misplaced the URL, but I am sure someone on this distribution must have it.

I have the Excel workbook that provided the basis for #1 above -- plus similar, but less complete, data on super-wideband codecs such as AAC and AC-3. If there is interest I will volunteer to attempt to secure CableLabs' formal approval to make it publicly available.

Keith

On Mar 1, 2010, at 7:52 AM, Michael Knappe wrote:

> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Michael Knappe <[email-masked]>
Date: Wed, 3 Mar 2010 00:47:39 -0800

Keith,

Thanks for the matrix info, will look through that in the morning, much appreciated.

On the topic of “conversational” vs “interactive”, there has been an effort to keep the audio carriage of the codec general and not speech-specific, yet clearly ‘interactive’ in nature, where an audio event at one end could be heard and responded to as quickly as possible at the other end. Picking non-overlapping language will always be a challenge – ironically the term ‘codec’ itself describes both a signal compression/decompression algorithm as well as the hardware packaging of an A/D and D/A converter on the same silicon, with both instances used back to back in an IP phone! (that’s always a tough one to explain when block diagramming...).    I would recommend sticking with ‘interactive’ for now.

Cheers,

Mike

On 3/3/10 12:10 AM, "Keith Lantz" <[email-masked]> wrote:

1. The matrices developed for the PacketCable 2.0 Codec & Media Specification <http://www.cablelabs.com/specifications/PKT-SP-CODEC-MEDIA-I08-100120.pdf>  -- in particular, Annexes C & D.

Keith

Hello everyone!

Adoption of WG  documents
========================

WG naming
==========

Codec info matrix
===============

Upcoming events
===============

---

From: "Roni Even" <[email-masked]>
Date: Fri, 5 Mar 2010 05:55:05 +0200

Hi,
I do not think that the name is important. The important part is that the
requirements will be clear and precise without contradicting the charter.
The requirements list the applications and if it will have all applications
than it will be challenging to develop one codec as the charter says that
will address too many usages. It will be important to prioritize the
applications and the major motivation as most of the people mentioned on the
list and in the discussions was conversional services with VOIP as the major
one.
Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Michael Knappe
> Sent: Wednesday, March 03, 2010 10:48 AM
> To: Keith Lantz
> Cc: [email-masked]
> Subject: Re: [codec] 3/1/2010 weekly update
> 
> Keith,
> 
> On the topic of "conversational" vs "interactive", there has been an
> effort to keep the audio carriage of the codec general and not speech-
> specific, yet clearly 'interactive' in nature, where an audio event at
> one end could be heard and responded to as quickly as possible at the
> other end. Picking non-overlapping language will always be a challenge
> - ironically the term 'codec' itself describes both a signal
> compression/decompression algorithm as well as the hardware packaging
> of an A/D and D/A converter on the same silicon, with both instances
> used back to back in an IP phone! (that's always a tough one to explain
> when block diagramming...).    I would recommend sticking with
> 'interactive' for now.
> 
> Cheers,
> 
> Mike
> 
> 
> With regard to a new name for the group, I would recommend
> "conversational" rather than "interactive" for two related reasons:
> First, "interactive" is used in the context of (streaming) services
> such as IPTV to denote the ability to interact with a stream -- e.g.
> trick play -- as opposed to two-way interaction between people. Thus,
> "interactive audio codec" is subject to being interpreted as a codec
> targeted for such services. Correspondingly, 3GPP, 3GPP2, PacketCable
> and other organizations/efforts adopted "conversational" to clearly
> identify services (and associated codecs) that support two-way
> communication between people. (Google for "conversational services" if
> you don't believe me. ;-))
> 
> With regard to the desired "matrix of basic information", you should
> consider starting with one of two existing matrices:
> 
> 1. The matrices developed for the PacketCable 2.0 Codec & Media
> Specification <http://www.cablelabs.com/specifications/PKT-SP-CODEC-
> MEDIA-I08-100120.pdf>  -- in particular, Annexes C & D.
> 
> 2. The matrix/database developed by ITU-T Study Group 16 in support of
> its activities. Unfortunately, I have misplaced the URL, but I am sure
> someone on this distribution must have it.
> 
> I have the Excel workbook that provided the basis for #1 above -- plus
> similar, but less complete, data on super-wideband codecs such as AAC
> and AC-3. If there is interest I will volunteer to attempt to secure
> CableLabs' formal approval to make it publicly available.
> 
> Keith
> 
> This is the first of what will be weekly update emails on the progress
> of the codec WG. This will include the status of work in progress as
> well as a reminder list for upcoming events. Comments on form / content
> as always more than welcome. We'll also post this info up on the wiki.
> 
> Adoption of WG  documents
> ========================
> There is general consensus to adopt draft-valin-codec-guidelines-02 [3]
> as the initial version of the Codec Standardization Guidelines and
> draft-valin-codec-requirements-02 [4] as the initial version of the
> Technical Requirements, as starting points for discussion and further
> consensus building within the WG.
> 
> WG naming
> ==========
> Koen Vos had a great proposal to change our longer WG title from
> "Internet Wideband Audio Codec" to "Internet Interactive Audio Codec",
> and there appears to be general consensus to move forward with that.
> Will update everyone on progress with the name change.
> 
> Codec info matrix
> ===============
> We'd like to create on our wiki a matrix of basic information about a
> number of codecs that might be considered as input to the WG's efforts.
> Please let Peter or I know if you'd like to help volunteer with that
> effort.
> 
> Upcoming events
> ===============
> Sunday, March 21, 2010: logistics TBD (sometime Sunday evening),
> proposed pre-WG codec beer bash / "technical" summit
>