Subject: [codec] #2: Please identify Requirements non-ambiguous and give them priorities.

From: "codec issue tracker" <[email-masked]>
Date: Tue, 23 Mar 2010 17:29:48 -0000

#2: Please identify Requirements non-ambiguous and give them priorities.
------------------------------------+---------------------------------------
 Reporter:  hoene@…                 |       Owner:     
     Type:  defect                  |      Status:  new
 Priority:  major                   |   Milestone:     
Component:  requirements            |     Version:     
 Severity:  Active WG Document      |    Keywords:     
------------------------------------+---------------------------------------
 I would suggest to add structure the requirement document.
 Especially, in the upcoming time of requirements discussion, it might be
 useful to number all single requirements and give them priorities.
 One could use a hierarchical numbering scheme and priorities such as
 trival, minor, major...

-- 
Ticket URL: <http://tools.ietf.org/wg/codec/trac/ticket/2>
codec <http://tools.ietf.org/codec/>

---

From: "codec issue tracker" <[email-masked]>
Date: Thu, 25 Mar 2010 22:46:43 -0000

Comment(by hoene@…):

 From Peter Saint-Andre:
 - clarify whether each requirement is nice or necessary

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/codec/trac/ticket/2#comment:1>
codec <http://tools.ietf.org/codec/>

---

From: "Christian Hoene" <[email-masked]>
Date: Sun, 28 Mar 2010 18:07:19 +0200

Hi,

what do you think about the following classification of requirements?

Requirements:
- Measurable features that the CODEC MUST fulfill.
- Requirements are verified in the qualification phase.

Objective:
- The designer try to work thoughts this objective. E.g., the CODEC SHALL support DTMF.
- Objectives are measured in the qualification phase to know to what degree they are fulfilled.

Priority:
- HIGH: This is required for the main use causes that occur frequently (>10% of all calls, e.g. IP-to-IP transmission). The codec MUST be optimized towards this feature.
- MEDIUM: Might be used from time-to-time (1%), e.g. tandem coding  with G.722.2
- LOW: Rather seldom, the codec needs not to perform very well in this scenario (<=0.1%), e.g. PSTN-to-PSTN interconnect

Cheers

 Christian

---------------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen 
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532 
http://www.net.uni-tuebingen.de/

>-----Original Message-----
>From: codec issue tracker [mailto:[email-masked]]
>Sent: Thursday, March 25, 2010 11:47 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [codec] #2: Please identify Requirements non-ambiguous and give them priorities.
>