Subject: [codec] updated charter

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Dec 2009 16:25:27 -0700

I've tried to update the charter in accordance with my sense of the room
in Hiroshima, specifically with regard to the goal of producing a single
codec:

http://trac.tools.ietf.org/bof/trac/attachment/wiki/BifIETF76/codec-charter.txt

Feedback is welcome as always.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Thu, 10 Dec 2009 17:23:56 -0600

> Feedback is welcome as always.

This looks good to me, and I do think you've captured the essence of the
discussions in Hiroshima.

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
skype: kpfleming | jabber: [email-masked]
Check us out at www.digium.com & www.asterisk.org

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 10 Dec 2009 16:45:10 -0700

> discussions in Hiroshima.

Super, thanks. I see that formation of the Codec WG is on the agenda for
the next IESG telechat, so perhaps there will be an IETF Last Call about
this in the near future. :)

https://datatracker.ietf.org/iesg/agenda/

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Roni Even" <[email-masked]>
Date: Fri, 11 Dec 2009 10:09:34 +0200

Hi Peter,
In general it looks OK. I have one question.
The requirement document is defined to be informational yet I believe it will provide values for codec quality requirements that will need to be passed by the proposed codec.
In this case should this document be informational or have more normative value. I assume that an informational document can be a normative reference.

Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Peter Saint-Andre
> Sent: Thursday, December 10, 2009 1:25 AM
> To: [email-masked]
> Subject: [codec] updated charter
> 
> I've tried to update the charter in accordance with my sense of the
> room in Hiroshima, specifically with regard to the goal of producing a
> single
> codec:
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 14 Dec 2009 15:48:48 -0700

On 12/11/09 1:09 AM, Roni Even wrote:
> Hi Peter, In general it looks OK. I have one question. The
> requirement document is defined to be informational yet I believe it
> will provide values for codec quality requirements that will need to
> be passed by the proposed codec. In this case should this document be
> informational or have more normative value. I assume that an
> informational document can be a normative reference.

Yes, a standards-track document can have a normative reference to an
informational document -- as I understand it, "normative" means "you
must understand the referenced document in order to understand this
document", and that relationship often applies to referenced documents
that contain requirements. However, it's a bit of a judgement call as to
whether the requirements document should be a normative reference or an
informative reference (and there is some controversy about whether the
distinction between normative and informative references is all that
useful anyway...).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: stephen botzko <[email-masked]>
Date: Mon, 14 Dec 2009 19:30:27 -0500

Though normative references made by other SDOs (in their standards) have to
be made to a standards track document in the IETF.  So perhaps that is a
consideration here.

Regards,
Stephen Botzko
Polycom

On Mon, Dec 14, 2009 at 5:48 PM, Peter Saint-Andre <[email-masked]>wrote:

> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec
>
>

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 14 Dec 2009 18:04:07 -0800

Huh?  The only body that has been moderately picky about RFC status that I¹m
aware of is the ITU.  Moderately, because I do recall references to
experimental RFCs in ITU Recs, and there are certainly normative references
to obsolete/historic RFCs.
In many other mainstream SDOs, e.g. ETSI or TIA, normative references to
informational documents are perfectly fine.
Stephan

On 12/14/09 4:30 PM, "stephen botzko" <[email-masked]> wrote:

> Though normative references made by other SDOs (in their standards) have to be
> made to a standards track document in the IETF.  So perhaps that is a
> consideration here.
>  
> Regards,
> Stephen Botzko
> Polycom
> 
> On Mon, Dec 14, 2009 at 5:48 PM, Peter Saint-Andre <[email-masked]> wrote:

---

From: stephen botzko <[email-masked]>
Date: Mon, 14 Dec 2009 22:39:35 -0500

The ITU-T was whati was thinking of.  Currently the ITU-T does not allow
normative references to informative or experimental RFCs.

Existing references are not always caught, but they are supposed to be
updated when the text is rerised.  I'm the editor of H.323, I had to revise
the text in order to remove several of these references In V7  (consented in
Novemver).

Added references *are* all checked, and you can't add references to
obsolete/historic RFCS unless you can provide a justification for referring
to something obsolete.  Likewise, you cannot add a new normative reference
to an informational RFC.

Regards,
Stephen Botzko
Polycom

On Mon, Dec 14, 2009 at 9:04 PM, Stephan Wenger <[email-masked]> wrote:

>  Huh?  The only body that has been moderately picky about RFC status that
> I’m aware of is the ITU.  Moderately, because I do recall references to
> ------------------------------