Subject: [codec] Comments on BoF charter problem statement

From: "Ingemar Johansson S" <[email-masked]>
Date: Wed, 4 Nov 2009 10:14:15 +0100

Hi

I have a comment on the introduction to the Codec BoF charter.
Quote:
"There are no standardized, high-quality audio codecs that are optimized for use in interactive Internet applications and that can be widely implemented and easily distributed among application developers, service operators, and end users."

This easily gives the hurried reader the impression that there are no codecs optimized for interactive internet applications available. This is not a correct statement. As I see it the main issue raised (especially on the codec list) is round the magic words "Royalty free". The statement above mix the tecnical and legal issues and I don't like that.

I would rather have seen a statement written something like.

"There exists a desire for standardized, high-quality codecs that can be widely implemented and easily distributed among application developers, service operators, and end users. Standards for this exists but the free use is restricted by royalty conditions"
Something like the above (perhaps with some better words) will give the reader a much better idea of what has actually been discussed on the codec list as well as during the last BoF

/Ingemar  

=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Research Engineer 

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 04 Nov 2009 14:16:45 -0700

On 11/4/09 2:14 AM, Ingemar Johansson S wrote:
> Hi
> 
> I have a comment on the introduction to the Codec BoF charter. Quote:
>  "There are no standardized, high-quality audio codecs that are
> optimized for use in interactive Internet applications and that can
> be widely implemented and easily distributed among application
> developers, service operators, and end users."
> 
> This easily gives the hurried reader the impression that there are no
> codecs optimized for interactive internet applications available.
> This is not a correct statement. As I see it the main issue raised
> (especially on the codec list) is round the magic words "Royalty
> free". The statement above mix the tecnical and legal issues and I
> don't like that.
> 
> "There exists a desire for standardized, high-quality codecs that can
> be widely implemented and easily distributed among application
> developers, service operators, and end users. Standards for this
> exists but the free use is restricted by royalty conditions" 
> Something like the above (perhaps with some better words) will give
> the reader a much better idea of what has actually been discussed on
> the codec list as well as during the last BoF

Thank you for the suggested text. I see several points:

1. The text you suggest says nothing about making sure that a codec is
optimized for use in Internet applications, and that is an important
consideration for the proposed work.

2. There exist codecs that can be widely implemented and easily
distributed, but they are not standardized through any SDO (and,
according to reports from application developers and service operators,
the lack of standardization and clear change control has hindered adoption).

3. There exist codecs that are standardized, but they cannot be widely
implemented and easily distributed (and, again according to reports from
application developers and service operators, the presence of usage
restrictions in the form of licensing fees and restriction has hindered
adoption).

My understanding is that the people who are interested in completing
this work would like to achieve a combination of (1) Internet-optimized,
(2) standardized through a SDO, and (3) free of usage restrictions.

I agree that this could be worded more clearly, and I'll try to do that
soon.

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 04 Nov 2009 14:42:53 -0700

> I agree that this could be worded more clearly, and I'll try to do that

Unfortunately, describing this all in detailed requires more words. :)
Here is proposed text...

###

Problem Statement

According to reports from developers of Internet audio applications
and operators of Internet audio services, there are no standardized,
high-quality audio codecs that meet all of the following three
conditions:

1. Are optimized for use in interactive Internet applications.

2. Can be widely implemented and easily distributed among application
developers, service operators, and end users.

3. Are published by a recognized standards development organization
(SDO) and therefore subject to clear change control.

There exist codecs that provide high quality encoding of audio
information, but that are not optimized for the actual conditions of
the Internet; according to reports, this mismatch between design and
deployment has hindered adoption of such codecs in interactive Internet
applications.

There exist codecs that can be widely implemented and easily
distributed, but that are not standardized through any SDO; according
to reports, this lack of standardization and clear change control has
hindered adoption of such codecs in interactive Internet applications.

There exist codecs that are standardized, but that cannot be widely
implemented and easily distributed; according to reports, this presence
of various usage restrictions (e.g., in the form of licensing fees and
royalties) has hindered adoption of such codecs in interactive Internet
applications.

Therefore, there exists demand among application developers and service
operators for audio codecs that meet all three of these criteria.
According to reports, filling this perceived gap would enable protocol
designers to more easily specify mandatory-to-implement codecs in their
protocols and thus improve interoperability, would enable developers to
more easily build innovative, interactive applications for the Internet,
would enable service operators to more easily deploy affordable,
high-quality audio services on the Internet, and would enable end users
of Internet applications and services to enjoy an improved user experience.

###

/psa

---

From: "Roni Even" <[email-masked]>
Date: Thu, 5 Nov 2009 13:59:15 +0200

Hi, 
I think that Ingemar made a good point and it should be addressed.
I also do not agree that the reason for lack of deployment of wideband is
because of royalties.
My observation is that wideband is being used in markets where the parties
that had interest in wide band audio agreed to select specific codec from
the available codecs.
That can be seen in video conferencing and in 3GPP. This is also tied to my
view that if the group want to succeed it should define one codec.
Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Peter Saint-Andre
> Sent: Wednesday, November 04, 2009 11:17 PM
> To: Ingemar Johansson S
> Cc: [email-masked]
> Subject: Re: [codec] Comments on BoF charter problem statement
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAkrx7z0ACgkQNL8k5A2w/vwmxgCeK/imxMeOid/SsF8GITber2Kv
> h0AAoIGJ5VVSIeMQrJcosUEttYk5igQg
> =WYju
> -----END PGP SIGNATURE-----
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Thu, 5 Nov 2009 13:16:18 +0100

Hi

The rewritten intro looks much better. One remaining concern is perhaps
that royalty free/licence free is not mentioned in bullet 2 but if I
understand it right you wanted to keep the 3 bullets short and explain
the details further down. 
Anyway I now see that the apples and oranges (technical and legal
matters) are kept separate and that is good.

/Ingemar

> From: Peter Saint-Andre [mailto:[email-masked]] 
> Sent: den 4 november 2009 22:43
> To: Ingemar Johansson S
> Cc: [email-masked]
> > according to reports from application developers and service 
> > operators, the lack of standardization and clear change 
> control has hindered adoption).
> > 
> > implemented and easily distributed (and, again according to reports 
> > from application developers and service operators, the presence of 
> > usage restrictions in the form of licensing fees and 
> restriction has 
> > hindered adoption).
> > 
> > I agree that this could be worded more clearly, and I'll try to do 
> > that soon.
> > 
> > Peter
> 
> Unfortunately, describing this all in detailed requires more 
> words. :) Here is proposed text...
> 
> ###
> 
> Problem Statement
> 
> According to reports from developers of Internet audio 
> applications and operators of Internet audio services, there 
> are no standardized, high-quality audio codecs that meet all 
> of the following three
> conditions:
> 
> 2. Can be widely implemented and easily distributed among 
> application developers, service operators, and end users.
> 
> There exist codecs that provide high quality encoding of 
> audio information, but that are not optimized for the actual 
> conditions of the Internet; according to reports, this 
> mismatch between design and deployment has hindered adoption 
> of such codecs in interactive Internet applications.
> 
> distributed, but that are not standardized through any SDO; 
> according to reports, this lack of standardization and clear 
> change control has hindered adoption of such codecs in 
> interactive Internet applications.
> 
> There exist codecs that are standardized, but that cannot be 
> widely implemented and easily distributed; according to 
> reports, this presence of various usage restrictions (e.g., 
> in the form of licensing fees and
> royalties) has hindered adoption of such codecs in 
> interactive Internet applications.
> 
> Therefore, there exists demand among application developers 
> and service operators for audio codecs that meet all three of 
> these criteria.
> According to reports, filling this perceived gap would enable 
> protocol designers to more easily specify 
> mandatory-to-implement codecs in their protocols and thus 
> improve interoperability, would enable developers to more 
> easily build innovative, interactive applications for the 
> Internet, would enable service operators to more easily 
> deploy affordable, high-quality audio services on the 
> Internet, and would enable end users of Internet applications 
> and services to enjoy an improved user experience.
> 
> ###
> 
> /psa
> 
> iEYEARECAAYFAkrx9V0ACgkQNL8k5A2w/vyWFACfboDwdLLWyzMmZFgUHRso5WHS
> F3wAn2Dbj9dW8S9/Exme0s3JMEt2KAVA
> =fCjL

---

From: Darren Longhorn <[email-masked]>
Date: Thu, 05 Nov 2009 15:12:33 +0000

> that had interest in wide band audio agreed to select specific codec from

I would agree with that, but there is still a preference for royalty
free, I have, for example, seen commercial deployments where speex was
chosen over amr-wb for exactly that reason.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Nov 2009 10:20:16 -0700

> matters) are kept separate and that is good.

Yes, I think it is good to separate those concerns.

I have updated the draft charter here:

http://trac.tools.ietf.org/bof/trac/attachment/wiki/BifIETF76/codec-charter.txt

So that we can have stable documents for review, probably Eric and I
won't upload further revisions to the draft charter before the BoF next
Thursday.

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Nov 2009 10:24:12 -0700

> chosen over amr-wb for exactly that reason.

Thanks for the feedback. I think that is consistent with reports
received from service operators and application developers.

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Koen Vos <[email-masked]>
Date: Fri, 06 Nov 2009 01:40:22 -0800

Quoting Roni Even:
> This is also tied to my view that if the group want to succeed it  
> should define one codec.

Roni, could you please elaborate on what you mean by "one codec," and  
why you think it matters?

AMR-WB has several modes, is that ok?
H.264 consists a whole toolbox of models and modes (AVC, SVC, MVC),  
not all of them supported by all implementations of H.264. Is that ok?

thanks,
koen.

---

From: "Roni Even" <[email-masked]>
Date: Fri, 6 Nov 2009 15:34:24 +0200

Hi Koen,
The AMR-WB was defined as one codec as discussed in earlier thread by
Ingemar for a specific application. The operation point is negotiable. This
is a reasonable solution if the requirement will be for multiple operation
points (in this case BW). What is not reasonable is to have two different
codecs with overlapping operation points for the same application.  You do
not start with multiple application and the requirements for the multiple
application and let everyone choose the subset they wants to support.
If one of the worries is deployment by people who worry about the cost of
deployment than one of the aspect of cost is the need to support multiple
codecs. Cost is not only how much royalty you pay but also how you maintain
your solution and support your customers.
As for the video SVC and MVC are enhancements to AVC.
Roni Even

> From: Koen Vos [mailto:[email-masked]]
> Sent: Friday, November 06, 2009 11:40 AM
> To: Roni Even
> Cc: 'Peter Saint-Andre'; 'Ingemar Johansson S'; [email-masked]

---

From: Koen Vos <[email-masked]>
Date: Fri, 06 Nov 2009 06:17:41 -0800

Hi Roni,

Maybe we should require that we will have a single codec, possibly  
with multiple modes - just to avoid confusion from circular definitions.

Is your wish simply to guarantee that all compliant implementations  
will be able to talk to each other?  That could for instance be  
guaranteed by requiring that any implementation needs to support more  
than half of the modes in the standard.

> What is not reasonable is to have two different
> codecs with overlapping operation points for the same application.

Not sure what you mean here, can you give an example? The same codec  
under two different names?

best,
koen.