Subject: [codec] Switching codecs and coding mode.

From: "Christian Hoene" <[email-masked]>
Date: Tue, 3 Nov 2009 10:30:03 +0100

Hello, 

Last week we had a discussion on the impact of switching between codecs and
between coding modes. I made a short review of related work to understand
the current state of the art. Actually, we have to distinguish multiple
different effects.

1.       The first is based on the fact that in case of mode or coding
switching a segment of speech consists of parts having good quality and
parts having bad quality. The question arises on how the overall quality is
judged. Some pioneering studies in this field have been made by AD Clark –
not in the case of switching the codecs/coding mode but for changing loss
rates. Refer to [1]. Also, [2] suggests an extension to the E-Model [2] to
support changing qualities.

2.       The event of changing the codec/coding mode might introduce
additional distortions. We can distinguish three cases:

a.       Changing of the bit rate, e.g. changing the frame size in CELT, the
bitpool value SBC and the coding rate in AMR/AMR-WB: I did not found any
listening-test results that there is any impairment beyond those described
in point 1. For example, it has been proven that CELT AND AMR do support the
seamless switching between coding modes.

b.      Changes in the packet rate might require a rescheduling of the
playout time because of the changed packetization delay. The resulting time
stretching or time compression might introduce additional distortions. Refer
to e.g. [3]. 

c.       Switching between two different codecs or switching the sampling
rate of a codec (e.g. 16 to 48 kHz in case of SBC, 32 to 48 kHz in case of
CELT, or between AMR-NB and AMR-WB) introduces distortions caused by the
needed synchronization of the decoder. Refer to [4] and [5] for
listening-tests in case of G.711 and G.722.2. In these publications they
noticed a notable distortion caused by switching between wideband and
narrowband. You hear them especially well if other transmission conditions
are good (e.g. no packet losses)

All these switching events might be concealed via various technical
approaches. However, I did not found any publications or patents on it –
deeper literature survey might be required.

To conclude, we can state that it is important that the system supports the
seamless of codecs or coding modes. If not, the distortion will be quite
notable.

Christian

[1] AD Clark, „
<http://www.ocecpr.org.cy/media/documents/Reports/ElectronicCom/EC_Publicati
on_Model-EffOfBurstPacketLoss-RecencyOnSVQ_EN_13-08-2003_VI.pdf> Modeling
the effects of burst packet loss and recency on subjective voice quality“,
Proc. IP Telephony Workshop, 2001 for details.

[2] Lewcio, B., Wältermann, M., Möller, S., Vidales, P. (2009). "E-model
supported Switching between Narrowband and Wideband Speech Quality". In:
Proc. 1st Int. IEEE Workshop on Quality of Multimedia Experience (QoMEX
'09), 29-31 July, US-San Diego CA.

[3] Y. J. Liang, N. Färber, and B. Girod, “Adaptive playout scheduling and
loss concealment for voice communication over IP networks,” IEEE
Transactions on Multimedia, vol. 5, no. 4, pp. 532–543, Dec. 2003.

[4] Lewcio, B., Möller, S. ,Vidales,P. Wältermann, M.,Kirschnick, N. (2008).
Methods for multimedia service adaptation in Next Generation Networks, in
Proceedings of the ETSI STQ 2008 Workshop on Effects of Transmission
Performance on Multimedia QoS,CZ-Prague, 17-19 June.

[5] Möller, S., Wältermann, M., Lewcio, B., Kirschnick, N., Vidales, P.
(2008). Handovers between Narrowband and Wideband Speech Transmission, in:
Sprachkommunikation 2008. Beiträge der 8. ITG-Fachtagung vom 8. bis 10.
Oktober 2008 in Aachen, ITG-Fachbericht 211, VDE-Verlag, DE-Berlin.

--------------------------------------------------------

Dr.-Ing. Christian Hoene

Interactive Communication Systems (ICS), University of Tübingen

Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532

http://www.net.uni-tuebingen.de/

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Tue, 3 Nov 2009 13:55:08 +0100

Hi
 
Please note the observation that AMR and AMR-WB does not give any switching artifacts when switching between codec modes. In fact the whole idea with AMR (Adaptive MultiRate) is to be able to freely switch between codec rates without artifacts. 
 
Regards
Ingemar

________________________________

	From: Christian Hoene [mailto:[email-masked]] 
	Sent: den 3 november 2009 10:30
	To: [email-masked]
	Subject: [codec] Switching codecs and coding mode.

	Hello, 

	Last week we had a discussion on the impact of switching between codecs and between coding modes. I made a short review of related work to understand the current state of the art. Actually, we have to distinguish multiple different effects.

	1.       The first is based on the fact that in case of mode or coding switching a segment of speech consists of parts having good quality and parts having bad quality. The question arises on how the overall quality is judged. Some pioneering studies in this field have been made by AD Clark - not in the case of switching the codecs/coding mode but for changing loss rates. Refer to [1]. Also, [2] suggests an extension to the E-Model [2] to support changing qualities.

	2.       The event of changing the codec/coding mode might introduce additional distortions. We can distinguish three cases:

	a.       Changing of the bit rate, e.g. changing the frame size in CELT, the bitpool value SBC and the coding rate in AMR/AMR-WB: I did not found any listening-test results that there is any impairment beyond those described in point 1. For example, it has been proven that CELT AND AMR do support the seamless switching between coding modes.

	b.      Changes in the packet rate might require a rescheduling of the playout time because of the changed packetization delay. The resulting time stretching or time compression might introduce additional distortions. Refer to e.g. [3]. 

	c.       Switching between two different codecs or switching the sampling rate of a codec (e.g. 16 to 48 kHz in case of SBC, 32 to 48 kHz in case of CELT, or between AMR-NB and AMR-WB) introduces distortions caused by the needed synchronization of the decoder. Refer to [4] and [5] for listening-tests in case of G.711 and G.722.2. In these publications they noticed a notable distortion caused by switching between wideband and narrowband. You hear them especially well if other transmission conditions are good (e.g. no packet losses)

	All these switching events might be concealed via various technical approaches. However, I did not found any publications or patents on it - deeper literature survey might be required.

	To conclude, we can state that it is important that the system supports the seamless of codecs or coding modes. If not, the distortion will be quite notable.

	Christian

	[1] AD Clark, "Modeling the effects of burst packet loss and recency on subjective voice quality <http://www.ocecpr.org.cy/media/documents/Reports/ElectronicCom/EC_Publication_Model-EffOfBurstPacketLoss-RecencyOnSVQ_EN_13-08-2003_VI.pdf> ", Proc. IP Telephony Workshop, 2001 for details.

	[2] Lewcio, B., Wältermann, M., Möller, S., Vidales, P. (2009). "E-model supported Switching between Narrowband and Wideband Speech Quality". In: Proc. 1st Int. IEEE Workshop on Quality of Multimedia Experience (QoMEX '09), 29-31 July, US-San Diego CA.

	[3] Y. J. Liang, N. Färber, and B. Girod, "Adaptive playout scheduling and loss concealment for voice communication over IP networks," IEEE Transactions on Multimedia, vol. 5, no. 4, pp. 532-543, Dec. 2003.

	[4] Lewcio, B., Möller, S. ,Vidales,P. Wältermann, M.,Kirschnick, N. (2008). Methods for multimedia service adaptation in Next Generation Networks, in Proceedings of the ETSI STQ 2008 Workshop on Effects of Transmission Performance on Multimedia QoS,CZ-Prague, 17-19 June.

	[5] Möller, S., Wältermann, M., Lewcio, B., Kirschnick, N., Vidales, P. (2008). Handovers between Narrowband and Wideband Speech Transmission, in: Sprachkommunikation 2008. Beiträge der 8. ITG-Fachtagung vom 8. bis 10. Oktober 2008 in Aachen, ITG-Fachbericht 211, VDE-Verlag, DE-Berlin.

	Dr.-Ing. Christian Hoene