Subject: [codec] G.719 royalty-free license

From: "Ingemar Johansson S" <[email-masked]>
Date: Wed, 11 Nov 2009 16:26:24 +0100

Hi

I have the following announcement regarding G.719

Ericsson offers a royalty-free license under Ericsson's G.719 standard essential patents for end user products. 
The license agreement can be obtained by contacting [email-masked]

Regards
Ingemar
=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Research Engineer 

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================

---

From: "Jean-Marc Valin" <[email-masked]>
Date: Wed, 11 Nov 2009 10:53:22 -0500

Hi,

I think this is great news! I guess this shows that collaboration would be possible. I would personally like to invite Ericsson to contribute the G.719 technology as input to the proposed working group. This could certainly help towards meeting some of the requirements we currently have and create an overall better codec.

Cheers,

	Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Ingemar Johansson S
Sent: Wed 11/11/2009 10:26 AM
To: [email-masked]
Subject: [codec] G.719 royalty-free license
 
Hi

Regards
Ingemar

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================
_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: "Anisse Taleb" <[email-masked]>
Date: Wed, 11 Nov 2009 16:38:26 +0100

Hi Ingo,
This is indeed quite interesting news given that this is a brand new codec
and the first ITU-T fullband conversational codec.

I assume this means that the codec is entirely royalty free since Polycom
offers also a royalty free license? Any comments on this?

Thanks for the information.

/Abisse 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ingemar Johansson S
> Sent: den 11 november 2009 16:26
> To: [email-masked]

---

From: "Benjamin M. Schwartz" <[email-masked]>
Date: Wed, 11 Nov 2009 11:30:22 -0500

> offers also a royalty free license? Any comments on this?

Polycom's license is "royalty free" but contains various use restrictions
and advertising clauses.  It is far from "no strings attached".  We don't
know what Ericsson's license says, although we now know how to find out
what it is.  Even Ericsson's license were a universal binding patent
non-assertion statement, the codec would still not be compatible with
common open-source licenses due to Polycom's patent licensing restrictions.

--Ben

---

From: Monty Montgomery <[email-masked]>
Date: Wed, 11 Nov 2009 12:59:13 -0500

Nonetheless excellent news that brings us another solid step forward
in untangling the IP web around internet codecs.   I'm glad to see it!

Monty

---

From: stephen botzko <[email-masked]>
Date: Wed, 11 Nov 2009 13:00:30 -0500

The license agreement from Polycom can be found here:
http://www.polycom.com/company/about_us/technology/siren_g7221/license_schedule.html

with a faq sheet here:
http://www.polycom.com/company/about_us/technology/siren_g7221/faq.html

Note that Polycom licenses G.722.1 and G.719 with the same agreement.

Stephen Botzko
Polycom.

---

From: <[email-masked]>
Date: Wed, 11 Nov 2009 19:38:17 +0100

Hi,
The Polycomm license agreement states that "In the event that Licensee makes a Qualifying Patent Assertion against Polycom or any of its subsidiaries, Polycom may immediately terminate all patent rights conveyed herein."  I'm not a lawer, but I interprete this such that the Licensee also gives his whole patent portfolio royalty-free to Polycomm if he wants to get the Polycomm codec royalty-free. Am I right?

Best regards,
Jari Hagqvist

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext stephen botzko
Sent: 11. marraskuuta 2009 20:01
To: [email-masked]
Subject: [codec] Fwd: G.719 royalty-free license

with a faq sheet here:

Stephen Botzko
Polycom.

On Wed, Nov 11, 2009 at 11:30 AM, Benjamin M. Schwartz <[email-masked]<mailto:[email-masked]>> wrote:

--Ben

_______________________________________________
codec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/codec

---

From: Eric Burger <[email-masked]>
Date: Thu, 12 Nov 2009 06:04:55 +0900

That is correct. There is another issue, which is inventors do not  
necessarily need to give up their entire rights in a technology in  
order to create a royalty free standard.

No large portfolio company will agree to "my one patent in a corner of  
a standard equals your portfolio of 55,000 patents." Assertions like  
this are a sure way to keep large technology firms from participating  
(unless that is your goal).

Reasonable royalty free agreements have the following points;

o  Royalty Free FOR USE TO IMPLEMENT AND MARKET ARTIFACTS THAT  
IMPLEMENT THE PUBLISHED STANDARD

    - This just states the IPR comes with no strings attached for the  
purposes of using the RFC, when published

    - This also allows the inventor to keep their rights for other  
purposes. This is an incentive for people to release their IPR without  
writing a blank check. This disproportionally protects small  
inventors, by the way.

o  License revoked if you assert IPR against me because of my  
IMPLEMENTATION OF THE PUBLISHED STANDARD

    - This provides incentives to prevent a party that did not  
participate in the standards process from asserting their IPR against  
the standard

    - This is acceptable to large companies, as they do NOT hand over  
their entire portfolio just because they participated in a small CODEC  
work group

If you want to go further, you can do the industry as a whole a favor  
and extend the IPR regime to protect third-parties:

o License revoked if you assert IPR against ANYONE because of THEIR  
implementation of the published standard

    - This gives people a reason to prosecute IPR in something they  
hope to be royalty free.

    - It provides a layer of protection to the industry by dissuading  
non-participants from asserting their (unknown to the work group) IPR  
against the ultimate standard.

For an example of such a declaration, see:
https://datatracker.ietf.org/ipr/580/

On Nov 12, 2009, at 3:38 AM, <[email-masked]> <[email-masked] 
 > wrote:

> Hi,
> The Polycomm license agreement states that "In the event that  
> Licensee makes a Qualifying Patent Assertion against Polycom or any  
> of its subsidiaries, Polycom may immediately terminate all patent  
> rights conveyed herein."  I'm not a lawer, but I interprete this  
> such that the Licensee also gives his whole patent portfolio royalty- 
> free to Polycomm if he wants to get the Polycomm codec royalty-free.  
> Am I right?
>
> Best regards,
> Jari Hagqvist
>
> On Wed, Nov 11, 2009 at 11:30 AM, Benjamin M. Schwartz <[email-masked] 
> > wrote:
> Anisse Taleb wrote:

---

From: Stephan Wenger <[email-masked]>
Date: Thu, 12 Nov 2009 07:58:52 +0900

Hi Eric,

I wholeheartedly agree with your email below, but also note that very few
rightholder companies in the IETF follow your approach.  Overly broad
reciprocity conditions are the norm for declarations offering no royalties,
and not an exception.  Just look at (most of) the recent Cisco-style
disclosures.

There are established areas of technologies in the IETF where an unspoken
consensus seems to prevail to keep the environment free of the licensing
game.  For those areas, the Cisco-style reciprocity conditions are IMHO just
fine. 

Stephan

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Thu, 12 Nov 2009 02:26:13 +0100

Hi
 
And thanks for the response and the offer.
I am still of the very strong opinion that codec work should be done in another venue (ITU-T, 3GPP, ...), this is mainly for practical reasons. There are also legal matters around which makes other venues more suitable but I don't believe that I am skilled enough to discuss the latter.
 
Regards
Ingemar

	From: Jean-Marc Valin [mailto:[email-masked]] 
	Sent: den 12 november 2009 00:53
	To: Ingemar Johansson S; [email-masked]
	Subject: RE: [codec] G.719 royalty-free license

	Hi,

	Cheers,
	
	        Jean-Marc

	-----Original Message-----
	From: [email-masked] on behalf of Ingemar Johansson S
	Sent: Wed 11/11/2009 10:26 AM
	To: [email-masked]
	Subject: [codec] G.719 royalty-free license
	
	Hi

	Regards
	Ingemar
	
	Ericsson AB
	Multimedia Technologies
	Labratoriegränd 11
	971 28, Luleå, Sweden
	Phone +46-1071 43042
	SMS/MMS +46-73 078 3289

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 12 Nov 2009 10:34:23 +0900

On 11/12/09 10:26 AM, Ingemar Johansson S wrote:

> I am still of the very strong opinion that codec work should be done in
> another venue (ITU-T, 3GPP, ...), this is mainly for practical
> reasons.

Would it be possible for you to describe some of those practical
reasons? I think that would be very helpful for our discussions at the
BoF today. The more practical and factual we can be, the better.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Roni Even" <[email-masked]>
Date: Thu, 12 Nov 2009 10:41:42 +0900

Hi,

I think that this should be part of survey of existing solutions. Based on
the current requirements this codec qualifies since it is royalty free and
there is no need to bring it as a proposal since it is already been approved
by a standard body.

The rest of the requirements are a set that allows any high quality codec to
qualify since there is no selection based on requirements and the proposal
is to allow the proposed group to select multiple codec.

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jean-Marc Valin
Sent: Thursday, November 12, 2009 12:53 AM
To: Ingemar Johansson S; [email-masked]
Subject: Re: [codec] G.719 royalty-free license

Hi,

I think this is great news! I guess this shows that collaboration would be
possible. I would personally like to invite Ericsson to contribute the G.719
technology as input to the proposed working group. This could certainly help
towards meeting some of the requirements we currently have and create an
overall better codec.

Cheers,

        Jean-Marc

-----Original Message-----
From: [email-masked] on behalf of Ingemar Johansson S
Sent: Wed 11/11/2009 10:26 AM
To: [email-masked]
Subject: [codec] G.719 royalty-free license

Hi

Ericsson offers a royalty-free license under Ericsson's G.719 standard
essential patents for end user products.
The license agreement can be obtained by contacting
[email-masked]

Regards
Ingemar

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Thu, 12 Nov 2009 02:56:21 +0100

OK

The main practical reason from my perspactive (my humble and personal
opinion) is that we have at our company a limited number of people who
do codec research. It is not a secret that all major companies today
need to prioritize the work and participating in the (codec)work in one
particular venue is not automatically guaranteed just because this work
exists. The amount of work must in some sense give a reasonable benefit.

I don't today see that codec work in IETF would provide with a benefit
over the activities already conducted in other standards venues, to put
it short I don't see the added value to justify the participation in a
possible codec WG.   
    
Regards
Ingemar

> From: Peter Saint-Andre [mailto:[email-masked]] 
> Sent: den 12 november 2009 10:34
> To: Ingemar Johansson S
> Cc: Jean-Marc Valin; [email-masked]
> > I am still of the very strong opinion that codec work 
> should be done 
> > in another venue (ITU-T, 3GPP, ...), this is mainly for practical 
> > reasons.
> 
> Would it be possible for you to describe some of those 
> practical reasons? I think that would be very helpful for our 
> discussions at the BoF today. The more practical and factual 
> we can be, the better.
> 
> Peter
> 
> --
> Peter Saint-Andre
> https://stpeter.im/
> 
> 
>

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Thu, 12 Nov 2009 03:08:26 +0100

Hi

This will give the rights to use G.719 RF under the terms listed in the license agreement.

Regards
Ingemar 

> From: Anisse Taleb [mailto:[email-masked]] 
> Sent: den 12 november 2009 00:38
> This is indeed quite interesting news given that this is a 
> brand new codec and the first ITU-T fullband conversational codec.
> 
> I assume this means that the codec is entirely royalty free 
> since Polycom offers also a royalty free license? Any 
> comments on this?
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Ingemar Johansson S