Subject: [codec] Summary of all...

From: "Christian Hoene" <[email-masked]>
Date: Wed, 15 Jul 2009 21:55:39 +0200

Hello,

I just compiled a short summary of all the emails on this mailing list.
Actually, it is a cut and paste collage. I tried to remain neutral. If not,
please feel free to correct and extend the Wiki articles.

https groupware1.cs.uni-tuebingen.de wiki/codec_bof
The SPAM filter might filter out this email because of the URL.

With best regards,
 Christian

--------------------------------------------------------
Dr.-Ing. Christian Hoene
Interactive Communication Systems (ICS), University of Tübingen
Sand 13, 72076 Tübingen, Germany, Phone +49 7071 2970532
http://www.net.uni-tuebingen.de/

---

From: Gregory Maxwell <[email-masked]>
Date: Wed, 15 Jul 2009 13:48:22 -0700

> please feel free to correct and extend the Wiki articles.

There appears to be a rather large amount of material on the wiki which as never been a topic of discussion here. This may be misleading to those who have not followed every message on this list since its inception.

As a matter of good house-keeping I believe if it were be preferable if those attempting scribe-like activity kept the editorializing to a minimum in those efforts.  But thanks for the collection of information, none the less.

Cheers.

(FWIW, I think your email is working fine— I got a half dozen copies of your message. Keep in mind that the archives are not instant)

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 15 Jul 2009 23:10:58 +0200

> -----Original Message-----
> From: Gregory Maxwell [mailto:[email-masked]]
> Sent: Wednesday, July 15, 2009 10:48 PM
> To: Christian Hoene; [email-masked]
> Subject: RE: [codec] Summary of all...
> 
> There appears to be a rather large amount of material on the wiki which as
> never been a topic of discussion here. This may be misleading to those who
> have not followed every message on this list since its inception.

Beside a few headline and some fill words, every word has been said on this
mailing list.

Christian

---

From: Gregory Maxwell <[email-masked]>
Date: Wed, 15 Jul 2009 14:14:29 -0700

> Beside a few headline and some fill words, every word has been said on this

Can you please point me to the message where AMR-WB+, HE-AACv2, etc were discussed?  I'd  like to point out their inapplicability to the work discussed here if someone hasn't done so already.

Thanks!

---

From: "Christian Hoene" <[email-masked]>
Date: Wed, 15 Jul 2009 23:27:05 +0200

Changed...

> From: Marc Petit-Huguenin [mailto:[email-masked]]
> Sent: Wednesday, July 15, 2009 11:20 PM
> To: Christian Hoene
> Cc: 'Gregory Maxwell'; [email-masked]
> Subject: Re: [codec] Summary of all...
> 
> Christian Hoene wrote:
> Hmm.
> "It need not to support for layered coding in the codec (which is
> need for multicast)."
> 
> One of the requirements I proposed was support for layered coding,
> and nobody objected.
> 
> --
> Marc Petit-Huguenin
> Home: [email-masked]
> Work: [email-masked]

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 15 Jul 2009 14:20:04 -0700

Hmm.

---

From: Koen Vos <[email-masked]>
Date: Wed, 15 Jul 2009 22:52:43 -0700

> One of the requirements I proposed was support for layered coding,

Layered coding can be seen as a method for computationally efficient
transcoding. So I would propose to rephrase the requirement as: support
for efficient transcoding to a lower bitrate and/or sample rate.

Also note the earlier discussion on this topic:
http://www.ietf.org/mail-archive/web/codec/current/msg00066.html
http://www.ietf.org/mail-archive/web/codec/current/msg00063.html

koen.

---

From: "Christian Hoene" <[email-masked]>
Date: Thu, 16 Jul 2009 09:36:15 +0200

Good morning,

I change it to

*	Support for efficient transcoding to a lower bitrate and/or sample
rate. 

*	For example, as Marc Petit-Huguenin proposed, by supporting layered
coding like in G.729.1 and G.718 
*	Layered coding can be seen as a method for computationally efficient
transcoding. 
*	Layered coding make sense in the conferencing environment as such
stripping should be done at the sender after encoding. Then, for all
receivers the encoding has to be done only once. 
*	However, for bidirectional transmissions, you do not need layered
encoding as most codecs now are VBR, its enough already to adapt codec (at
the source) to the bandwidth. 

As far as I remember layered coding comes at some (neglectable?) costs. I do
not know how large the lost in term of bandwidth is going to be, if multiple
layers are supported as compared to a single layer. (I did not found the
proper publication addressing this issue)

Are you planning to add a bandwidth extension layer to the SILK draft soon?
It might be quite useful to fill the quality gap between SILK and CELT –
especially for low delay audio coding

With best regards,

 Christian

Dr.-Ing. Christian Hoene

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Koen

> Vos

> Sent: Thursday, July 16, 2009 7:53 AM

> To: [email-masked]

> _______________________________________________

> codec mailing list

> [email-masked]

> https://www.ietf.org/mailman/listinfo/codec

---

From: "Roni Even" <[email-masked]>
Date: Thu, 16 Jul 2009 11:28:46 +0300

Christian,

I am not sure what you are discussing since I did not see any of it on this
mailing list. If you want to have a discussion or suggest something it
should be on this mailing list.

BTW: I cannot access your link due to security reasons.

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Christian Hoene
Sent: Thursday, July 16, 2009 10:36 AM
To: 'Koen Vos'; [email-masked]
Subject: Re: [codec] Summary of all...

Good morning,

I change it to

With best regards,

 Christian

Dr.-Ing. Christian Hoene

Koen

---

From: Christian Hoene <[email-masked]>
Date: Thu, 16 Jul 2009 10:33:50 +0200

Hello Roni,

> Christian,
> 
> I am not sure what you are discussing since I did not see any of it on
> this mailing list. If you want to have a discussion or suggest
> something it should be on this mailing list.

In the last weeks, some hundred mails have been send on the list. It is
quite hard to keep track on the issues that have been discussed.
My intention is not to discuss something outside the mailing list, but
to keep track of the arguments. Therefore, I read all the mail again and
did some cut-and-paste to write the Wiki articles. 
I tried to avoid adding arguments that have not been raised on this
mailing but structured the arguments and made some minor editorial
changes.

> BTW: I cannot access your link due to security reasons.

I have asked our web administrator to find a way to access the Wiki
without security problems. As usual, it will take some hours until it is
fixed...

Sorry,

 Christian

> 
> Roni
> 
>  
> 
> From:[email-masked] [mailto:[email-masked]] On Behalf
> Of Christian Hoene
>       * Support for efficient transcoding to a lower bitrate and/or
>         sample rate. 
>               * For example, as Marc Petit-Huguenin proposed, by
>                 supporting layered coding like in G.729.1 and G.718 
>               * Layered coding can be seen as a method for
>                 computationally efficient transcoding. 
>               * Layered coding make sense in the conferencing
>                 environment as such stripping should be done at the
>                 sender after encoding. Then, for all receivers the
>                 encoding has to be done only once. 
>               * However, for bidirectional transmissions, you do not
>                 need layered encoding as most codecs now are VBR, its
>                 enough already to adapt codec (at the source) to the
>                 bandwidth. 
> 
> As far as I remember layered coding comes at some (neglectable?)
> costs. I do not know how large the lost in term of bandwidth is going
> to be, if multiple layers are supported as compared to a single layer.
> (I did not found the proper publication addressing this issue)
> 
>  
> 
> Are you planning to add a bandwidth extension layer to the SILK draft
> soon? It might be quite useful to fill the quality gap between SILK
> and CELT – especially for low delay audio coding
> 
>  
> 
> With best regards,
> 
>  Christian
> 
>  
> 
> > From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Koen
> 
> > Vos
>

---

From: Koen Vos <[email-masked]>
Date: Thu, 16 Jul 2009 02:38:47 -0700

> Are you planning to add a bandwidth extension layer to the SILK draft soon?

There is no plan for that right now.

> It might be quite useful to fill the quality gap between SILK and  
> CELT especially for low delay audio coding

The gap is small: SILK goes up to 24 kHz sampling rate; CELT starts at 32 kHz.

koen.

---

From: stephen botzko <[email-masked]>
Date: Thu, 16 Jul 2009 07:05:39 -0400

Hi all

Though I think Christian's attempt to summarize is noble, I am somewhat
concerned about it.

He is clearly working to be fair, and the bulk of the wiki is snippets of
actual postings.  However, by its very nature it is a summary, and will not
include everything.  The classification/organization/selection of postings
into categories also represents Christian's view of what categories matter.

It is not clear to me how (or even if) this will be used by the IETF
leadership, so I am not sure how much time/effort I need to spend
cross-checking the hundreds of emails against the wiki.

Perhaps a clarification from IETF leadership as to whether this activity
matters would be helpful?

Regards,
Stephen Botzko
Polycom

2009/7/16 Christian Hoene <[email-masked]>

> > From:[email-masked] <[email-masked]> [mailto:
> [email-masked]] On Behalf
> > Of Christian Hoene

---

From: Jean-Marc Valin <[email-masked]>
Date: Thu, 16 Jul 2009 09:08:02 -0400

Hi,

I share Stephen's concerns about the summary and I see that these concerns 
are actually expressed on both sides. Again, I don't think there was any 
bad-faith or bias involved, but simply that this sort of summary is bound 
to be subjective. There is also the issue that some people who expressed 
opinions may even have changed their mind now. So instead of arguing over 
the summary itself, which is counter-productive, I suggest we just continue 
discussing on the list. Considering how often the arguments get repeated, 
it's not necessary for anyone to read the whole archive or a summary to get 
an idea of the arguments.

	Jean-Marc

stephen botzko wrote:
> He is clearly working to be fair, and the bulk of the wiki is snippets 
> of actual postings.  However, by its very nature it is a summary, and 
> will not include everything.  The classification/organization/selection 
> of postings into categories also represents Christian's view of what 
> categories matter.
> 
> 2009/7/16 Christian Hoene <[email-masked] 
> <mailto:[email-masked]>>
> 
>     Hello Roni,
> 
>      > Christian,
>      >
>      > From:[email-masked]
>     <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] On
>     Behalf
>      > Of Christian Hoene
>      > To: 'Koen Vos'; [email-masked] <mailto:[email-masked]>
>      > > From: [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] On
>      > Behalf Of Koen
>      >
>      > > Vos
>      >
>      > > To: [email-masked] <mailto:[email-masked]>
>      >
>      > > [email-masked] <mailto:[email-masked]>
>      >
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>