Subject: [codec] Updated Charter Proposal Take 3

From: Jason Fischl <[email-masked]>
Date: Wed, 29 Jul 2009 11:13:32 +0200

Jean-Marc and I have updated the charter based on the comments from Roni and
a few private replies.

--------------
DRAFT CHARTER:

Motivation:

There is interest and value in having widely, easily distributable and
accessible codec technology from the Internet community. Codec experts from
both within and outside the IETF community have expressed an interest in
contributing effort in this area. The IETF standards process provides a
model for producing standards that encourages transparent design and open
collaboration early on in the process. Any IETF codec designs that may
emerge will also benefit from input and review from other RAI working groups
and other areas of the IETF.

Goals:
 
The goal of this working group is to standardize audio codecs that can be
implemented, distributed, and used broadly, and be interoperable between a
wide set of interested parties. The group is chartered to work on audio
codecs for interactive communication over the Internet. Codecs optimized for
very low bit rates or for non-interactive audio are out of scope. The codecs
should address the following technical considerations:
 
 * suitability for most fixed-point Digital Signal Processors (DSP);
 * medium- to high-quality speech at moderate bit-rate;
 * high-quality music encoding at higher bit-rates;
 * sampling rate profiles from narrow-band to full audio bandwidth;
 * real-time adaptive bit rate;
 * source-controlled variable bit-rate (VBR);
 * low algorithmic delay;
 
Beyond technical considerations, IPR issues will be handled in accordance
with BCP 78 and BCP 79. Specifically, many existing codecs with the
technical attributes listed above are encumbered with licensing fees and
other IPR claims that make royalty-free and wide distribution and use across
the Internet community difficult. The working group will try to standardize
codecs that can be relatively freely and easily distributed, and employed as
much as possible. In doing so, it will adhere closely to these BCPs. More
specifically, "In general, IETF working groups prefer technologies with no
known IPR claims or, for technologies with claims against them, an offer of
royalty-free licensing." Note that in accordance with BCP 79, this working
group will not explicitly rule out the possibility of adopting technology
that does not meet these IPR requirements; the decision will be left to the
normal rough consensus of the working group. 
 
Deliverables:  
 
1) Codec Standardization Guidelines - that define a set of metrics which can
be used to evaluate a codec. These metrics would include complexity, quality
vs bitrate, algorithmic delay, packet loss performance and footprint. The
complete list will be specified in this document. An evaluation of these
metrics should be considered by the working group in trying to come to
consensus about proposed changes to one of the draft codecs. A set of
pass/fail requirements MAY be specified in the requirements document. It
will be up to the working group to evaluate whether or not the proposed
codec is better than the reference codec. Continuous testing will be done
throughout the process. After a codec is finalized, these guidelines will be
used to characterize the codec. This is an Informational track document.
 
2) Requirements Document - that defines the application requirements of the
resulting solution. The requirements will include the exact technical
considerations including the target values for metrics defined in the Codec
Standardization Guidelines, any pass/fail requirements, an optional
reference codec, the scenarios that are being addressed and the assumptions
about the Internet operating environment. This is an Informational track
document.

3) Algorithm description for one or more wideband Internet audio codecs.
There MUST be a text description of the algorithm as well as a reference
implementation. The reference implementation MUST include an encoder and a
decoder, and MUST be compliant with BCP 78 and BCP 79. The text description
MUST indicate those components of the encoder and decoder which are
mandatory, recommended and optional. For example, in some codec definitions
only the decoder is specified whereas others have bit-exact specifications.
Any characterization MUST be performed with the reference encoder. This is a
Proposed Standard document. 
 
It is not necessary to produce a single codec that solves the entire range
of scenarios. A codec may be approved by the working group without
addressing all of the scenarios.

Milestones:
 
Jan-2010: WGLC on Codec Standardization Guidelines 
Jan-2010: WGLC on Requirements 
Jul-2010: WGLC on codec algorithm description(s) to IESG
Mar-2010: Codec Standardization Guidelines to IESG (Informational)
 Mar-2010: Requirements to IESG (Infomational)
Jan-2011: Submit codec algorithm description(s) to IESG (Standards Track)

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 29 Jul 2009 04:59:23 -0700

This is a very useful approach in the IETF.

Unless the IETF steps up to a standard, nobody can stop the proliferation of free audio (and video) codecs and the ensuing interoperability problems.

Henry

On 7/29/09 11:13 AM, "Jason Fischl" <[email-masked]> wrote:

--------------
DRAFT CHARTER:

Motivation:

Goals:

Deliverables:

Milestones:

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: Anisse Taleb <[email-masked]>
Date: Wed, 29 Jul 2009 17:15:48 +0200

Hi Henry, all,

I fail to understand your argument. How is the IETF to stop (free) audio
codec proliferation and avoid interoperability problems by creating yet
another (free?) audio codec? 

This concerns me even more when I read the Charter. I have the feeling that
it does not have any limitation on how many codecs it intends to standardize
and, if more than one codec, how much application-overlap will they have
between them (inside "ietf") and with other (3gpp, itu, mpeg) existing
codecs. 

The charter somewhat hints, at several instances, to more than ONE wideband
Internet audio codec being adopted...
"Algorithm description for one or more wideband Internet audio codecs." 
"A codec may be approved by the working group without addressing all of the
scenarios."
[ Btw, still puzzled as to the meaning of the word internet? are other
codecs from other SDOs unusable as "internet" codecs? ]

As it stands, the current charter would, on the contrary, exacerbate codec
proliferation and add even more interoperability problems than stop or
prevent them... 

Kind regards,

/Anisse

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Henry Sinnreich
Sent: den 29 juli 2009 13:59
To: Jason Fischl; [email-masked]
Cc: Jean-Marc Valin
Subject: Re: [codec] Updated Charter Proposal Take 3

Unless the IETF steps up to a standard, nobody can stop the proliferation of
free audio (and video) codecs and the ensuing interoperability problems.

Henry

	Jean-Marc and I have updated the charter based on the comments from
Roni and
	a few private replies.
	
	--------------
	DRAFT CHARTER:
	
	Motivation:
	
	There is interest and value in having widely, easily distributable
and
	accessible codec technology from the Internet community. Codec
experts from
	both within and outside the IETF community have expressed an
interest in
	contributing effort in this area. The IETF standards process
provides a
	model for producing standards that encourages transparent design and
open
	collaboration early on in the process. Any IETF codec designs that
may
	emerge will also benefit from input and review from other RAI
working groups
	and other areas of the IETF.
	
	Goals:
	
	The goal of this working group is to standardize audio codecs that
can be
	implemented, distributed, and used broadly, and be interoperable
between a
	wide set of interested parties. The group is chartered to work on
audio
	codecs for interactive communication over the Internet. Codecs
optimized for
	very low bit rates or for non-interactive audio are out of scope.
The codecs
	should address the following technical considerations:

	Beyond technical considerations, IPR issues will be handled in
accordance
	with BCP 78 and BCP 79. Specifically, many existing codecs with the
	technical attributes listed above are encumbered with licensing fees
and
	other IPR claims that make royalty-free and wide distribution and
use across
	the Internet community difficult. The working group will try to
standardize
	codecs that can be relatively freely and easily distributed, and
employed as
	much as possible. In doing so, it will adhere closely to these BCPs.
More
	specifically, "In general, IETF working groups prefer technologies
with no
	known IPR claims or, for technologies with claims against them, an
offer of
	royalty-free licensing." Note that in accordance with BCP 79, this
working
	group will not explicitly rule out the possibility of adopting
technology
	that does not meet these IPR requirements; the decision will be left
to the
	normal rough consensus of the working group. 
	
	Deliverables: 
	
	1) Codec Standardization Guidelines - that define a set of metrics
which can
	be used to evaluate a codec. These metrics would include complexity,
quality
	vs bitrate, algorithmic delay, packet loss performance and
footprint. The
	complete list will be specified in this document. An evaluation of
these
	metrics should be considered by the working group in trying to come
to
	consensus about proposed changes to one of the draft codecs. A set
of
	pass/fail requirements MAY be specified in the requirements
document. It
	will be up to the working group to evaluate whether or not the
proposed
	codec is better than the reference codec. Continuous testing will be
done
	throughout the process. After a codec is finalized, these guidelines
will be
	used to characterize the codec. This is an Informational track
document.
	
	2) Requirements Document - that defines the application requirements
of the
	resulting solution. The requirements will include the exact
technical
	considerations including the target values for metrics defined in
the Codec
	Standardization Guidelines, any pass/fail requirements, an optional
	reference codec, the scenarios that are being addressed and the
assumptions
	about the Internet operating environment. This is an Informational
track
	document.
	
	3) Algorithm description for one or more wideband Internet audio
codecs.
	There MUST be a text description of the algorithm as well as a
reference
	implementation. The reference implementation MUST include an encoder
and a
	decoder, and MUST be compliant with BCP 78 and BCP 79. The text
description
	MUST indicate those components of the encoder and decoder which are
	mandatory, recommended and optional. For example, in some codec
definitions
	only the decoder is specified whereas others have bit-exact
specifications.
	Any characterization MUST be performed with the reference encoder.
This is a
	Proposed Standard document. 
	
	It is not necessary to produce a single codec that solves the entire
range
	of scenarios. A codec may be approved by the working group without
	addressing all of the scenarios.
	
	Milestones:
	
	Jan-2011: Submit codec algorithm description(s) to IESG (Standards
Track)

---

From: <[email-masked]>
Date: Wed, 29 Jul 2009 21:00:27 +0200

Hi all

In line with the comments below from Anisse Taleb.

Indeed, my understanding of what IETF would intent to do with such a Charter proposal is as follows : 

1) Set some requirements that are already met by many existing standardized or proprietary codecs : the first "technical considerations" listed in the proposed Charter text seem to be a good start for this !
2) Put a "IETF standardized" label on a collection of proprietary codecs : the ones that will be submitted to this WG : of course not interoperable between themselves nor with any other already standardized codecs and without taking into account works from other SDOs nor already existing standards
3) Run some tests to characterize those codecs and give some information about their performance once standardized.
4) Let the organizations interested in these codecs deploy them (hopefully, at least, the proponents chosing their favourite ones) with possibly several different codecs needed to cover all the application needs (and again not interoperable between themselves). 
5) Then cross your fingers and hope that some IPRs will not be declared and license fees requested by any other organizations than the proponent(s) of the codecs (possibly not even member of IETF...) which is more or less captured in the Charter text by the very weak statement about Royalty Free issue : The working group will TRY to standardize codecs that can be RELATIVELY FREELY and easily distributed. Indeed, RF cannot be ensured !

As a result, what is the value added by Standardization with respect to the previous situation with non standardized codecs ?
The situation in terms of interoperability is in fact even worse : you have just added new standardized codecs to the already too large existing portfolio (the opposite of the standardization goals)and the result would just be to weaken the whole voice and audio standardization area and confuse the market.

Stephane 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Anisse Taleb
Envoyé : mercredi 29 juillet 2009 17:16
À : 'Henry Sinnreich'; 'Jason Fischl'; [email-masked]
Cc : 'Jean-Marc Valin'
Objet : Re: [codec] Updated Charter Proposal Take 3

Hi Henry, all,

I fail to understand your argument. How is the IETF to stop (free) audio codec proliferation and avoid interoperability problems by creating yet another (free?) audio codec? 

This concerns me even more when I read the Charter. I have the feeling that it does not have any limitation on how many codecs it intends to standardize and, if more than one codec, how much application-overlap will they have between them (inside "ietf") and with other (3gpp, itu, mpeg) existing codecs. 

The charter somewhat hints, at several instances, to more than ONE wideband Internet audio codec being adopted...
"Algorithm description for one or more wideband Internet audio codecs." 
"A codec may be approved by the working group without addressing all of the scenarios."
[ Btw, still puzzled as to the meaning of the word internet? are other codecs from other SDOs unusable as "internet" codecs? ]

As it stands, the current charter would, on the contrary, exacerbate codec proliferation and add even more interoperability problems than stop or prevent them... 

Kind regards,

/Anisse

From: [email-masked] [mailto:[email-masked]] On Behalf Of Henry Sinnreich
Sent: den 29 juli 2009 13:59
To: Jason Fischl; [email-masked]
Cc: Jean-Marc Valin
Subject: Re: [codec] Updated Charter Proposal Take 3

Henry

	
	--------------
	DRAFT CHARTER:
	
	Motivation:

	Goals:

	
	
	Deliverables: 

	

	Milestones: