Subject: Re: [codec] Codec BOF approved, much work needed

From: "Slava Borilin" <[email-masked]>
Date: Wed, 8 Jul 2009 20:48:53 +0400

Dear Roni, Cullen,

Can you please advice on the procedure- there are some suggestions to
agenda made on this list- how this should translate into the final
agenda?

Slava Borilin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roni Even
Sent: Friday, June 26, 2009 11:40 AM
To: 'Cullen Jennings'
Cc: [email-masked]
Subject: Re: [codec] Codec BOF approved, much work needed

Cullen,
Thanks,
If I may, I would like to suggest based on my observations on the list
discussion that the agenda will also include the following topics.

1. Should the IETF work on codecs (speech/audio)
2. If yes, should the these codecs be standard track or informational. I
am
suggesting this item since as far as I understand after iLBC publication
the
conclusion was that the IETF cannot do expert review on codecs even for
Informational status.

3. If the IETF will do standard track, Is the prerequisite to qualify
for
approval is Royalty Free. The list discussion points that there is no
agreement that the IETF can provide with high probability a RF codec.

I think that only after these topics, which looks to me like ground
rules,
are addressed we can start discussing the content of the charter. 

Roni Even

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Friday, June 26, 2009 9:09 AM
> To: Ron Even
> Cc: [email-masked]
> Subject: Re: [codec] Codec BOF approved, much work needed
> 
> 
> Roni,
> 
> The primary goal of this BOF should be collecting the information that
> helps make an informed decision about if a WG should be formed or not.
> I certainly did not mean to imply by the agenda that there was any
> assumption that a WG would be formed.
> 
> I agree the charter below is far from ideal for collecting this
> information. I'm expecting the agenda to change, based on the list
> discussion, so we have time to talk about the key topics where
> community input is needed to drive the decisions about if a WG should
> be formed or not.
> 
> Cullen <RAI AD>
> 
> 
> On Jun 19, 2009, at 8:59 , Ron Even wrote:
> 
> > Cullen,
> > I looked at the agenda
> >
> > 1. Administrative (Chairs, 5 min)
> >   - Note takers, Jabber scribes
> >   - Agenda bashing
> >
> > 2. Introduction and Scoping of BOF (Chairs/ADs, 15 min)
> >
> > 3. Proposed CODECs (TBD, 25 min)
> >   - Expect to have two or more drafts here
> >
> > 4. Charter Discussion (All, 40 min)
> >
> > 5. Decisions and HUMs (All, 5 min)
> >
> > 6. Conclusions and Next Steps (Chairs/ADs, 5 min)
> >
> >
> > And it looks to me that it starts with assumption that we will have
> > a new working group.
> >
> > I am not sure that that this was agreed and yet I see no time
> > allocated to discuss the topic. I would expect that item 3 will be
> > rational for doing codec at the IETF considering that this work is
> > done also by other SDOs that the IETF is working with.
> >
> > Now even if there will be such a WG starting with proposed CODECS is
> > like having a solution before the requirements. In other standard
> > bodies requirements are not just names but they also have values. So
> > what is the purpose of proposing codecs, do we need to select at the
> > BOF which one will be standardize, to me it looks like this should
> > be done later.
> >
> > Roni Even
> >
> >
> >
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On
> > Behalf
> > > Of Cullen Jennings
> > > Sent: Friday, June 12, 2009 8:32 PM
> > > To: [email-masked]
> > > Subject: [codec] Codec BOF approved, much work needed
> > >
> > >
> > > I have approved the CODEC BOF proposal. However, we need a bunch
of
> > > work to get ready.  Various people on IESG/IAB were not
comfortable
> > > with the current charter and agenda so we need to work on theses
> > > before the meeting.
> > >
> > > A draft agenda/charter Jason provided are at
> > >
> > > Agenda: http://svn.resiprocate.org/rep/ietf-drafts/codec-
> bof/agenda.txt
> > >
> > > Charter: http://svn.resiprocate.org/rep/ietf-drafts/codec-
> > > bof/charter.txt
> > >
> > > After discussion with the IESG/IAB:
> > >
> > > I'd like to remove the "as Proposed Standard" from the charter
text
> > > for both milestones and see how the discussion goes in the BOF
> > before
> > > deciding which way this should go.
> > >
> > > I'd like to see more consideration around the issues of designing
a
> > > codec that did a good job of mapping a real time stream onto IP
> > > packets. The way IP deals with packet loss and congestion has
> > > implications for designing a codec that works well over IP. I know
> > > some of the discussion I have had off list people talked about how
> > we
> > > wanted a codec that supported adaptive bit rates that could change
> > on
> > > the fly to be able to work well on an IP network.
> > >
> > > I will be working the folks to make sure the agenda has time to
> > > directly address the key topics which include (more may be
coming):
> > >
> > > Will we be able to get qualified people to do and review the work?
> > >
> > > Key design goals of a new codec?
> > >
> > > Do we need a new codec or are there already ones defined that meet
> > the
> > > needs?
> > >
> > > I have asked Jason Fischl  and Jean-Marc Valin to co-chair this
> BOF.
> > >
> > > Thanks,
> > >
> > > Cullen <RAI AD>
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > codec mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/codec
> > _______________________________________________
> > codec mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/codec

_______________________________________________
codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/codec

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 8 Jul 2009 10:31:49 -0700

I'm expecting some folks send a new version of the agenda out some  
time in the next few days or so that hopefully take into account the  
current comments.  After that, more comments on the agenda can be  
collected and integrated into the agenda.

Cullen

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 8 Jul 2009 11:41:51 -0700

Roni,

It is now really hard to count how many times you have repeated these arguments.

Henry

-----Original Message-----

Cullen,
Thanks,

Roni Even

of
comfortable
text
a

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 08 Jul 2009 11:56:25 -0700

Hi Henry,
I agree with Roni¹s suggestions and arguments.  We can cease repeating them
if the BOF agenda adequately addresses them.  As of this minute, it doesn¹t.
Regards,
Stephan

---

From: Jean-Marc Valin <[email-masked]>
Date: Wed, 08 Jul 2009 15:01:40 -0400

Stephan Wenger wrote:
> Hi Henry,
> I agree with Roni’s suggestions and arguments.  We can cease repeating 
> them if the BOF agenda adequately addresses them.  As of this minute, it 
> doesn’t.

The agenda that's available is pretty old. There should be an updated one 
soon that should (hopefully!) address everyone's concerns.

	Jean-Marc

>     ------------------------------------------------------------------------
> ------------------------------------------------------------------------
>

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 08 Jul 2009 12:08:52 -0700

Who is handling this?  Do we have BOF chairs by now?
Stephan

On 7/8/09 12:01 PM, "Jean-Marc Valin" <[email-masked]> wrote:

> Stephan Wenger wrote:
>> Hi Henry,
>> I agree with Roni¹s suggestions and arguments.  We can cease repeating
>> doesn¹t.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 8 Jul 2009 12:46:26 -0700

> Who is handling this?  Do we have BOF chairs by now?

Yes, Jason Fischl  and Jean-Marc Valin. That should be in the email  
that started this thread - hope it made it to the list.