Subject: [codec] НА: RE: Updated Agenda for Codec BOF

From: "Slava Borilin" <[email-masked]>
Date: Fri, 10 Jul 2009 21:10:01 +0400

Free tutorial on codecs during the IETF but outside BoF sounds to be good workaround. Is there a place for it on Wed or Thu? (it better be before BoF imho)

Slava Borilin

----- Исходное сообщение -----
От: Roni Even <[email-masked]>
Отправлено: 10 июля 2009 г. 20:44
Кому: 'Peter Saint-Andre' <[email-masked]>; 'stephen botzko' <[email-masked]>
Копия: 'Ingemar Johansson S' <[email-masked]>; 'Slava Borilin' <[email-masked]>; [email-masked] <[email-masked]>
Тема: RE: [codec] Updated Agenda for Codec BOF

Hi,
I still fail to see what is the value in presenting one, two or three
codecs. I saw that there was a request to present a third one. 
I can agree that there are people who can present codecs as a suggested
solution including existing ones. Since there is no charter yet under which
the codecs are to be specified it may serve as a tutorial on codecs. So if
we open to codec presentation in the BOF let allow everyone to present their
codecs including ITU and MPEG ones and spend the whole BOF of the different
codecs technologies. 
If the idea behind this presentation is to show specific functionality than
instead it will be more fruitful to present requirements, since I could see
from the list discussion that there is no consensus even between the current
proponents what the requirements are.

Roni Even 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Peter Saint-Andre
> Sent: Friday, July 10, 2009 5:46 PM
> To: stephen botzko
> Cc: Ingemar Johansson S; Slava Borilin; [email-masked]
> Subject: Re: [codec] Updated Agenda for Codec BOF
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On 7/10/09 5:26 AM, stephen botzko wrote:
> > Sorry to disagree on this.
> >
> > - A 25 minute presentation is not "short" in a 2 hour meeting.  5
> > minutes would be short.
> > - SILK and CELT are well known, and can be studied/reviewed by anyone
> > interested off-line.
> >
> > The net effect of a 25 minute codec presentation by WG proponents is
> to
> > remove 25 minutes of discussoin time.  A second effect is that it
> biases
> > the time allotment in favor of proponents, which acts to skew the
> input
> > to IESG in that direction. Arguments against are just as important as
> > arguments for at this point in the process.
> >
> > Perhaps a compromise is possible?  Move item 4 to the _end_ of the
> > agenda, and make it the "time permits" activity?
> 
> How about 5 minutes to discuss each of the codec I-Ds at a high level?
> Allotting 10 minutes out of 2 hours to existence proofs and what they
> imply for the work of the Codec WG (if approved) seems helpful to me.
> Clearly anyone can read the I-Ds ahead of time, but IMHO the BoF can
> productively talk about how these codecs could be used as input to a
> working group.
> 
> Peter
> 
> - --
> Peter Saint-Andre
> https://stpeter.im/
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iEYEARECAAYFAkpXVDAACgkQNL8k5A2w/vxzFACgxpRsJZyUEcGzhmcpx8MARPE2
> TEUAoMwK2EjNJvBpmRfi3xCZuN1x/WLV
> =bx98
> -----END PGP SIGNATURE-----
> 
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 10 Jul 2009 11:42:44 -0600

On 7/10/09 11:10 AM, Slava Borilin wrote:
> Free tutorial on codecs during the IETF but outside BoF sounds to be
> good workaround. 

I'm all in favor of a tutorial on codecs. But why make it free? I think
it would be better to charge for entry. ;-)

In all seriousness, I think that the brief presentations on SILK, CELT,
etc. would not provide a tutorial on codec design -- that topic is too
big to cover in 5 or 10 minutes. But I do think it would be helpful for
the designers of codecs like SILK and CELT to describe *briefly* how
they designed their codecs, the lessons they learned, whether they think
an even better codec could be designed within the IETF, etc. I would
assume that these people (and people like them) would be the ones doing
the work of a Codec WG (if approved), so I think it would be good for
them to describe their thought processes and experiences, the major
issues they see in performing such work within the IETF, etc.

OK, I'll be quiet now. :)

> Is there a place for it on Wed or Thu? (it better be
> before BoF imho)

Most definitely before.

Peter

- --
Peter Saint-Andre
https://stpeter.im/