Subject: Re: [codec] Miles for your thoughts

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 29 Jul 2009 08:17:02 -0400

This suggests that some folks understand this charter as being 
open-ended.  (I do wonder about the bounds on a charter to define an 
undefined number of codecs.)

It has normally been understood (I would calim it is a hard and fast 
rule, but it is widely understood and widely taken as important) that 
WGs should be defined in such a way that the WG has defined scope, and 
has a well-defined "completion" at which point it is done.

If we really want to define a new kind of beast, one with a perpetual 
charter, we should be very clear about that.

Yours,
Joel M. Halpern

United Offers and Announcements wrote:
> To ensure receipt of our emails, please add
> [email-masked] to your Address Book.
> 
> ============================================================
> United Mileage Plus(R) 
> ============================================================
> 
> ************************************************************
> 100,000 MILES FOR YOUR THOUGHTS
> ************************************************************
> 
> Dear Joel M Halpern,
> 
> You've just traveled with us, and we'd like to know how you
> enjoyed your trip.
> 
> Please tell us how we can make your travels even more
> comfortable and convenient by taking our five-minute survey,
> and you'll get a chance to win 100,000 Mileage Plus(R) bonus
> miles.
> 
> Just complete this five-minute survey within seven days of 
> the completion of your trip, and you'll be automatically
> entered in our exclusive sweepstakes giveaway. Your feedback
> will help ensure that we continue to provide everything you
> are looking for in a flight experience and more.
> 
> Thanks for sharing your thoughts, and thanks for flying
> United!
>                  ----------------------
>                   TAKE THE SURVEY NOW
>                  ----------------------                  
> http://mymileageplus.com/mmps/89998/242779/c4be1a19be19907d170c0b3402bf5381
> 
> ============================================================
> Terms and Conditions:
> 
> No Purchase Necessary: This sweepstakes is open to persons
> 21 years of age or older, except the employees, and their
> families, of United and Pearson Assessments, and the 
> affiliates, subsidiaries, and advertising agencies of
> either company. This offer is void wherever prohibited and
> subject to all federal, state, and local laws. United
> reserves the right to terminate this sweepstakes
> without notice.
> 
> 1.  By filling out this questionnaire, you are automatically
> entered in the WIN MILES SWEEPSTAKES. If you do not wish to
> fill out this questionnaire but would like to enter the
> sweepstakes, print your name, address, zip code, flight
> number, date of travel and the words "WIN MILES SWEEPSTAKES"
> on a plain 3" x 5" index card. Mail your entry to: Pearson
> Assessments, ATTN: United Survey Sweepstakes Winners, 1313
> Lone Oak Road, Eagan, MN 55121-1334.
> 
> 2.  Winner must be a Mileage Plus(R) member in order to
> receive the Prize. A Winner not currently a member will be
> invited to become a member in order to receive the Prize.
> Non flight bonus miles can only be credited to the winner's
> Mileage Plus(R) account. Non flight Mileage Plus(R) miles
> apply to base flight miles only and do not count toward
> elite status. Miles accrued, awards issued and bonus offers
> are subject to the rules of the United Mileage Plus(R)
> program. The Mileage Plus(R) Program, including accruals,
> awards and bonus miles offers is subject to change without
> notice. Taxes and fees related to award travel are the
> responsibility of the passenger. United and Mileage Plus(R)
> are registered service marks. For complete details about the
> Mileage Plus(R) program, visit mileageplus.com.
> 
> 3.  Winners will be selected in random drawings conducted by
> Pearson Assessments, an independent organization whose
> decisions are final on all matters relating to the
> sweepstakes. All prizes are non-transferable and no
> substitutes or cash equivalents are allowed. Taxes, if any,
> are the responsibility of the individual winners. Winners
> will be asked to execute an affidavit of eligibility and
> release. Non-flight miles will be posted to the member's
> account within one month from the time when the affidavit is
> returned to United.
> 
> 4.  Drawings for prizes will be conducted on a quarterly
> basis, starting with October-December 2006; the end date of
> this sweepstakes has not been determined but can be chosen
> by United at any time. Entries submitted will be eligible
> for the drawing which takes place in the month immediately
> subsequent to the quarter in which travel occurred. Each
> drawing will have one prize, consisting of 100,000 Mileage
> Plus(R) miles to be awarded to the winner's Mileage Plus(R)
> account. See mileageplus.com to enroll online.
> 
> 5.  Retail value of the prize depends on the actual
> itinerary flown. Chance of winning depends on the number of
> eligible entrants. For a list of winners, send a stamped,
> self-addressed envelope within one year of the drawing to:
> WIN MILES SWEEPSTAKES WINNERS LIST, United Airlines, ATTN:
> WHQLA, P.O. Box 66100, Chicago, IL 60666.
> 
> ____________________________________________________________
> 
> My mileage summary
> http://www.mymileageplus.com
> 
> united.com
> http://www.united.com
> 
> Partner offers
> http://www.united.com/page/article/0,8566,1176,00.html
> 
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
> 
> Change your email address
> http://mymileageplus.com/mmps/99432/242779/c4be1a19be19907d170c0b3402bf5381
> 
> Update your email preferences
> http://mymileageplus.com/mmps/89999/242779/c4be1a19be19907d170c0b3402bf5381
> 
> Privacy policy
> http://www.united.com/privacy
> 
> 
> You are subscribed to receive information and updates from
> United at [email-masked].
> 
> Please do not reply to this email. We cannot accept
> electronic replies to this email address.
> 
> To contact the sender, write to:
> United Airlines Operations Center - WHQPW,
> 1200 E. Algonquin Rd.,
> Elk Grove Township,
> Illinois 60007 USA
> 
> Copyright 2009 United Air Lines, Inc. All rights reserved.
>

---

From: Simon Perreault <[email-masked]>
Date: Wed, 29 Jul 2009 14:28:48 +0200

> undefined number of codecs.)

No. This is not how I understood the charter.

The charter is more restrictive than I would like it to be.

One can always hope...

Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org

---

From: Simon Perreault <[email-masked]>
Date: Wed, 29 Jul 2009 14:44:34 +0200

Joel M. Halpern wrote:
> I presume you relize that perpetual working groupsa re normally against
> IETF policy?

Yes I know.

perpetual != large, long-lived, nor legendary.

I think the IETF should take on the immense task of creating patent-free
Internet codecs for all purposes.

And when the WG is done with that, dissolve.

(The current charter is not this broad. Examples:

"Codecs optimized for very low bit rates or for non-interactive audio
are out of scope."

"medium- to high-quality speech at moderate bit-rate"

"real-time adaptive bit rate"

etc.)

(Maybe it is better to take it in strides and recharter along the way. I
don't think the first step should make anyone queasy, and it can even
serve as a test.)

Simon

---

From: Herve Taddei <[email-masked]>
Date: Wed, 29 Jul 2009 15:54:32 +0200

Hi,

> I think the IETF should take on the immense task of creating 

> patent-free Internet codecs for all purposes.

Usually an SDO tries to focus a bit, especially to avoid overlapping with
other SDOs where there could be more expertise.

What are all purposes?

BTW, who will have the responsibility to ensure that the codec is really RF?
In case the codec gets deployed and that this codec is supposed to be RF but
it turns out after its deployment that it infringes an essential patent that
cannot be suppressed (for interoperability reason), who will pay the company
that claims license, the IETF or the codec proponent? 

I imagine that a company who implements the IETF RF codec must get an
insurance that the codec is really RF as they could base their decision to
use that codec on that RF reason. If we end up having codecs which were
supposed to be RF that would become RAND, the whole activity would not have
been useful.  It is certainly something to be discussed in the BOF also.

>From the charter I understood that RF is not even sure to be provided "this
working group will not explicitly rule out the possibility of adopting
technology that does not meet these IPR requirements". What is then the
difference with other SDOs?

With regard to the charter, both encoder and decoder reference
implementations must be provided (in readable C-code and not in libraries).
Is the reference implementation encoder/decoder as listed in the charter a
C-code implementation? 

The current charter is extremely broad.

Best regards

Herve