Subject: Re: [codec] RE : Codec BOF approved, much work needed

From: "Slava Borilin" <[email-masked]>
Date: Wed, 8 Jul 2009 20:43:55 +0400

Cullen,

Sorry for delayed answer.

For codecs - most of ITU codecs are (were) not for IP networks, so I believe they did not care at all and so there was no practice (only G.718 may be the exception).

However, it is always some simulation for every network type (very common is radio network with errors, for example, when it comes to codecs to be used in the 

TIA-921 is nowadays used by carriers when they do judge/accept the overall VoIP systems, so it sounds as good candidate for judging the codec as well.

Regards,
Slava Borilin

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: Friday, June 26, 2009 7:50 AM
To: Slava Borilin
Cc: [email-masked]
Subject: Re: [codec] RE : Codec BOF approved, much work needed

On Jun 18, 2009, at 6:56 , Slava Borilin wrote:

> For congested networks - I assume that the way to judge the codec is  
> to judge the MOS over TIA-921 network profiles (that's what we use)  
> which covers realistic packet loss and congestion scenarios, and not  
> just "average normally distributed XX% packet loss".

Roni brought up and interesting point about looking at how other  
groups doing codec design did the design and evaluation. Just out of  
curiosity, are the TIA-921 profiles what folks doing codec design at  
the ITU use as the basis of design for codecs to run over IP networks?

---

From: "Roni Even" <[email-masked]>
Date: Wed, 8 Jul 2009 20:44:16 +0300

Slava,
As far as I understand TIA-921 is not addressing codec quality. It addresses
the transport and can give a model for packet loss. 
The ITU cares for packet networks and design tests for testing the codec
quality when packet loss occue=rs.
Roni Even

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Slava Borilin
> Sent: Wednesday, July 08, 2009 7:44 PM
> To: Cullen Jennings
> Cc: [email-masked]
> For codecs - most of ITU codecs are (were) not for IP networks, so I
> believe they did not care at all and so there was no practice (only
> G.718 may be the exception).
> 
> However, it is always some simulation for every network type (very
> common is radio network with errors, for example, when it comes to
> codecs to be used in the
> 
> TIA-921 is nowadays used by carriers when they do judge/accept the
> overall VoIP systems, so it sounds as good candidate for judging the
> codec as well.
> 
> Regards,
> Slava Borilin
> 
> 
> 
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: "Slava Borilin" <[email-masked]>
Date: Wed, 8 Jul 2009 21:49:47 +0400

Roni,

Sorry for possible confusion, and you are correct on TIA to be used as model for packet loss.

We have MOS, PESQMOS metrics for measuring the quality of the codec.
My point however, was that such measurements should be done NOT on the "pure" codec in the pure network, and, also, NOT in the fixed set of "average distributed errors and losses", but the set of test cases should be taken from TIA 921 model.

We have seen a lot of codec comparison diagrams in the past which either compared MOS at fixed and average distributed packet loss scenarios, which I believe do not clearly reflect реу internet nature.
So we need to create curves on how codec MOS are presented in all TIA-921 network profiles.

Slava

-----Original Message-----
From: Roni Even [mailto:[email-masked]] 
Sent: Wednesday, July 08, 2009 9:44 PM
To: Slava Borilin; 'Cullen Jennings'
Cc: [email-masked]
Subject: RE: [codec] RE : Codec BOF approved, much work needed

Slava,