Subject: [codec] FW: [AVT] RFC 5574 on RTP Payload Format for the Speex Codec

From: Henry Sinnreich <[email-masked]>
Date: Mon, 22 Jun 2009 19:01:52 -0700

------ Forwarded Message
From: <[email-masked]>
Date: Mon, 22 Jun 2009 17:09:20 -0700
To: <[email-masked]>, <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Subject: [AVT] RFC 5574 on RTP Payload Format for the Speex Codec

A new Request for Comments is now available in online RFC libraries.

        RFC 5574

        Title:      RTP Payload Format for the
                    Speex Codec
        Author:     G. Herlein, J. Valin,
                    A. Heggestad, A. Moizard
        Status:     Standards Track
        Date:       June 2009
        Mailbox:    [email-masked],
                    [email-masked],
                    [email-masked], [email-masked]
        Pages:      14
        Characters: 27995
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-avt-rtp-speex-07.txt

        URL:        http://www.rfc-editor.org/rfc/rfc5574.txt

Speex is an open-source voice codec suitable for use in VoIP (Voice
over IP) type applications.  This document describes the payload
format for Speex-generated bit streams within an RTP packet.  Also
included here are the necessary details for the use of Speex with the
Session Description Protocol (SDP).  [STANDARDS TRACK]

This document is a product of the Audio/Video Transport Working Group of the IETF.

This is now a Proposed Standard Protocol.

STANDARDS TRACK: This document specifies an Internet standards track
protocol for the Internet community,and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Internet
Official Protocol Standards (STD 1) for the standardization state and
status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/rfcsearch.html.
For downloading RFCs, see http://www.rfc-editor.org/rfc.html.

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
USC/Information Sciences Institute

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

------ End of Forwarded Message

---

From: "Christer Holmberg" <[email-masked]>
Date: Sat, 27 Jun 2009 04:47:38 +0200

Henry,

If there already exists an open-source codec, suitable for VoIP, why do you need a new one?

Regards,

Christer

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Henry Sinnreich
Sent: Tuesday, June 23, 2009 5:02 AM
To: [email-masked]
Subject: [codec] FW: [AVT] RFC 5574 on RTP Payload Format for the Speex Codec

------ Forwarded Message

        RFC 5574

The RFC Editor Team

---

From: Christopher Montgomery <[email-masked]>
Date: Fri, 26 Jun 2009 22:49:38 -0400

> If there already exists an open-source codec, suitable for VoIP, why do you need a new one?

The terrifying possibility that one might want something good for more
than mid-latency VoIP.

Monty

---

From: "Roni Even" <[email-masked]>
Date: Sat, 27 Jun 2009 12:50:47 +0300

Christer,
The IETF work only covers the payload specification not the codec itself.
The BOF is to discuss publishing the codec itself as an RFC. I agree that if
it is open source and is already being used and wonder why do we need the
IETF RFC. I am not sure whether the objective there is to define a new one
or publish an existing one or one that being worked by another "open" group
as an IETF RFC, the one I see being pushed is the "CELT" done by XIPH.org.
You are right that it can be published the same as speex as an open source
and the IETF will publish the payload specification.

Roni 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Christer Holmberg
> Sent: Saturday, June 27, 2009 5:48 AM
> To: Henry Sinnreich; [email-masked]
> Subject: Re: [codec] FW: [AVT] RFC 5574 on RTP Payload Format for the
> Speex Codec
> 
> Henry,
> 
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec

---

From: Henry Sinnreich <[email-masked]>
Date: Sat, 27 Jun 2009 12:48:06 -0700

Christer,

There is more than VoIP audio on the Internet, for example:
 Telepresence (enterprise) and the Digital Living Room (consumer) are just emerging. Both require highest quality, stereo, wideband interactive A/V and the applications have some very different requirements, for example, instead of cancelling out surrounding noise, people may want to share a concert during a communication session as well.

Henry

On 6/26/09 9:47 PM, "Christer Holmberg" <[email-masked]> wrote:

Henry,

Regards,

Christer

------ Forwarded Message

        RFC 5574

The RFC Editor Team

---

From: "Christer Holmberg" <[email-masked]>
Date: Sun, 28 Jun 2009 00:25:27 +0200

Hi Roni, 

I know that the RFC only covers the payload spec.

But, the argument has been that there is no suitable open-source codec available (no matter who has defined it), and that IETF therefor needs to define one.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: Roni Even [mailto:[email-masked]]
Lähetetty: la 27.6.2009 11:50
Vastaanottaja: Christer Holmberg; 'Henry Sinnreich'; [email-masked]
Aihe: RE: [codec] FW: [AVT] RFC 5574 on RTP Payload Format for the Speex	Codec
 
Christer,

Roni 

> Of Henry Sinnreich