Subject: Re: [appsdir] [mile] I-D Action: draft-ietf-mile-enum-reference-format-08.txt

From: S Moonesamy <[email-masked]>
Date: Thu, 11 Sep 2014 10:20:06 -0700

Hi Claudio,

[Cc to MILE WG Chairs]

Eric Burger expressed some strong views [1] about 
draft-ietf-mile-enum-reference-format-08 [2] and suggested an AppsDir 
review (XML expertise).

I suggest following up with the Apps ADs.

Best regards,
-sm

1. I suggest not asking Eric to volunteer for the review. :-)
2. http://tools.ietf.org/html/draft-ietf-mile-enum-reference-format-08

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 12 Sep 2014 08:18:27 +0100

On Thursday, 11 September 2014, S Moonesamy <[email-masked]> wrote:

> Hi Claudio,
>
> [Cc to MILE WG Chairs]
>
> Eric Burger expressed some strong views [1] about draft-ietf-mile-enum-reference-format-08
> [2] and suggested an AppsDir review (XML expertise).
>

FYI, the document already had an AppsDir review, including XML review. It
has been updated to reflect it.

---

From: [email-masked] (Henry S. Thompson)
Date: Fri, 12 Sep 2014 11:11:35 +0100

> I suggest following up with the Apps ADs.

I've had a quick look at this, and at IODEF (RFC 5070) itself.  I
don't immediately see any serious problems with the XML aspects as
such, with one moderately serious exception: unless I'm missing
something, the necessary edits to RFC5070 are not spelled out, in
terms of modifying the IODEF XML schema to incorporate the new
definition, in a new namespace, of the ReferenceName element.  How
this is done in turn has implications for backward compatibility,
i.e. a straight substitution is _not_ what is called for.

Until this is done, the example XML instance will not validate.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

---

From: Claudio Allocchio <[email-masked]>
Date: Fri, 12 Sep 2014 12:27:43 +0200 (CEST)

> Until this is done, the example XML instance will not validate.

I guess we can do also a formal review quickly... Henry would you be 
available for a slighly longer look ?

> ht

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

            PGP Key: http://www.cert.garr.it/PGP/keys.php3#ca

---

From: [email-masked] (Henry S. Thompson)
Date: Fri, 12 Sep 2014 12:04:11 +0100

Claudio Allocchio writes:

>> ...
>> I've had a quick look at this,...

> available for a slighly longer look ?

Sure, although I know very little about IODEF itself.  I presume I
should keep Alexey and Takeshi on the cc list.

ht

---

From: Claudio Allocchio <[email-masked]>
Date: Fri, 12 Sep 2014 13:53:16 +0200 (CEST)

> should keep Alexey and Takeshi on the cc list.

I was also involved in the very early IODEF specification, thus keep also 
me on :-) (although it changed quite alot since !)

---

From: Tim Bray <[email-masked]>
Date: Fri, 12 Sep 2014 07:17:50 -0700

I reviewed this and some changes resulted. Is there a link to Eric's
concerns?
On Sep 11, 2014 10:29 AM, "S Moonesamy" <[email-masked]> wrote:

> _______________________________________________
> appsdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/appsdir
>

---

From: S Moonesamy <[email-masked]>
Date: Fri, 12 Sep 2014 08:11:27 -0700

Hi Tim,
At 07:17 12-09-2014, Tim Bray wrote:
>I reviewed this and some changes resulted. Is there a link to Eric's concerns?

It was a private message.  I am copying this message to Eric so that 
he can provide a link to the concerns.

Best regards,
-sm

---

From: Tim Bray <[email-masked]>
Date: Fri, 12 Sep 2014 08:53:22 -0700

For the existing review, and the conversation that followed it, start here:
 http://www.ietf.org/mail-archive/web/mile/current/msg01458.html​

On Fri, Sep 12, 2014 at 8:11 AM, S Moonesamy <[email-masked]> wrote:

> It was a private message.  I am copying this message to Eric so that he
> can provide a link to the concerns.
>
> Best regards,
> -sm

-- 
- Tim Bray (If you’d like to send me a private message, see
https://keybase.io/timbray)

---

From: S Moonesamy <[email-masked]>
Date: Fri, 12 Sep 2014 12:45:55 -0700

Hi Tim,
At 08:53 12-09-2014, Tim Bray wrote:
>For the existing review, and the conversation that followed it, 
>start here:  http://www.ietf.org/mail-archive/web/mile/current/msg01458.html

Thanks for the link; I went to read the thread.  I'll say: nice work. :-)

Best regards,
-sm

---

From: Tim Bray <[email-masked]>
Date: Sat, 13 Sep 2014 15:30:17 -0700

Haha, except for I totally missed Henry’s point that the way they defined
it you can’t actually schema-validate.  (Not surprising; I’m well known to
have a strained relationship with all flavors of schemas for XML)

On Fri, Sep 12, 2014 at 12:45 PM, S Moonesamy <[email-masked]> wrote:

>> For the existing review, and the conversation that followed it, start
>> here:  http://www.ietf.org/mail-archive/web/mile/current/msg01458.html
>>
>