Subject: Re: [appsdir] APPSDIR review of draft-ietf-homenet-arch-10

From: S Moonesamy <[email-masked]>
Date: Thu, 19 Sep 2013 12:43:44 -0700

Hi Ted,

[Cc to appsdir@ which is publicly readable]

Please see the message at 
http://www.ietf.org/mail-archive/web/apps-discuss/current/msg10454.html 
for context.

I suggest talking to Barry and Pete as this is an unusual 
situation.  I don't know how the working group read the review from 
Dave Cridland and my review.  I prefer not to see a fight between 
Apps and another area as it does not help anyone.

Barry, Pete, can you provide some guidance?

Thanks,
-sm

---

From: Ted Lemon <[email-masked]>
Date: Thu, 19 Sep 2013 17:30:38 -0400

On Sep 19, 2013, at 3:43 PM, S Moonesamy <[email-masked]> wrote:
> I suggest talking to Barry and Pete as this is an unusual situation.  I don't know how the working group read the review from Dave Cridland and my review.  I prefer not to see a fight between Apps and another area as it does not help anyone.

There won't be a fight—I'm just trying to figure out what the right thing is to do.   The situation is complicated by the fact that as Brian said, the document really does focus on layer 3 and naming, and isn't intended to go any wider than that.   To us, that's what "IPv6" means, but I think we failed to account for the possibility that other readers might think it includes the application layer.

From my perspective, I think accounting for the application layer is a good idea—it's just not something that this document sets out to do, and indeed I don't think this document by itself can do that, so that needs to be excluded by what we mean by "IPv6 Home Network Architecture."   As Brian said, we really are talking about the bottom of the stack here.

I would actually encourage you to look at the MIF architecture document (not yet adopted, but should be soon), which is still an intarea document, but really addresses the apps layer problem more directly: https://datatracker.ietf.org/doc/draft-anipko-mif-mpvd-arch/

I say this not only because I think it's a good and interesting document, and not only because I would like your input, but also because I believe it relates pretty closely to what's going on with the homenet architecture document, and I'm realizing that by exposing you to partial snapshots of the larger picture, we are making your work harder.

---

From: SM <[email-masked]>
Date: Thu, 19 Sep 2013 16:58:48 -0700

Hi Ted,
At 14:30 19-09-2013, Ted Lemon wrote:
>There won't be a fight—I'm just trying to figure 
>out what the right thing is to do.   The 
>situation is complicated by the fact that as 
>Brian said, the document really does focus on 
>layer 3 and naming, and isn't intended to go any 
>wider than that.   To us, that's what "IPv6" 
>means, but I think we failed to account for the 
>possibility that other readers might think it includes the application layer.

The document discusses about addressability.  As 
Pete pointed out there's an application 
perspective to that.  There are two alternatives 
right now, i.e. what Dave Cridland suggested or 
looking into the organization of the 
document.  There may be more alternatives if there is input from other people.

> From my perspective, I think accounting for the 
> application layer is a good idea—it's just not 
> something that this document sets out to do, 
> and indeed I don't think this document by 
> itself can do that, so that needs to be 
> excluded by what we mean by "IPv6 Home Network 
> Architecture."   As Brian said, we really are 
> talking about the bottom of the stack here.

The bottom of the stack approach is not that 
practical when the parts have to be put 
together.  In my opinion it leads to complexity.

>I would actually encourage you to look at the 
>MIF architecture document (not yet adopted, but 
>should be soon), which is still an intarea 
>document, but really addresses the apps layer 
>problem more directly: 
>https://datatracker.ietf.org/doc/draft-anipko-mif-mpvd-arch/
>
>I say this not only because I think it's a good 
>and interesting document, and not only because I 
>would like your input, but also because I 
>believe it relates pretty closely to what's 
>going on with the homenet architecture document, 
>and I'm realizing that by exposing you to 
>partial snapshots of the larger picture, we are making your work harder.

I thought about MIF when I was reading the 
draft.  The home networking would likely be using 
split views for DNS.  I have to go through the 
DHCPv6 specifications and some of the MIF work 
before I can comment on the MIF architecture 
document.  The work is not that hard. I'll take 
the liberty not to explain why or else I will be 
volunteered for IETF work.  :-)

Best regards,
-sm

---

From: Ted Lemon <[email-masked]>
Date: Thu, 19 Sep 2013 21:01:24 -0400

On Sep 19, 2013, at 7:58 PM, SM <[email-masked]> wrote:
> The bottom of the stack approach is not that practical when the parts have to be put together.  In my opinion it leads to complexity.

Are you proposing that we just give up on multihoming and large prefixes, and settle for NPT66?

---

From: SM <[email-masked]>
Date: Thu, 19 Sep 2013 21:20:52 -0700

Hi Ted,
>prefixes, and settle for NPT66?

No, as that would create complexity and cause addressability issues 
(see http://www.ietf.org/mail-archive/web/behave/current/msg05046.html ).

Best regards,
-sm

---

From: Ted Lemon <[email-masked]>
Date: Fri, 20 Sep 2013 06:55:10 -0400

On Sep 20, 2013, at 12:20 AM, SM <[email-masked]> wrote:
> No, as that would create complexity and cause addressability issues (see http://www.ietf.org/mail-archive/web/behave/current/msg05046.html ).

I didn't think so, but talking about simplicity at the application layer tends to make my wind wander in that direction.   I think we blew up "simplicity" as soon as we decided to talk about multihoming.   But I'd be delighted to be proven wrong.