Subject: [appsdir] new drafts for review

From: Claudio Allocchio <[email-masked]>
Date: Sat, 27 Jul 2013 16:01:58 +0200 (CEST)

Here I am...

we need to review the following drafts which are in LC now:

draft-allen-dispatch-imei-urn-as-instanceid-10
due date: August 16th 2013
Assigned to Martin Duerst.

draft-montemurro-gsma-imei-urn-16
due date: August 16th 2013
Assigned to Julian Reschke.

draft-ietf-geopriv-relative-location-06
due date: August 15th 2013 (LC ends before, but this is to allow some more 
time)
Assigned to Martin Thomson.

draft-ietf-geopriv-res-gw-lis-discovery-05
due date: August 15th 2013 (LC ends before, but this is to allow some more 
time)
Assigned to Murray S. Kucherawy.

Please ACK if you can make the review !

see you all soon!

Best!

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

            PGP Key: http://www.cert.garr.it/PGP/keys.php3#ca

---

From: Julian Reschke <[email-masked]>
Date: Sat, 27 Jul 2013 18:40:47 +0200

On 2013-07-27 16:01, Claudio Allocchio wrote:
> ...
> ...

Sorry, can't make it.

Best regards, Julian

---

From: Tim Bray <[email-masked]>
Date: Sat, 27 Jul 2013 10:12:14 -0700

As some of you will have noticed, I had unkind things to say about the
imei-urn drafts on the ietf@ list, the  idea seems problematic to me.  So
I’ve actually read them already.  And would volunteer to re-do, focusing on
nits & consistency rather than the whole thing being a stupid idea. Only
that might be seen as unfair. Up to you, Claudio.  -T

On Sat, Jul 27, 2013 at 7:01 AM, Claudio Allocchio <
[email-masked]> wrote:

> draft-allen-dispatch-imei-urn-**as-instanceid-10
> draft-montemurro-gsma-imei-**urn-16
> draft-ietf-geopriv-relative-**location-06
> draft-ietf-geopriv-res-gw-lis-**discovery-05
> ------------------------------**------------------------------**
> ------------------
>            PGP Key: http://www.cert.garr.it/PGP/**keys.php3#ca<http://www.cert.garr.it/PGP/keys.php3#ca>
> ______________________________**_________________
> appsdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/appsdir<https://www.ietf.org/mailman/listinfo/appsdir>
>

---

From: SM <[email-masked]>
Date: Sat, 27 Jul 2013 10:42:51 -0700

Hi Tim,
At 10:12 27-07-2013, Tim Bray wrote:
>As some of you will have noticed, I had unkind things to say about 
>the imei-urn drafts on the ietf@ list, the idea seems problematic to 
>me.  So I've actually read them already.  And would volunteer to 
>re-do, focusing on nits & consistency rather than the whole thing 
>being a stupid idea. Only that might be seen as unfair. Up to you, Claudio.  -T

Your messages were fine.  I personally think that you would do a very 
good review.  I don't know how the author will read the review if you 
do it given that you have already stated a position.  I usually avoid 
it if there can be a perception that the review is unfair.

Claudio, Martin is one of the authors of 
draft-ietf-geopriv-relative-location-06. :-)

Best regards,
-sm

---

From: "Martin J. Dürst" <[email-masked]>
Date: Sun, 28 Jul 2013 17:06:34 +0900

I wouldn't mind if Tim could do it. My next week is already very packed, 
and then I'm on vacation for quite a bit of time, sorry.

Or Tim could send me his notes, and I'll forward them so it doesn't seem 
unfair :-).

Regards,    Martin.

On 2013/07/28 2:12, Tim Bray wrote:
> nits&  consistency rather than the whole thing being a stupid idea. Only
> On Sat, Jul 27, 2013 at 7:01 AM, Claudio Allocchio<

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 28 Jul 2013 01:16:04 -0700

> Please ACK if you can make the review !
ack.

-MSK

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Jul 2013 01:40:35 -0700

> Assigned to Martin Thomson.

Please don't assign me my own draft :)

---

From: Claudio Allocchio <[email-masked]>
Date: Sun, 28 Jul 2013 15:20:44 +0200 (CEST)

Hello Martin and Tim,

On Sun, 28 Jul 2013, "Martin J. Dürst" wrote:

> I wouldn't mind if Tim could do it. My next week is already very packed, and 
> then I'm on vacation for quite a bit of time, sorry.
>

I think Martin's suggestion is a good one, also following SM's:

>good review.  I don't know how the author will read the review if you do 
>it given that you have already stated a position.  I usually avoid it if 
>there can be a perception that the review is unfair.

Let's have Tim forwards his own full review notes to Martin, and Martin 
adds his owns, and "sign" the review, thus we avoid the problem of a 
biased reaction by the authors. Is this ok?

In then mean time we also need somebody for 
draft-montemurro-gsma-imei-urn-16 as Jullian cannot make it. Would it be a 
problem if Tim does this one "officially" ?

best!

---

From: Claudio Allocchio <[email-masked]>
Date: Sun, 28 Jul 2013 15:33:00 +0200 (CEST)

> Please don't assign me my own draft :)

yes... sorry! It was an authors' list misread!

Mark, could you please do this review ?

all the best !

---

From: SM <[email-masked]>
Date: Sun, 28 Jul 2013 07:55:49 -0700

Hi Claudio,
At 06:20 28-07-2013, Claudio Allocchio wrote:
>Let's have Tim forwards his own full review 
>notes to Martin, and Martin adds his owns, and 
>"sign" the review, thus we avoid the problem of 
>a biased reaction by the authors. Is this ok?

As Martin Dürst will be responsible for the review I don't see any problem.

>draft-montemurro-gsma-imei-urn-16 as Jullian 
>cannot make it. Would it be a problem if Tim does this one "officially" ?

There are two drafts:

   (i) draft-montemurro-gsma-imei-urn-16

   (ii) draft-allen-dispatch-imei-urn-as-instanceid-10

I'll suggest Martin for 
draft-montemurro-gsma-imei-urn-16 and Tim for 
draft-allen-dispatch-imei-urn-as-instanceid-10.

I'll suggest 
draft-petithuguenin-behave-turn-uris-05 for URI review.  It's a short draft.

Martin Thomson, would you like to review 
draft-ietf-websec-x-frame-options-05 if Claudio 
agrees?  If so, could you talk to Tobias and see 
when the draft will be ready for review?

Best regards,
-sm

---

From: Tim Bray <[email-masked]>
Date: Sun, 28 Jul 2013 08:16:51 -0700

I don't think it would be good for the integrity of the process if one
person did the review and another person's name was on it.  I'll take care
of urn-as-instanceid

On Sun, Jul 28, 2013 at 7:55 AM, SM <[email-masked]> wrote:

>> adds his owns, and "sign" the review, thus we avoid the problem of a biased
>> reaction by the authors. Is this ok?
>>
>
>  In then mean time we also need somebody for draft-montemurro-gsma-imei-**urn-16
>> as Jullian cannot make it. Would it be a problem if Tim does this one
>> "officially" ?
>>
>
> There are two drafts:
>
>   (i) draft-montemurro-gsma-imei-**urn-16
>
>   (ii) draft-allen-dispatch-imei-urn-**as-instanceid-10
>
> I'll suggest Martin for draft-montemurro-gsma-imei-**urn-16 and Tim for
> draft-allen-dispatch-imei-urn-**as-instanceid-10.
>
> I'll suggest draft-petithuguenin-behave-**turn-uris-05 for URI review.
>  It's a short draft.
>
> Martin Thomson, would you like to review draft-ietf-websec-x-frame-**options-05
> if Claudio agrees?  If so, could you talk to Tobias and see when the draft
> will be ready for review?
>
> Best regards,
> -sm

---

From: Claudio Allocchio <[email-masked]>
Date: Sun, 28 Jul 2013 17:20:04 +0200 (CEST)

> As Martin Dürst will be responsible for the review I don't see any problem.

esactly...

> I'll suggest Martin for draft-montemurro-gsma-imei-urn-16 and Tim for 

I just picked up the one in LC, but nothing wrong to review the second 
one, too. It depends on Martin's and Tim's available time.

> I'll suggest draft-petithuguenin-behave-turn-uris-05 for URI review.  It's a 
> short draft

Yes it's a short one. Could you do that one SM?

>
> Martin Thomson, would you like to review draft-ietf-websec-x-frame-options-05 

I've no objection to this.

---

From: SM <[email-masked]>
Date: Sun, 28 Jul 2013 08:25:41 -0700

Hi Tim,
At 08:16 28-07-2013, Tim Bray wrote:
>I don't think it would be good for the integrity of the process if 
>one person did the review and another person's name was on it.  I'll 
>take care of urn-as-instanceid

Agreed.

Best regards,
-sm

---

From: Tobias Gondrom <[email-masked]>
Date: Sun, 28 Jul 2013 17:28:04 +0200

On 28/07/13 17:20, Claudio Allocchio wrote:
>>> Let's have Tim forwards his own full review notes to Martin, and
>>> Martin adds his owns, and "sign" the review, thus we avoid the
>>> problem of a biased reaction by the authors. Is this ok?
>>
>>> draft-montemurro-gsma-imei-urn-16 as Jullian cannot make it. Would
>>> it be a problem if Tim does this one "officially" ?
>>
>> There are two drafts:
>>
>> I'll suggest draft-petithuguenin-behave-turn-uris-05 for URI review. 
>> It's a short draft
>
>> draft-ietf-websec-x-frame-options-05 if Claudio agrees?  If so, could
>> you talk to Tobias and see when the draft will be ready for review?
>

regarding draft-ietf-websec-x-frame-options-05: This was relatively
uncontroversial. Pre-IETF-LC, I received some feedback on the text from
the AD to correct some editorial bits and to improve readability. The
revised version is ready, just waiting for the submission window to open
again tonight at midnight local time in Berlin. Then the draft will
start into IETF LC and should be ready for review.

Best regards, Tobias

> _______________________________________________
> appsdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/appsdir

---

From: SM <[email-masked]>
Date: Sun, 28 Jul 2013 08:34:39 -0700

>>  (i) draft-montemurro-gsma-imei-urn-16

Let's fix this quickly.  Martin, could you take the assignment?  The 
Last Call ends on August 16.  I cannot perform the review as I have 
already commented during the Last Call.

>I just picked up the one in LC, but nothing wrong to review the 
>second one, too. It depends on Martin's and Tim's available time.

The two drafts are interlinked. :-)

>>I'll suggest draft-petithuguenin-behave-turn-uris-05 for URI 
>>review.  It's a short draft
>

I'll do it.

Best regards,
-sm

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Jul 2013 22:03:57 -0700

On 28 July 2013 08:20, Claudio Allocchio <[email-masked]> wrote:
>> draft-ietf-websec-x-frame-options-05 if Claudio agrees?  If so, could you
>> talk to Tobias and see when the draft will be ready for review?
>

I can do x-frame-options.  I'll see if I can find Tobias.

---

From: Tobias Gondrom <[email-masked]>
Date: Mon, 29 Jul 2013 08:06:08 +0200

Hi Martin,

ok. Just submitted the last revision (as the submission window just
reopened).
It basically contains the feedback/editorial fixes of the AD (Barry),
who is now putting it on IETF LC.
So please review this one:
http://www.ietf.org/internet-drafts/draft-ietf-websec-x-frame-options-06.txt
Best regards, Tobias

Ps.: @Martin: I will chair the websec session today at 15:10. drop me an
email if and when you like to meet for a chat.

---

From: Tobias Gondrom <[email-masked]>
Date: Mon, 29 Jul 2013 11:01:58 +0200

Hi Martin,
sorry, I missed another typo and a reference issue, so here is version
07 to fix it.
http://www.ietf.org/internet-drafts/draft-ietf-websec-x-frame-options-07.txt
(no big change, so in case you already started reading, no worries, the
diff is minimal.)
Best regards, Tobias

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Jul 2013 14:06:06 +0200

I don't really know much about the problem space here… HTTP-related stuff is usually what I do.

Happy to have a stab at it, but it might take a little while (I'm on the road) and the results may be underwhelming.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 29 Jul 2013 15:46:27 +0200 (CEST)

On Mon, 29 Jul 2013, Mark Nottingham wrote:

> Happy to have a stab at it, but it might take a little while (I'm on the 
> road) and the results may be underwhelming.

yes, I know... but "our" geolocation experts are all involved in the 
draft, thus we need an indipended look at it. I also read it, and it is 
not such a complex specification, thus if you do that (by Aug 15th) it 
will be ok.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Jul 2013 15:47:50 +0200

I'm on the road until the 10th, and then in jet lag hell. Can I have one more week?

Thanks,

On Jul 29, 2013, at 3:46 PM, Claudio Allocchio <[email-masked]> wrote:

> yes, I know... but "our" geolocation experts are all involved in the draft, thus we need an indipended look at it. I also read it, and it is not such a complex specification, thus if you do that (by Aug 15th) it will be ok.
> 
> 
> > > Cheers,
>> 
>>

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 29 Jul 2013 15:53:28 +0200 (CEST)

> I'm on the road until the 10th, and then in jet lag hell. Can I have one 

the LC already ends 2 weeks earlier (we are in one of the late arrival 
cases we ar trying to avoid happening)... and it may go on IESG desk 
around August 18th... (I'm also on vacation with not so good connectivity)

Unless there is someone else available (volunteers?) we should really have 
it by Aug 15th in order to be useful to the comments process.

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 29 Jul 2013 15:06:44 +0100

On 29/07/2013 14:53, Claudio Allocchio wrote:
> Unless there is someone else available (volunteers?) we should really 
> have it by Aug 15th in order to be useful to the comments process.

I might owe Martin and Mark some favours, so I am happy to review the 
document :-).

>>>> Happy to have a stab at it, but it might take a little while (I'm 
>>>> on the road) and the results may be underwhelming.
>>>
>>> draft, thus we need an indipended look at it. I also read it, and it 
>>> is not such a complex specification, thus if you do that (by Aug 
>>> 15th) it will be ok.
>>>
>>>
>>>>> Cheers,
>>>>
>>>>

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 29 Jul 2013 16:13:39 +0200 (CEST)

Hi all,

let's see if http://trac.tools.ietf.org/area/app/trac/wiki/tracker now 
tracks correctly the agred assignements :-)

(please check!)

I still do not have confirm from Mark because he may not have enough time 
(and it's another "late" review case, thus it was really a short notice).

Jari's message to all WG chairs and IETF has arrived, thus hopefully we 
can start avoinding this late arrival problem better.

Thanks for your understanding meanwhile ;-)

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 29 Jul 2013 16:16:04 +0200 (CEST)

> I might owe Martin and Mark some favours, so I am happy to review the 

ok Alexey!

thanks indeed!

> draft-ietf-geopriv-relative-location-06 due date: August 15th 
> 2013 (LC ends before, but this is to allow some more time)

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Jul 2013 16:27:04 +0200

Thanks very much!

On Jul 29, 2013, at 4:16 PM, Claudio Allocchio <[email-masked]> wrote:

> 
>> I might owe Martin and Mark some favours, so I am happy to review the document :-).
> 
> ok Alexey!
> 
> thanks indeed!
> 
>> draft-ietf-geopriv-relative-location-06 due date: August 15th 2013 (LC ends before, but this is to allow some more time)
>