Subject: Re: [appsdir] Request for early review of draft-ietf-core-coap-13.txt

From: SM <[email-masked]>
Date: Fri, 07 Dec 2012 14:19:22 -0800

Hi Tobias,

Carsten asked for an early review of draft-ietf-core-coap-13.  Would 
you be able to do it by December 21?

Thanks,
-sm

---

From: Tobias Gondrom <[email-masked]>
Date: Tue, 11 Dec 2012 19:56:16 +0800

> you be able to do it by December 21?

Hi SM,
this I-D is very interesting, but quite extensive and honestly don't 
feel totally comfortable handling the large scope of it; if possible I 
would prefer to have a week longer, so I could work through it over the 
holidays. Would Dec-29 still be ok?
Or would maybe somebody else be faster and interested?

Thanks and sorry for the delay, Tobias

---

From: SM <[email-masked]>
Date: Tue, 11 Dec 2012 05:32:45 -0800

Hi Tobias,
At 03:56 11-12-2012, Tobias Gondrom wrote:
>feel totally comfortable handling the large scope of it; if possible 
>I would prefer to have a week longer, so I could work through it 
>over the holidays. Would Dec-29 still be ok?

As Carsten made the request extending the date to December 29 is his 
call.  I am ok with it if he agrees.

I am not comfortable asking you to work through the holidays.  As the 
draft is quite lengthy maybe the review could be a combined effort of 
two reviewers.  If anyone would like to help out, please drop me a 
note.  Alternately, I'll have to find someone else who is faster and 
interested.  Let's see if anyone steps forward first.

Best regards,
-sm

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 11 Dec 2012 14:52:50 +0100

On Dec 11, 2012, at 14:32, SM <[email-masked]> wrote:

>> this I-D is very interesting, but quite extensive and honestly don't feel totally comfortable handling the large scope of it; if possible I would prefer to have a week longer, so I could work through it over the holidays. Would Dec-29 still be ok?
> As Carsten made the request extending the date to December 29 is his call.  I am ok with it if he agrees.

Of course, I would like it yesterday :-), but getting a good review this year would be great.
The optimal result would be to have it in time for the WGLC comment processing.
The WGLC closes on Dec 21, 23:59Z.  (And, yes, the authors are planning to spend some holiday time on this...
But I agree this is different from asking reviewers to do this.)

> I am not comfortable asking you to work through the holidays.  As the draft is quite lengthy maybe the review could be a combined effort of two reviewers.  If anyone would like to help out, please drop me a note.  Alternately, I'll have to find someone else who is faster and interested.  Let's see if anyone steps forward first.

This draft is meant to interoperate with an HTTP world, and to solve, in a constrained world, a subset of the problem HTTP solves.  So those who are familiar with how HTTP (1.1) has evolved recently probably have the easiest time reviewing it from an appsdir perspective.  While I also have requested a separate secdir review, a healthy amount of apps-centric security thinking will help with the security related parts.  So, yes, two reviewers that can maybe each focus on one of these two angles would be perfect.

Grüße, Carsten

---

From: Tobias Gondrom <[email-masked]>
Date: Tue, 11 Dec 2012 23:05:43 +0800

Yes, the scope of this I-D is fairly broad. Plus lengthy. That is indeed 
part of my concern.
So if a second volunteer would be open to join, that might indeed be a 
good thing for this I-D.

Honestly, it will be extremely difficult for me to find enough time 
during my normal work days before Dec-21, as the last days before 
Christmas seem to be more crazy busy.... So actually to work on it 
during my holidays is rather better for me, like probably also for the 
authors. So I have to ask either for extension or a replacement by 
someone faster than me.

Best regards, Tobias

Ps.: I definitely can offer the "apps-centric security" review bits.... ;-)

---

From: SM <[email-masked]>
Date: Tue, 11 Dec 2012 11:53:06 -0800

Hi Tobias,
At 07:05 11-12-2012, Tobias Gondrom wrote:
>So if a second volunteer would be open to join, that might indeed be 
>a good thing for this I-D.

I'll leave this open as someone might step forward to help.

>during my holidays is rather better for me, like probably also for 
>the authors. So I have to ask either for extension or a replacement 
>by someone faster than me.

I am not sure whether anyone would be faster as the mailing list has 
been quiet.  Let's set December 29 as the deadline.

>Ps.: I definitely can offer the "apps-centric security" review bits.... ;-)

You fit the profile of the ideal reviewer for this assignment. :-)

Best regards,
-sm