Subject: Re: [Anima-bootstrap] [Anima] Concise version of BRSKI

From: Toerless Eckert <[email-masked]>
Date: Tue, 23 May 2017 16:28:24 +0200

It is quite frustrating to see the bootstrap draft be handled in a way that is impossible
to track:

- it would have been better not to crearte anothrer branch that you can only be aware 
  of by having seen this email
- If you use a new branch, it would be great if you would have updated the IETF anima bootstrap wiki page
  with this information.
- for the sake of the non-git experts amongst us, it would be great to also indicate some
  command how to retrieve this branch. I for once tried:

  git clone -b concise https://github.com/anima-wg/anima-bootstrap

  and that totally did not work.
  So as of right now i am lost in how i should review this version of the document.

Toerless

On Tue, Apr 18, 2017 at 05:07:18PM +0000, Max Pritikin (pritikin) wrote:
> 
> Peter,
> 
> The current text is wordy and repetitive and says things more than once <grin>. Primary focus is to remove repetitive text, tighten remaining text, and consolidate normative statements. 
> 
> As an initial example the -05 draft has 3 main sections:
> 	architectural overview
> 	functional overview (contains design considerations discussions)
> 	protocol details
> The initial ???concise??? branch commit moves the functional overview to the appendix. Subsequent commits are resolving normative texts that were in there by moving needed bits back into the protocol discussion. You can follow along via the git repository here:
> 	https://github.com/anima-wg/anima-bootstrap/compare/concise
> 
> There was a comment that the design considerations are useful and might be appropriate to keep here or in another document. At the moment I don???t have a formulated position on that.  
> 
> - max
> 
> > On Apr 18, 2017, at 3:27 AM, peter van der Stok <[email-masked]> wrote:
> > 
> > Hi Max,
> > 
> > excellent idea. I looked at the present version, and there is still a lot of text.
> > Where in the text do you want to reduce more? What is the end-objective?
> > And will this become the final document, or is it a study that will be used later for editing the final document?
> > 
> > Peter
> > 
> > Max Pritikin (pritikin) schreef op 2017-04-15 00:34:
> >> For those of you tracking the git repository please note the existence
> >> of a new branch. As warned I???m significantly reducing the text. This
> >> work is going on in the branch ???concise???.
> >> _______________________________________________
> >> Anima mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/anima
> 
> _______________________________________________
> Anima-bootstrap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima-bootstrap

-- 
---
[email-masked]

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Tue, 23 May 2017 16:30:39 +0000

> On May 23, 2017, at 8:28 AM, Toerless Eckert <[email-masked]> wrote:
> 

As previously requested this thread was sent to the anima working group mailing list rather than the now deprecated bootstrap mailer. Not sure how else to communicate status. 

The up to date document is available via the github repository. This is in alignment with multiple conversations at ietf and was the subject of a BoF at the Chicago IETF. If you have concerns about how git might work within a working group process flow i’ll bet the authors of https://tools.ietf.org/html/draft-thomson-github-bcp-00 or would be interested in the feedback. I suggest raising your concerns on the ietf-and-github mailing list to ensure they’re addressed as part of that broader effort. 

>  git clone -b concise https://github.com/anima-wg/anima-bootstrap

https://github.com/anima-wg/anima-bootstrap includes a dropdown to select the branch if you just want to look at the specific files. Using this for example the pre06 version from the concise branch is available here:
	https://github.com/anima-wg/anima-bootstrap/blob/concise/dtbootstrap-anima-keyinfra-06.txt 
One way to determine which branch has the most activity is to look here:
	https://github.com/anima-wg/anima-bootstrap/branches/active

>  and that totally did not work.

Using -b worked for me. Not sure what you did wrong then. 

>  So as of right now i am lost in how i should review this version of the document.

Thanks for joining the meeting today and voicing your concerns. To help we’ll push the 06 version of the doc to give you a better reference for generating feedback. 

- max

---

From: peter van der Stok <[email-masked]>
Date: Wed, 24 May 2017 08:52:37 +0200

Hi Max,

> 
> Thanks for joining the meeting today and voicing your concerns. To
> help we’ll push the 06 version of the doc to give you a better
> reference for generating feedback.
> 
> - max

I'm looking forward to that version. I did like the lay-out of -06pre.
Can you make sure that all terminology is consistent, like circuit 
proxy, join proxy, proxy; join registrar, domain registrar, cloud 
registrar, and others. (also in the figures)
If they are different concepts, please specify their differences.

many thanks,

peter