Subject: [Anima-bootstrap] CoAP mandatory?

From: "Liubing (Leo)" <[email-masked]>
Date: Wed, 4 Jan 2017 09:35:16 +0000

Hi Dear all,

The 04 draft has an editor note:

“ [[EDNOTE: The
   choice of CoAP as the mandatory to implement protocol rather than
   HTTP maximizes code reuse on the smallest of devices.  Unfortunately
   this means this document will have to include the EST over CoAP
   details as additional sections.  The alternative is to make 'HTTPS
   proxy' method the mandatory to implement and provide a less friendly
   environment for the smallest of devices.  This is a decision we'll
   have to see addressed by the broader team.]]
”
Does this open question already have a final conclusion?
Thanks.

Best regards,
Bing

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 10 Jan 2017 01:11:48 +0000

Hi Bing,
I can’t answer your question on behalf of the BRSKI authors, but I wanted to share that we are starting a new draft to describe how BRSKI’s section 5.7.5 (ESToCOAP) will be done. We hope to get it adopted in ACE WG.
Regards,
Panos

From: Anima-bootstrap [mailto:[email-masked]] On Behalf Of Liubing (Leo)
Sent: Wednesday, January 04, 2017 4:35 AM
To: [email-masked]
Subject: [Anima-bootstrap] CoAP mandatory?

Hi Dear all,

“ [[EDNOTE: The

Best regards,
Bing

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 12 Jan 2017 03:10:06 +0000

Hi Panos,

Thanks for your response.

So I guess once the new draft is adopted, BRSKI will choose the CoAP as mandatory, right?

Best regards,
Bing

From: Panos Kampanakis (pkampana) [mailto:[email-masked]]
Sent: Tuesday, January 10, 2017 9:12 AM
To: Liubing (Leo); [email-masked]
Cc: peter van der Stok; Kumar, Sandeep
Subject: RE: CoAP mandatory?

Hi Bing,

From: Anima-bootstrap [mailto:[email-masked]] On Behalf Of Liubing (Leo)
Sent: Wednesday, January 04, 2017 4:35 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Anima-bootstrap] CoAP mandatory?

Hi Dear all,

“ [[EDNOTE: The

Best regards,
Bing