Subject: Fwd: Regarding Agentx

From: Randy Presuhn <[email-masked]>
Date: Tue, 22 Aug 2000 13:21:20 -0700 (PDT)

Hi -

I'm forwarding a non-susbcriber post to the agentx working group
mailing list.  Since this person hasn't bothered to subscribe,
and due to the nature of the query, I suggest responding privately.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id XAA20501
> 	for <[email-masked]>; Mon, 21 Aug 2000 23:09:53 -0700 (PDT)
> Received: from fw-us-hou1.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.8.6) with SMTP id e7M6A2j03362
> 	for <[email-masked]>; Tue, 22 Aug 2000 01:10:02 -0500 (CDT)
> Received: from pspl.co.in (lords.intranet.pspl.co.in [192.168.1.14])
> 	by mail2.pspl.co.in (8.9.3/8.9.3) with ESMTP id LAA26573
> 	for <[email-masked]>; Tue, 22 Aug 2000 11:43:50 +0530
> Message-ID: <[email-masked]>
> Date: Tue, 22 Aug 2000 11:44:57 +0530
> From: Ajay Sakpal <[email-masked]>
> X-Mailer: Mozilla 4.72 [en] (WinNT; I)
> X-Accept-Language: en
> MIME-Version: 1.0
> To: [email-masked]
> Subject: Regarding Agentx
> Content-Type: multipart/mixed;
>  boundary="------------0E598FECB1C0AB32D8DC2ECA"
> 
> This is a multi-part message in MIME format.
> --------------0E598FECB1C0AB32D8DC2ECA
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
> Dear sir/madam,
>             I have visited your site and read specifications about
>  AgentX RFC 2741 , Can you please brief me about the
>  platforms on which it is portable,  and what are the licence
>  terms.
> Regards
> Ajay
> 
> 
> --------------0E598FECB1C0AB32D8DC2ECA
> Content-Type: text/x-vcard; charset=us-ascii;
>  name="ajay.vcf"
> Content-Transfer-Encoding: 7bit
> Content-Description: Card for Ajay Sakpal
> Content-Disposition: attachment;
>  filename="ajay.vcf"
> 
> begin:vcard 
> n:Sakpal;Ajay 
> tel;work:Ext: 286
> x-mozilla-html:FALSE
> adr:;;;;;;
> version:2.1
> email;internet:[email-masked]
> fn:Ajay
> end:vcard
> 
> --------------0E598FECB1C0AB32D8DC2ECA--
> 
>

---

From: Daris A Nevil <[email-masked]>
Date: Wed, 23 Aug 2000 09:23:53 -0500

Randy, et al,

Since there is not very much discussion on this news list I wanted to
take
just a moment and describe the success we have had with the CMU AgentX
implementation. We are using the CMU package under both an Intel and an
embedded PowerPC platform on Linux.  It works quite well.  We did have
to fix a bug that caused the snmpd program to crash (see patch below).
We also added code that allows for disabling the automatic subagent
shutdown on accumulated lost packets (our particular proxy agent
protocol
responds very slowly).

All in all I would describe the CMU AgentX package, along with the
CMU SNMP package, as a well written piece of code.  We would be
interested in hearing other people's success/failures with CMU
or other AgentX packages.

Regards,
Daris Nevil

BTW, the inclosed patch should be run from the agentx/snmpd subdir.

-- 
Daris A Nevil
Simple Network Magic Corporation
401 Kentucky Lane
McKinney, TX 75069
214-793-7757
[email-masked]
www.snmc.com
quickstack.com
qslinux.org

---

From: Bob Natale <[email-masked]>
Date: Wed, 23 Aug 2000 11:47:28 -0400

At 8/23/2000:10:23 AM, Daris A Nevil wrote:

Hi Daris,

>take just a moment and describe the success we have had with the CMU AgentX
>implementation.

Thanks...this is exactly the kind of posting that's needed on
this list at this time...i.e., those concerned with implementation
and deployment issues...not to the exclusion, of course, of any
technical questions about the AgentX protocol or MIB, or the
two RFCs, or new work, or administration of the WG.

>We are using the CMU package

Can you provide a pointer to the current CMU code...I don't
recall having heard anything new since Matt White left CMU
some time ago.

>under both an Intel and an embedded PowerPC platform on Linux.

Is that Linux on both platforms (can you also let us know
the particular flavor/version of Linux you are using)?

>It works quite well.

Excellent news.

>We did have to fix a bug that caused the snmpd program to crash
>(see patch below).

Thanks...have you tried to get this back to the CMU
folks (of course, let's hope they are also monitoring
this channel!).

>shutdown on accumulated lost packets

And that's in the patch too...?

>(our particular proxy agent protocol responds very slowly).

I assume you are saying that this slowness is not inherently
related to AgentX itself?

>CMU SNMP package, as a well written piece of code.

Excellent.

>We would be interested in hearing other people's success/failures
>with CMU or other AgentX packages.

Do you monitor the UCD-SNMP work (an off-shoot from an older
CMU-SNMP release)?  Their list has had a fair amount of traffic
re the UCD-SNMP AgentX implementation (developed independently
of the CMU-SNMP AgentX work, AFAIK) in recent months...?

>BTW, the inclosed patch should be run from the agentx/snmpd subdir.

Ok...again, thanks a million for posting this info...I may
ask you for a more formal (but only slightly so!) report
in the near future.

Cordially,

BobN
------------ ISO 9001 Registered Quality Supplier -----------
Bob Natale         | ACE*COMM              | 301-721-3000 [v]
Dir, Net Mgmt Prod | 704 Quince Orchard Rd | 301-721-3001 [f]
[email-masked]| Gaithersburg MD 20878 | www.acecomm.com
------------- Free downloads at www.winsnmp.com -------------

---

From: Daris A Nevil <[email-masked]>
Date: Wed, 23 Aug 2000 11:11:49 -0500

Hi Bob,

Thanks for your enthusiasm.  I was beginning to think that I am the only
one excited about AgentX.

> recall having heard anything new since Matt White left CMU

The version we started with was downloaded from:

	http://www.net.cmu.edu/groups/netdev/agentx/

> the particular flavor/version of Linux you are using)?

We are using Redhad 6.2 for our Intel platform, and QSLinux
for our MPC850 embedded PowerPC platform (see http://qslinux.org
and ftp://qslinux.org).

> folks (of course, let's hope they are also monitoring

I forwarded the bug fix to [email-masked]

> And that's in the patch too...?

Yes.

> related to AgentX itself?

You are correct in that it has nothing to do with AgentX. Our
subagent collects data across a slow async bus, so the snmpd
program sometimes times out the subagent.  The original code
always shuts down the subagent after 3 timed out AgentX packets
(or whatever AgentxSubagmentMaxTimeouts was set to in /etc/snmpd.conf).
Our modified code lets us disable this "feature" by setting
AgentxSubagentMaxTimeouts and AgentxSubagentMaxParseErrors to zero.

> of the CMU-SNMP AgentX work, AFAIK) in recent months...?

We were not aware of the UCD package when we started working with
the CMU package.  We were also drawn to the CMU package because of
earlier experience with the CMU SNMP package, which we are also
using.

One thing that the AgentX package needs is a thoroughly cleaned and
updated documentation package.  There are comments in the release
notes that say things like:

* Set is not supported
* TCP is not supported
* Getbulk is not supported

From what we have seen all of these features are supported by the
current version of CMU AgentX.  It appears to be complete.

---

From: Kevin Lingle <[email-masked]>
Date: Wed, 23 Aug 2000 18:24:54 -0400

Anyone have good, bad, ugly experience using ucd-snmp agentx?

kevin
Daris A Nevil wrote:
>   ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>                        Name: snmpd_snmc.patch
>    snmpd_snmc.patch    Type: application/x-unknown-content-type-patch_auto_file
>                    Encoding: base64

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Kevin R. Lingle       919.392.2029
 checkout: http://wwwin-eng.cisco.com/Eng/IOS/SNMP_WWW/mib-police.html
 Sometimes I think I understand everything, then I regain consciousness.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

---

From: Kevin Lingle <[email-masked]>
Date: Thu, 24 Aug 2000 11:44:29 -0400

Daris A Nevil wrote:

>         http://www.net.cmu.edu/groups/netdev/agentx/

So I take that to mean you downloaded ver 1.4.1 ??

I have been evaluating a few extensible agents and looked at CMU
as well as UCD-SNMP.   When I browsed the cmu website I notice
that nothing seemed to be updated in a long time.  I sent some
email asking about current status and development activities.
About two weeks later I got the following response:

---- email begin
From: "Russell J. Yount" <[email-masked]>                07/28/00 12:30
Subject: CMU software releases
To: [email-masked]

kevin,
        At the current time we have no developers working on it.
We have lost a greate deal of staff over recent years to outside companies,
and as such have drop development of this.

-Russ

Russell J. Yount <[email-masked]>
Manager of Network Development
Carnegie Mellon University
(412) 268-8391

**
** Initial Query From [email-masked]
** Thu, 13 Jul 2000 16:55:32 -0400
** To: [email-masked]
**

Hi,

Your web page http://www.net.cmu.edu/groups/netdev/snmpd.html
indicates that SET support is not available in your extensible
snmp agent.  It further indicates that support is planned near term.

Is set support available yet?

All of your pages and your release history date back to 1998.
Is this project even active anymore??  Have there truely been
no updates to code or web since 1998?!?!?

kevin
---- email end

Further if you look at the README from UCD-SNMP ver 4.1.2 you see
the following:

   "My snmp code, based on the CMU 2.1.2.1 version with a lot of
    additions.  It is fully extensible."

Thus, I abandoned any consideration of CMU code and am opting for
UCD-SNMP.

While I'm glad to hear of the successes you've had, I'm wondering
why you are even using the CMU code downloaded from their website
as it seems to be quite behind the times?

Kevin

---

From: Matt White <[email-masked]>
Date: Mon, 28 Aug 2000 10:43:29 -0400 (EDT)

> current version of CMU AgentX.  It appears to be complete.

Yeah, I do believe I implemented SET and GETBULK before I left.  I don't
think I did agent capabilities and I know TCP is not supported by the
subagent library (though the master agent does have the ability to accept
TCP AgentX connections).

-Matt