Subject: RE: Fwd: Regarding Agentx

From: "Ayers, Mike" <[email-masked]>
Date: Thu, 24 Aug 2000 12:05:20 -0500

This issue also crossed the UCD-SNMP mailing list, where one of the
CMU AgentX developers also pointed out that there is currently no new
development.  However, that thread had been started by someone who had used
CMU AgentX successfully, and it was agreed that within certain parameters,
CMU was useable.  If there is interest, I can root through my archives and
post the thread.

/|/|ike

> -----Original Message-----
> From: Kevin Lingle [mailto:[email-masked]]
> Sent: Thursday, August 24, 2000 8:44 AM
> To: Daris A Nevil
> Cc: Bob Natale; [email-masked]
> Subject: Re: Fwd: Regarding Agentx
> 
> 
> 
> Daris A Nevil wrote:
> >
> 
> > The version we started with was downloaded from:
> > 
> >         http://www.net.cmu.edu/groups/netdev/agentx/
> 
> So I take that to mean you downloaded ver 1.4.1 ??
> 
> I have been evaluating a few extensible agents and looked at CMU
> as well as UCD-SNMP.   When I browsed the cmu website I notice
> that nothing seemed to be updated in a long time.  I sent some
> email asking about current status and development activities.
> About two weeks later I got the following response:
> 
> ---- email begin
> From: "Russell J. Yount" <[email-masked]>                
> 07/28/00 12:30
> Subject: CMU software releases
> To: [email-masked]
> 
> kevin,
>         At the current time we have no developers working on it.
> We have lost a greate deal of staff over recent years to 
> outside companies,
> and as such have drop development of this.
> 
> -Russ
> 
> Russell J. Yount <[email-masked]>
> Manager of Network Development
> Carnegie Mellon University
> (412) 268-8391
> 
> **
> ** Initial Query From [email-masked]
> ** Thu, 13 Jul 2000 16:55:32 -0400
> ** To: [email-masked]
> **
> 
> Hi,
> 
> Your web page http://www.net.cmu.edu/groups/netdev/snmpd.html
> indicates that SET support is not available in your extensible
> snmp agent.  It further indicates that support is planned near term.
> 
> Is set support available yet?
> 
> All of your pages and your release history date back to 1998.
> Is this project even active anymore??  Have there truely been
> no updates to code or web since 1998?!?!?
> 
> kevin
> ---- email end
> 
> Further if you look at the README from UCD-SNMP ver 4.1.2 you see
> the following:
> 
>    "My snmp code, based on the CMU 2.1.2.1 version with a lot of
>     additions.  It is fully extensible."
> 
> Thus, I abandoned any consideration of CMU code and am opting for
> UCD-SNMP.
> 
> While I'm glad to hear of the successes you've had, I'm wondering
> why you are even using the CMU code downloaded from their website
> as it seems to be quite behind the times?
> 
> Kevin
> -- 
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> =-=-=-=-=
>  Kevin R. Lingle       919.392.2029
>  checkout: http://wwwin-eng.cisco.com/Eng/IOS/SNMP_WWW/mib-police.html
>  Sometimes I think I understand everything, then I regain 
> consciousness.
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> =-=-=-=-=
>

---

From: Kevin Lingle <[email-masked]>
Date: Thu, 24 Aug 2000 13:34:30 -0400

i'd be interested in at least a summary of what "within certain parameters" means.

kevin

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Kevin R. Lingle       919.392.2029
 checkout: http://wwwin-eng.cisco.com/Eng/IOS/SNMP_WWW/mib-police.html
 Sometimes I think I understand everything, then I regain consciousness.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

---

From: Matt White <[email-masked]>
Date: Mon, 28 Aug 2000 11:46:43 -0400 (EDT)

> i'd be interested in at least a summary of what "within certain parameters" means.

Off the top of my head:

*  Is CMU feature complete for your needs?
*  Do you need a support infrastructure?  UCD has pretty good support
   lists.  CMU has pretty much nothing besides what you can wheedle out of
   me ;).  
*  Is size important?  CMU is slimmer than UCD.  
*  Are you building subagents from scratch or are you instrumenting
   already existing code?  CMU was built with instrumentation of already
   existing code in mind.  UCD also works for this purpose, but Wes keeps
   saying that he thinks the CMU package might be better for that and so
   I'm starting to believe him. 

-Matt

---

From: Matt White <[email-masked]>
Date: Mon, 28 Aug 2000 10:51:10 -0400 (EDT)

I'll pipe in and say that, even though there is no current development,
that I'm relatively happy with the code I originally wrote.  It's small
and appears understandable by mere mortals.  There are several things I
would change internally, but aren't there always?

Matt White
Ericsson IP Infrastructure