Subject: Re: Query regarding Agent-X

From: Randy Presuhn <[email-masked]>
Date: Tue, 29 Aug 2000 11:34:44 -0700 (PDT)

Hi -

I'm forwarding your post to the agentx working group mailing
list.

I've unblocked mailcity.com here, so you should now be able to
subscribe, unless it's also being blocked by our firewalls.
(In the long run, you might be better off subscribing from
another domain; I suspect some of the mailing list subscribers'
systems will also bounce traffic from mailcity.com addresses.)

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

> From [email-masked] Tue Aug 29 10:38:47 PDT 2000
> To: [email-masked]
> Date: Tue, 29 Aug 2000 10:34:33 -0700
> From: "Venkatesh B" <[email-masked]>
> Message-ID: <[email-masked]>
> X-Sent-Mail: off
> Reply-To: [email-masked]
> X-Expiredinmiddle: true
> Subject: Query regarding Agent-X
> X-Sender-Ip: 216.85.115.83
> Organization: Lycos Communications  (http://comm.lycos.com:80)
> Content-Language: en
> 
> Hello Mr Presuhn,
>      I had a query regarding the use of Agent-X for one of my assignments. I tried to subscribe to AgentX mailing group, but failed in my attempt(probably because of my mailcity account). I would be very grateful if you could answer my question(please see the text below), or provide indicators to the solution.
> 
> Thanks for your precious time,
> With best regards,
> Venkatesh Babu.
> 
> I have a bunch of devices of different types. A few of these already have SNMP agent implementations. I have to provide SNMP support for the rest. Each of these devices is IP_Addressable by itself.
> 
> I am in the process of integrating these devices into a single container. At this point I have the option of giving a integrated management view of these devices and I would like to do it.
> 
> Since my application is a multi-component system that requires management(preferably integrated), I thought Agentx might help. Does my application warrant the use of AgentX. I ask this question because 
> 
> 1)these devices even after integration, will not be a single IP_Addressable entity but will each have one for itself.
> 2)few of these already have agents written for them and it will not be possible for me to rewrite their agents. I can write sub-agents for a couple of components which do not have SNMP agents in them.
> 
> If Agentx is a right way, how do I go about tackling the components that already have agents written for them(how do I make them subagents). 
> If Agentx is not the right approach, what other alternatives do I have using which I can provide this integrated management view.
> 
> 
> 
> 
> Get your FrEE Email and Voicemail at Lycos Communications at
            ^
           changed to get past spam filter

> http://comm.lycos.com

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 30 Aug 2000 15:48:59 -0700 (PDT)

Hi -

> Subject: Query regarding Agent-X
...
> If Agentx is not the right approach, what other alternatives do I have using which I can provide this integrated management view.
...

It really depends on the extent to which you need to manage it
as though it were a single system.  For example, if these IP-
addressable entities are cards in a larger box, then agentx
may be a very reasonable solution.  The problem of integrating
legacy SNMP agents in such a configuration is tricky, since
all the complications of proxies can arise, and a meaningful
access control policy may be precluded by security holes in
those legacy agents.

For more background on the motivations for AgentX, please see
http://www.simple-times.org/pub/simple-times/issues/4-2.html

It might be worth your while to take a look at some of the
related work going on in the IETF in these working groups:
http://www.ietf.org/html.charters/disman-charter.html
http://www.ietf.org/html.charters/snmpconf-charter.html